View Full Version : Change Terminal Resolution

1st February 2007, 04:17 AM
Is there any way to change the resolution of the terminal? I'm talking about the CLI interface that you work in before X starts. I'm having a very hard time trying to search for this topic since 99.9% of screen resolution questions refer to the GUI. Thanks.

1st February 2007, 04:32 AM
Yes, it is very easy. You must add a vga= line to the kernel line in /etc/boot/grub.conf
For some guidelines:
Documentation/kernel-parameters.txt#1652 (http://www.mjmwired.net/kernel/Documentation/kernel-parameters.txt#1652)
Documentation/fb/vesafb.txt#29 (http://www.mjmwired.net/kernel/Documentation/fb/vesafb.txt#29)
Documentation/svga.txt (http://www.mjmwired.net/kernel/Documentation/svga.txt)

1st February 2007, 04:44 AM
The topic you want to search for is "linux framebuffer". There's a How-to (http://tldp.org/HOWTO/Framebuffer-HOWTO.html) for it. You can use the generic VESA framebuffer (which mjmwired mentioned) that all modern video cards support, or you can use a framebuffer specific to your video card (which is a better choice in general).

For instance, I have an ATI Radeon video card, and I use the radeonfb framebuffer to get a 1024x768 console with 8-bit color depth with a 76MHz vertical refresh rate, using a line like this in my /boot/grub/grub.conf in FC6:

kernel /vmlinuz-2.6.19 ro root=/dev/hdb2 video=radeonfb:1024x768-8@76
I compiled support for the Radeon framebuffer directly into my kernel (i.e. not as a module).
There are framebuffers for Nvidia and other video cards. One cool benefit of using a console framebuffer (in addition to the nice Tux bootup logo :) ) is you can view graphics files in console mode, and even watch TV if you have a TV tuner card.

1st February 2007, 07:19 AM
I'm having a hard time trying to get this figured out. Is there anyway i could get an example with the vga=? Also, my monitor is 1440x900 (1024x768 is all I want for the CLI) and i just want to make sure that this wont effect the x servers resolution. Thanks.

1st February 2007, 04:23 PM
Try vga=791. To see all the options, use vga=ask, just like the first link that mjmwired listed says.
The framebuffer resolution is unrelated to the X server resolution.