PDA

View Full Version : Xerox Phaser Driver



dmbrown00
1st February 2007, 02:46 AM
I got a Xerox Phaser 6110/B printer. Installing the driver ./setup.sh does nothing. I tried linux32 ./setup.sh, which output
/root/.setup5910: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory
I think I need 32-bit GTK libs. What do I do?

Seve
1st February 2007, 02:50 AM
Hello:
Assuming you are running FC6 ?
You need to install gtk+
yum install gtk+*

Seve

dmbrown00
1st February 2007, 03:14 AM
No luck:

Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

Seve
1st February 2007, 03:20 AM
Hello:
Are you running FC6 and if so are you using the 32 or 64bit version?
Also, log in as root using
su -
yourpassword
and type and post the output
yum list | grep -F gtk+

Seve

dmbrown00
1st February 2007, 03:27 AM
gtk+.x86_64 1:1.2.10-55.fc6 installed
gtk+-devel.x86_64 1:1.2.10-55.fc6 installed
gtk+extra.x86_64 2.1.1-3.fc6 installed
gtk+extra-devel.x86_64 2.1.1-3.fc6 installed
I think it wants the 32-bit. How would I install them?

Seve
1st February 2007, 03:37 AM
gtk+.x86_64 1:1.2.10-55.fc6 installed
gtk+-devel.x86_64 1:1.2.10-55.fc6 installed
gtk+extra.x86_64 2.1.1-3.fc6 installed
gtk+extra-devel.x86_64 2.1.1-3.fc6 installed
I think it wants the 32-bit. How would I install them?
Hello:
You need to download them from here :
http://download.fedora.redhat.com/pub/fedora/linux/extras/6/i386/repodata/repoview/G.group.html

Save them in one directory......say /home/username/newdir
Then once they are downloaded, log in as root using
su -
yourpassword
and
cd /home/username/newdir
and run
rpm -ivh * .rpm

and you should be good to go
Seve

mwette
1st February 2007, 03:53 AM
I think you can do this directly w/ yum. If you read the man page ("man yum")
under the "MISC" header they indicate that you can use name.arch. So you
could try


# yum install gtk+.i386

Seve
1st February 2007, 03:55 AM
I think you can do this directly w/ yum. If you read the man page ("man yum")
under the "MISC" header they indicate that you can use name.arch. So you
could try


# yum install gtk+.i386

Hello:
Good point :)
And much easier I might add. :cool:

Seve

dmbrown00
1st February 2007, 04:03 AM
The yum doesn't work, but manual rpms does. Need to --force to install both 64- and 32-bits.

Seve
1st February 2007, 04:09 AM
The yum doesn't work, but manual rpms does. Need to --force to install both 64- and 32-bits.
Hello:
Sorry to bother you, however, does that mean you were able to successfully install you Phaser drivers?

Seve

dmbrown00
1st February 2007, 04:15 AM
Yes. :) To anyone else with a Phaser: make sure in linux-config (as root) go into Options and put in root password so it can talk to cups.

Seve
1st February 2007, 04:17 AM
Yes. :) To anyone else with a Phaser: make sure in linux-config (as root) go into Options and put in root password so it can talk to cups.
Hello:
I have a Phaser8400, so I was just curious as I am not running 64bit.
Xerox provides excellent support for linux.

Enjoy :)

Seve