PDA

View Full Version : help with hard disk



sensss
1st February 2007, 12:09 AM
I got a hard disk of 20gb and i used several distro's of linux and all of them said that it has 2gb..i've formated it a few times but still 2 gb it said :( can anyone please help me :confused:

pyxel
1st February 2007, 12:28 AM
Hello,

Please show us the output from fdisk -l /dev/hdX on the specific disk drive. For complete formating of drive you can try it with dd command like this: dd if=/dev/zero of=/dev/hdX bs=1024 (be cureful with this command).

sensss
1st February 2007, 12:31 AM
it says:

[root@rds ~]# fdisk -l /dev/hdd

Disk /dev/hdd: 2111 MB, 2111864832 bytes
255 heads, 63 sectors/track, 256 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdd1 * 1 256 2056288+ 8e Linux LVM


and the drive has 20gb, not 2

Brian1
1st February 2007, 12:54 AM
Does seem odd on the drive. Post brand and model number of the drive.

Brian

sensss
1st February 2007, 01:02 AM
It's a Western Digital Quantum Fireball Lct20 20 GB

Brian1
1st February 2007, 02:32 AM
Quantum is now owned by Maxtor from last I known.
If you multiple the follow 255 heads, 63 sectors/track, 256 cylinders and then multiple that by 512 you get about 2gig.

Now is the machine you have the drive connected too fairly old?
If so it may be a bios issue. Check this links from maxtor.
https://maxtor.custhelp.com/cgi-bin/maxtor.cfg/php/enduser/olh_adp.php?p_faqid=344&p_sid=Q1NI16ti&p_lva=#
http://www.maxtor.com/portal/site/Maxtor/menuitem.5d2b41d3cef51dfe29dd10a191346068/?channelpath=%2Fen_us%2FSupport%2FProduct+Support% 2FDesktop+Storage%2FMaxtor+Other%2FFireball+lct20

Brian

sensss
1st February 2007, 06:55 AM
in windows it works without any problems so i don't see why it doesn't work in linux

sensss
1st February 2007, 09:53 PM
anyway any sugestions?pls

AlexThomson_NZ
1st February 2007, 10:19 PM
Faulty allocation table? Maybe you should try using gparted or something and 'resize' it to 20gigs (might pay to back it up first).

This isn't a FAT16 formatted partition is it which has a 'theoretical' limit of 2gigs? (which windows gets around by hacking the then industry standard- as they do so well)

Brian1
1st February 2007, 11:22 PM
I would partition and format it under windows and use vfat as the filesystem.
Then see how Linux sees it. If it sees 20gig then I would try the blowing the partition and created the LVM which you are wanting. See if it looks correct still and then procede to create the logical partitions within that.

Brian

sensss
1st February 2007, 11:24 PM
well i already done it with the vfat method (it was 20 gb of space) but after linux still detects it as 2gb

Brian1
2nd February 2007, 12:27 AM
Its got me. No idea why one would see 20gig and linux sees 2 gig. This is in left feild if you wish to try is get one of those USB harddrive encloseures to add a harddrive too. Then see what it sees when connected as USB. If still the same it eliminates the IDE controller module. If it sees the full 20gig then I would some issue with the IDE controller and or module to interface to it in the kernel.

Another thought is boot up with a Live CD like Knoppix and see if it sees the full 20gig. If so then one needs to deterimne the difference from your install to the Live CD. Can be as simply as the kernel itself. If Knoppix is using a different kernel then compile that kernel on your machine and boot up with that.

Brian

AlexThomson_NZ
2nd February 2007, 03:04 AM
Well as I said...

Dont use fat, use fat32 (or even better ext3) or you will get your 2gb limit

ajamison
29th April 2007, 07:19 PM
Hello,
I was going to install a second Harddrive into my linux machine and (forgive me if this sounds newbieish but i am used to Windows) I wanted to know if i just want to add it as a second harddrive with its own space not to expand an existing mount point.

In windows as you know all additional Harddrives are mapped to letters (D:,E: ect) I want to essentially do the same thing with linux have an icon on my gnome desktop that links to the Ext hd so i can drag and drop stuff to this location.

What would i need to change in Fedora Core 6 to first have this drive mount when ever the pc boots and to allow it to be 100% accessible by all local users. I want it to be completely read/writable by all local users.

I know with linux drives are mounted inside folders (ie /dev/sda1) but I am such a newb with this kind of linux task and call to the more experienced *nix gurus for help. This would bring me one step closer to getting rid of Windows mwuhahahaha.

giblet1973
29th April 2007, 08:35 PM
sensss - i had one of those drives once, with red hat 8 installed from memory. i had no problems with the capacity. have you tried upgrading the bios on your machine?

ajamison... i'd suggest doing some more research on this subject, or creating your own topic. but anyway... you add your disk, run fdisk on it (if it is ide and your second disk then fdsk /dev/sdb will get you going), create your partitions, run mkfs on the new partitions (eg mkfs.ext3 /dev/sdb1 if you want to format the first partition of the second hard drive using ext3), and then you need to decide if you want new mount points or if you are extending existing mount points. let's say you are creating on primary partition under a new mount, /u01. you'd create a folder /u01, then add an entry to /etc/fstab for /dev/sdb1 which points to /u01. finally you can mount your new filesystem,eg mount /u01. done.