PDA

View Full Version : Beryl 0.20 beta2 update white screen issue



icydog
31st January 2007, 08:54 PM
The Beryl update hit the repos today, but when I run it it just turns my entire display white (well, light gray) until I killall beryl. The only way to get it to work is force beryl to use Copy instead of texture_from_pixmap (beryl --use-copy), which I didn't have to do before. It runs terribly slow this way. Does anybody know how to get texture_from_pixmap working again?

I'm using the nvidia drivers from livna (9746). It worked fine with beryl 0.14.

xeonman9000
31st January 2007, 09:54 PM
I have this problem too, now I can't use KDE because Beryl automatically loads on startup.
Basically, I boot up and the KDE splash screen appears, then after a few seconds, the Beryl splash screen appears (very jerkily) and it fades to white and remains that way. I can rotate the cube using the keyboard, but that too is very jerky, and the cube is entirely white.

icydog
31st January 2007, 10:38 PM
xeonman, I can rotate the cube too and I get the same thing when I do. I use KDE too.

btw, to get beryl into a usable form, run killall beryl (ctrl-alt-f1) and change your startup script to pass --use-copy to beryl. But this is slow.

cdnlilwolf
31st January 2007, 10:44 PM
I get it too. It is not restricted to just KDE. I ran a session in Gnome and had the same problem.

jdeslip
1st February 2007, 08:03 AM
Ya, me too! Has anyone reported this to bugzilla?!? By the way, I am using 64 bit version. What is everyone else with this problem using?

ryptyde
1st February 2007, 12:51 PM
I have the Beryl 0.2.0 beta2 on two computers one a P3, GeForce4 MX 420 and the other a P4, nv6200xx? both boxes are single core cpu's. I have tried them both in Gnome and KDE and they are working nearly the same as before with the exception of the "Super" key to initiate certain functions.

cvbrowne
1st February 2007, 02:30 PM
Posting so that I'll get emailed when someone fixes this... works on my computer at work... but not my computer at home... its' weird though... when I now run the command ps aux | grep beryl

I now see both beryl-manager (normal compared to 0.1.4) and beryl --skip-gl-yield (not normal and not an option I put in)

icydog
1st February 2007, 02:39 PM
I tried many combinations of the options available in beryl-manager... the only workaround is the --use-copy option, but it's so slow i can't watch fullscreen video on an athlon 3000+. --skip-gl-yield or not doesn't make a difference for me.

cvbrowne
1st February 2007, 05:42 PM
Someone in the beryl forums compiled the SVN version and added a repo for it... I installed it and it works flawlessly.... well for a beta.... 0.1.4 was much more stable.

as root... type the command

vi /etc/yum.repos.d/beryl.repo

then paste the following into it.




[beryl]
name=Beryl svn for Fedora Core $releasever - $basearch
baseurl=http://www.saafinternational.com/beryl/repo/RPMS/$basearch/
enabled=1
gpgcheck=0




then run:

yum upgrade

alongwor
1st February 2007, 06:27 PM
I also have the same problem since the update.
Shall try the new repo.
Now this maybe a silly question, but why has a beta version been put in what I thought were the stable repo's?

JSchmitt
1st February 2007, 10:03 PM
I have got the same problem as reported in this thread. But after installing the most recent nvidia driver 1.0-9746 from the nvidia website this problem doesn't cooure anymore.

Best Regards:

Jochen Schmitt

xeonman9000
1st February 2007, 11:02 PM
xeonman, I can rotate the cube too and I get the same thing when I do. I use KDE too.

btw, to get beryl into a usable form, run killall beryl (ctrl-alt-f1) and change your startup script to pass --use-copy to beryl. But this is slow.
When I pressed ctrl alt and f1, The screen goes black and there's a flashing white line, but nothing can be inputted, except ctrl alt delete to restart. How do I stop Beryl booting on startup? I changed the startup script I made, but it still does it. I just want to use KDE, without Beryl.

cvbrowne
1st February 2007, 11:42 PM
Did you try CTRL-ALT-F2 through F6? If not try that first. The other steps are a little long... so try that first

Logik
2nd February 2007, 05:01 AM
i had the same, white beryl screen, problem as well. (FC6/x64/Nvidia)

I tried upgrading to the latest SVN, and it still wasnt working.

Reinstalled my NVIDIA drivers and all is well now.

Anyone know if the SVN releases are worth installing over the official ones?

mpajoh
2nd February 2007, 08:23 PM
i had the same, white beryl screen, problem as well. (FC6/x64/Nvidia)

I tried upgrading to the latest SVN, and it still wasnt working.

Reinstalled my NVIDIA drivers and all is well now.

Anyone know if the SVN releases are worth installing over the official ones?

What drivers did you install, the ones from nvidia site or kmod-nvidia###?

Logik
2nd February 2007, 09:02 PM
What drivers did you install, the ones from nvidia site or kmod-nvidia###?
the x64 .sh script from NVIDIAs site.

xeonman9000
3rd February 2007, 12:33 AM
Did you try CTRL-ALT-F2 through F6? If not try that first. The other steps are a little long... so try that first
None of those work, they all take me to the black screen with the white prompt and no input capabilities.

jdeslip
3rd February 2007, 03:50 AM
I see that beryl weleased 0.2.0 RC1 yesterday. Perhaps this will reach the extras repo soon? I hope it fixes the problem. Also, how come there is a newer version of nvidia driver out than what is in livna repository? Do they not update for each release?

-Jack

bseltzer
3rd February 2007, 07:19 AM
I just now did a "yum list updates" and for the beryl packages, the command returns;

beryl.i386 0.1.99.2-2.fc6 extras
beryl-core.i386 0.1.99.2-2.fc6 extras
beryl-gnome.i386 0.1.99.2-2.fc6 extras
beryl-kde.i386 0.1.99.2-2.fc6 extras
beryl-manager.i386 0.1.99.2-1.fc6 extras
beryl-plugins.i386 0.1.99.2-3.fc6 extras
beryl-settings.i386 0.1.99.2-1.fc6 extras

Is this the version causing the problems? If so, I'm just going to add "beryl*" to my global excludes in /etc/yum.conf until this gets straightened out.

Regards,
Bert

jdeslip
3rd February 2007, 07:56 AM
Yes those are the ones that cause the problem.

mpajoh
3rd February 2007, 02:48 PM
Someone in the beryl forums compiled the SVN version and added a repo for it... I installed it and it works flawlessly.... well for a beta.... 0.1.4 was much more stable.

as root... type the command

vi /etc/yum.repos.d/beryl.repo

then paste the following into it.




[beryl]
name=Beryl svn for Fedora Core $releasever - $basearch
baseurl=http://www.saafinternational.com/beryl/repo/RPMS/$basearch/
enabled=1
gpgcheck=0




then run:

yum upgrade

This SVN version corrected my white screen problem.

bseltzer
3rd February 2007, 05:56 PM
Thing is... the 0.1.4-2 distro is stable and works just fine, thank you. And my FC6 desktop is essentailly an operational platform from which I do at least occassional "real" work. So unless the 0.1.99.2-2 version includes some "must have" enhancements, I'm a bit hard pressed to come up with a good reason to be fooling around with an untested SVN distro.

'Course that's just my take on this particular issue... ;)

Regards,
Bert

mpajoh
3rd February 2007, 09:41 PM
. . .


[beryl]
name=Beryl svn for Fedora Core $releasever - $basearch
baseurl=http://www.saafinternational.com/beryl/repo/RPMS/$basearch/
enabled=1
gpgcheck=0

. . .

There are new SVN file on that URL -- Ver 0.2.0-0.svn.
cvbrowne or anyone else tried these? Do they work?

xeonman9000
4th February 2007, 12:02 AM
Someone in the beryl forums compiled the SVN version and added a repo for it... I installed it and it works flawlessly.... well for a beta.... 0.1.4 was much more stable.

as root... type the command

vi /etc/yum.repos.d/beryl.repo

then paste the following into it.




[beryl]
name=Beryl svn for Fedora Core $releasever - $basearch
baseurl=http://www.saafinternational.com/beryl/repo/RPMS/$basearch/
enabled=1
gpgcheck=0




then run:

yum upgrade
I tried this and got the following:


[root@localhost ~]# yum upgrade
Loading "installonlyn" plugin
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
No Packages marked for Update/Obsoletion

BNiels707
4th February 2007, 03:43 AM
I tried out the new repo suggested by mpajoh after a xorg-server update killed my Beryl performance (using fglrx drivers). Now Beryl won't start, even using "beryl-xgl --use-copy. I just throws the following:

************************************************** ************
* Beryl system compatiblity check *
************************************************** ************

Detected xserver : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension : failed

No composite extension
beryl-xgl: No composite extension

bseltzer
5th February 2007, 05:02 AM
Thing is... the 0.1.4-2 distro is stable and works just fine, thank you. And my FC6 desktop is essentailly an operational platform from which I do at least occassional "real" work. So unless the 0.1.99.2-2 version includes some "must have" enhancements, I'm a bit hard pressed to come up with a good reason to be fooling around with an untested SVN distro.

'Course that's just my take on this particular issue... ;)

Regards,
Bert

Or even a beta, for that matter. Has anyone submitted a bug report to the beryl developer(s) ? If so, was there a response?

I'm wondering if there are any common threads to the probelm's manifestation. Like is it peculiar to a particular video card or motherboard or software configuration? Just a thought....

Regards,
Bert

jdeslip
7th February 2007, 08:23 AM
I tried the 0.1.9999 files in the repo just now. The problem still remains :( :( Were these files an attempt to fix the 0.1.99 iissues?

jdeslip
7th February 2007, 09:36 AM
The guys at beryl claim this is an invidia bug see their responses in:

http://bugs.beryl-project.org/ticket/875
and
http://bugs.beryl-project.org/ticket/848

I believe livna has latest nvidia drivers, though. Hopefully there is a fix soon.

d347hm4n
7th February 2007, 02:16 PM
I'm running the 0.2 release and it is working fine with me amdxp2.6 w. a geforce 5200, i got the latest nvidia drivers also. Could this be a dual core bug?

jdeslip
7th February 2007, 07:23 PM
Do you have x86_64. I have a feeling this is an 64 bit issue judging from posts above...

bseltzer
7th February 2007, 10:51 PM
The guys at beryl claim this is an invidia bug see their responses in:

http://bugs.beryl-project.org/ticket/875
and
http://bugs.beryl-project.org/ticket/848

I believe livna has latest nvidia drivers, though. Hopefully there is a fix soon.

Given the "not our problem" nature of these responses and the very limited genuine usefullness of beryl, I'd just as soon dump the whole mess at least until such time as the finger pointing stops. I mean, OK, if it really is an NVIDIA driver bug, then kindly tell me which NVIDIA drivers DO work. If none of them do, then maybe it IS beryl...

Don't get me wrong. I like "eye-candy" as much as the next person. I'm just not willing to sacrifice functionality to get it. In all candor, even the 0.1.4 version of beryl is not all that stable.

Regards,
Bert

icydog
8th February 2007, 12:23 AM
To be honest, I'm pretty tired of Beryl devs blaming nvidia for things. I've only had two major (*major*) bugs with beryl, and both were blamed on nvidia with no resolution in sight.

The first one was the issue where after opening a certain number of windows, your windows contents would turn black. This was back when nvidia texture_from_pixmap used to work (until you hit this bug). They blamed it on nvidia... but this issue was not present in compiz using the same nvidia drivers.

Then this issue, which breaks texture_from_pixmap even more on nvidia, and yet again they are blaming it on nvidia. It used to work. Even if it is nvidia's fault, why can't they enable a workaround? Clearly it is possible to get it working because it used to!

bseltzer
8th February 2007, 12:47 AM
To be honest, I'm pretty tired of Beryl devs blaming nvidia for things. I've only had two major (*major*) bugs with beryl, and both were blamed on nvidia with no resolution in sight.

The first one was the issue where after opening a certain number of windows, your windows contents would turn black. This was back when nvidia texture_from_pixmap used to work (until you hit this bug). They blamed it on nvidia... but this issue was not present in compiz using the same nvidia drivers.

Then this issue, which breaks texture_from_pixmap even more on nvidia, and yet again they are blaming it on nvidia. It used to work. Even if it is nvidia's fault, why can't they enable a workaround? Clearly it is possible to get it working because it used to!

At the risk of "singing to the choir"....

The primary point is I could not care less whose "fault" it is. Assigning blame does not resolve any issue. If I wanted to be embroiled in the vendor blame game, I'd run Windo$e.

A secondary point is since beryl doesn't supply any real functionality, why bother? "yum removed beryl*" works just fine.

Regards,
Bert

jdeslip
8th February 2007, 12:48 AM
Yes, I agree. I have created a post in nvidia forum about this issue. But, it seems the the nvidia developers hadn't even heard of this issue.

http://www.nvnews.net/vbulletin/showthread.php?t=85853

Thanks beryl for blaming someone and not even informing them! I have no idea how to proceed from here...

jdeslip
8th February 2007, 12:50 AM
Also, despite your logic, Bert, Beryl is pretty f-ing awesome and I want it to work. I don't care if it adds functionality or not.

bseltzer
8th February 2007, 01:23 AM
Also, despite your logic, Bert, Beryl is pretty f-ing awesome and I want it to work. I don't care if it adds functionality or not.

Hey, to each his own... For me, my desktop machine is a tool, and therefore, the value of any software running on it is judged (by me, anyway) in terms of it's utility. Other folks have different perspectives for different reasons. I understand and respect that.

More to the point, beryl would/could be awesome, if it just worked. Until such time as it does, it's just another piece of lame-ware, sucking up cycles that could be better used for some other purpose, like a window manager that was both pretty AND robust.

Regards,
Bert

jdeslip
10th February 2007, 08:48 PM
Anyone got any news on this? (Beside 'use copy')

jbkt23
11th February 2007, 12:28 AM
I have Beryl working, first time install, and yes I did have to 'use copy', but I don't know what is slow. I can rotate the cube as fast as I can scoll the wheel at one click per desktop. The following are settings, system info and configs.
dmesg:
Linux version 2.6.19-1.2895.fc6 .........
Command line: ro root=LABEL=/12 iommu=noaperture rhgb quiet

###########################################
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "glx"
Load "dbe"
Load "extmod"
Load "GLcore"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell D2026T"
DisplaySize 380 290
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.0 - 96.0
VertRefresh 50.0 - 100.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV18 [GeForce4 MX 4000 AGP 8x]"
Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

###########################################
~/.beryl-manager

[wm-settings]
active_wm=0
fallback_wm=0
active_dm=0
iconsize=24
use_fallback_wm=true

[beryl-settings]
render_path=2 # copy
cow_mode=1 # enabled
rendering_mode=0
platform=1 #nvidia
binding=0
no_gl_yield=false

##################################

Hope this helps for a similar setup

jbkt23

icydog
11th February 2007, 01:40 AM
When you are doing --use-copy, try playing a video. Mplayer, kaffeine, and whatever else I've tried all skip frames incredibly. I have an 64-bit Athlon 3000+ with 1 GB DDR, I'm pretty sure it can play 640x480 videos. It even lags when not fullscreen, and it's so bad the video and audio will desync.

icydog
11th February 2007, 02:00 AM
AH HA!

Do this:

LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager

(Of course, if you have 32-bit machine then remove the 64)

StephenH
11th February 2007, 04:15 AM
AH HA!

Do this:

LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager

(Of course, if you have 32-bit machine then remove the 64)
At the risk of sounding ignorant, where do I "do this"?

Like many others, I am running x86_64 and can now get compiz to work (since I got a real video card to replace the onboard stuff), but get white screens with beryl.

Stephen

icydog
11th February 2007, 04:21 AM
Oh sorry about that. If you are using the nvidia binary drivers (which is what this bug seems to target), then paste that line into a prompt or the run dialog or something. In other words, instead of starting beryl-manager by typing "beryl-manager" which is the name of the executable, add that bit in front of it.

You need to do this every time you start bery-manager, instead of clicking the icon in the menu or typing just plain "beryl-manager". At least, it works for me...

StephenH
11th February 2007, 04:45 AM
Oh sorry about that. If you are using the nvidia binary drivers (which is what this bug seems to target), then paste that line into a prompt or the run dialog or something. In other words, instead of starting beryl-manager by typing "beryl-manager" which is the name of the executable, add that bit in front of it.

You need to do this every time you start bery-manager, instead of clicking the icon in the menu or typing just plain "beryl-manager". At least, it works for me...
OKAY! :D

It worked. Thank you. I had about given up hope on getting Beryl to run. Compiz was working fine, but Beryl was giving me a white screen. Now I can see what a number of other people were talking about. :)

Stephen

jdeslip
11th February 2007, 06:27 AM
Icydog this sounds so promising but I get the following error and nothing happens:

LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl
beryl: symbol lookup error: /usr/lib64/nvidia/libGL.so.1: undefined symbol: _nv001274gl

(same thing happens if I replace beryl by beryl-manager)

jdeslip
11th February 2007, 06:44 AM
I should probably add I am using x86_64 nvidia driver from livna version 9746.

dmbrown00
11th February 2007, 09:12 AM
I added this to my /etc/X11/xorg.conf:


Section "Extensions"
Option "Composite" "Enable"
Option "RenderAccel" "Enable
EndSection


And made this simple script:


#!/bin/bash
LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager


I added that script to my startup programs, restarted X, and now Beryl works!

jdeslip
11th February 2007, 09:38 AM
What version of driver are you using?? When I try that command I still get: beryl: symbol lookup error: /usr/lib64/nvidia/libGL.so.1.0.9746: undefined symbol: _nv001274gl

weitjong
11th February 2007, 04:57 PM
Thanks icydog. It works for me as well. I am using the latest 64-bit nvidia driver from livna.

bseltzer
11th February 2007, 05:34 PM
I think ya'll know my point of view where this "beryl" thingie is concerned, and although I can get it running on my P4 3.06 GHz, 1 GB RAM, NVIDIA GeForce4 MX 420 system, "works" is definitely not the term I'd use to describe the process.

For starters, if LD_PRELOAD needs to be set, why doesn't the beryl-manager do it by itself without the need for a command-line kludge? Secondly, why doesn't this particular version make the beryl-manager available in the System-->Preferences-->More Preferences menu anymore? And finally, when I do run beryl-manager, it kills off metacity but doesn't replace it with anything until I force it to reload the window manager.

Bottom line... If you're into dicking around with your computer, this is all just fine, but if instead, you're into using the box, beryl is still lame-ware. I'll probably continue to give it a spin whenever a new version comes out, but it'll have to become a whole lot more robust before I'll make it part of my standard setup.

I'm sure it will eventually become a fine desktop environment, assuming it's developers take a bit more responsibility for their code and develop a more rigorous testing program, but for now, it remains most appropriate for hobbyists and developers. Just my $0.02 worth...

Regards,
Bert

weitjong
11th February 2007, 06:31 PM
I totally agree. It used to work out of box for me. All I needed to do then was to add "beryl-manager" into gnome session manager so that it starts whenever I login into gnome. However, I cannot just wait until the fixed version comes out. Believe it or not, I have got so used to the transparent backgrond in gnome Terminal now and since I have dual monitor setup, only beryl handles maximized windows to my liking. It only takes me a one time effort to write a startup script with the LD_PRELOAD and add it into the session manager, and temporarily disabling the old "beryl-manager", and forget about it. When the fix is out, I can easily switch back without a sweat.

By confirming the work around solution posted by icydog in my earlier post, I hope it helps others like me who want to have beryl back as quick as possible.

icydog
11th February 2007, 08:50 PM
jdeslip, I think this only works on nvidia 9746 drivers. Try updating.

jdeslip
11th February 2007, 09:21 PM
Hi Icydog,

I am using 9746. I got it working though by doing two things. One erasing some left over 9625 and 9631 files that were in my /usr/lib64 directory. Then it would work but would complain it did not have access to /dev/nvidia0 and /dev/nvidiactl. So, it was doing indirect rendering instead of direct. I did chmod a+rw on those files and now it doesn't complain about that. Is this safe?

icydog
11th February 2007, 10:00 PM
Are you using Livna drivers? When you yum update those, the old ones should automatically get erased.

dmbrown00
11th February 2007, 10:05 PM
I think udev is supposed to make the permissions on /dev/nvidia* to allow the current X user to write them. When I am logged in, they are owned by me, with permissions 600. Do you have livna-config-display (http://www.diffingo.com/downloads/livna/livna-config-display-0.0.4-1.noarch.rpm) installed? Just run it and choose AIGLX. I had to do that to get the old version to work; it might work for the new one, too.

jdeslip
11th February 2007, 10:17 PM
Ah, thanks dmbrown, I see that they are now owned by jdeslip - not sure why yesterday they were owned by root.

icydog - I now use livna-drivers. But some time in the past I used the script from nvidia, I think that was my problem - there were some leftovers.

Anyway, seems to work now! Thanks.

Now onto a superficial issue!! Why can't I make the caps transparent in this version?

billythekid
17th February 2007, 06:27 PM
AH HA!

Do this:

LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager

(Of course, if you have 32-bit machine then remove the 64)

thanks icydog. I've been trying different drivers and xorg.conf settings for a few hours. This command immedietely got Beryl up and running (x64, fedora core 6, nvidia 7600). Should livna or Fedora be notified to include this in future beryl packages?

you the man

StephenH
17th February 2007, 09:02 PM
I added this to my /etc/X11/xorg.conf:


Section "Extensions"
Option "Composite" "Enable"
Option "RenderAccel" "Enable
EndSection


And made this simple script:


#!/bin/bash
LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager


I added that script to my startup programs, restarted X, and now Beryl works!
Okay, I am going to display my ignorance here, but where are startup programs located? (I am using Gnome)

Stephen

dmbrown00
17th February 2007, 09:42 PM
System > Preferences > More Preferences > Sessions, Start Up Programs tab.

StephenH
17th February 2007, 10:05 PM
System > Preferences > More Preferences > Sessions, Start Up Programs tab.
Thanks. I knew it was probably something simple. I don't think I had ever looked at that particular utility before.

Stephen

TylerDurdened
18th February 2007, 12:04 AM
Someone in the beryl forums compiled the SVN version and added a repo for it... I installed it and it works flawlessly.... well for a beta.... 0.1.4 was much more stable.

as root... type the command

vi /etc/yum.repos.d/beryl.repo

then paste the following into it.




[beryl]
name=Beryl svn for Fedora Core $releasever - $basearch
baseurl=http://www.saafinternational.com/beryl/repo/RPMS/$basearch/
enabled=1
gpgcheck=0





then run:

yum upgrade
I tried running this but it says a bunch of packages are set to be updated but it fails to update because I need beryl-plugins that is greater than 2.0

jbkt23
18th February 2007, 04:30 AM
D_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager

I attempted this but it did not eliminate the white screen for me. My card is a GForce4 4000 and have been relegated to legacy kmod fork of 9631 era builds. But, when you say that it worked for you does that mean that you did not change the advanced beryl options, or did you mean that in addition to changing those settings, the script eliminated the hangs with streaming media?

jbkt23

StephenH
18th February 2007, 05:31 AM
D_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager

I attempted this but it did not eliminate the white screen for me. My card is a GForce4 4000 and have been relegated to legacy kmod fork of 9631 era builds. But, when you say that it worked for you does that mean that you did not change the advanced beryl options, or did you mean that in addition to changing those settings, the script eliminated the hangs with streaming media?

jbkt23
For me, I did not have to change any of the advanced beryl options. It fixed the white screen for me. I also have tweaked a bunch of the settings to get the desktop to do some pretty nifty things. I'll try to attach a screenshot, cut down in size to make it more managable.

This is on a GeForce 7600GS card with the current drivers though. I hope you can figure out what is going on with your system.

Stephen

icydog
18th February 2007, 08:28 AM
@jbkt23:

I'm not sure if you simply made an error in pasting onto this forum, but the command begins with LD_PRELOAD. Your post says D_PRELOAD without the L. Maybe that is the problem?

jbkt23
18th February 2007, 05:43 PM
@jbkt23:

I'm not sure if you simply made an error in pasting onto this forum, but the command begins with LD_PRELOAD. Your post says D_PRELOAD without the L. Maybe that is the problem?

No such luck. I just mis-quoted what I entered at the command line. There are several ' .so ' files in the /lib64/nvidia directory, I might have to experiment a bit since 'libGL.so.1' is a link to 'libGL.so.9631' . I don't know if preloading a link works.

At least it's pretty easy to recover from the white screen.

jbkt23

jbkt23
18th February 2007, 06:35 PM
OK
$ LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1.0.9631 beryl-manager

That did the trick. I am now streaming with no clipping or hangs.

One thing you have to do if beryl is running is kill it first by issueing in a terminal window:
ps aux | grep beryl
user 3522 0.0 2.0 261664 10300 ? Ssl 12:11 0:00 beryl-manager
user 3757 2.7 1.9 242632 9900 ? SL 12:18 0:12 beryl --skip-gl-yield

then issue:
$ kill -9 3522
$ kill -9 3757

then you can issue:
$ LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1.0.9631 beryl-manager
NOTE:
You need to list what is in your lib64/nvidia directory as libGL.so may be linked to a different version than what I have.
Also you may not need ot change the preload command as Icydog had earlier posted because I may not have killed the beryl deamon properly in my first attempts.

jbkt23

StephenH
18th February 2007, 08:26 PM
Congratulations. I have really begun to appreciate Beryl. When I switch to one of my other systems that isn't running it, everything seems rather flat.

Stephen

jbkt23
19th February 2007, 12:56 AM
Well now I have a new quirk to deal with. In my open terminal window I am getting constant error output as follows:
beryl: pixmap 0x420011f can't be bound to texture
beryl: Couldn't bind redirected window 0x142c03f to texture
beryl: pixmap 0x4200121 can't be bound to texture
beryl: Couldn't bind redirected window 0x142c021 to texture
beryl: pixmap 0x4200123 can't be bound to texture
beryl: Couldn't bind redirected window 0x10204b3 to texture
beryl: pixmap 0x4200125 can't be bound to texture
beryl: Couldn't bind redirected window 0xe0682e to texture
beryl: pixmap 0x4200127 can't be bound to texture
beryl: Couldn't bind redirected window 0x1012d0a to texture

Haven't had time to do a search.

jbkt23

stanjam
21st February 2007, 04:57 AM
Just a note for people who have not been able to fix the white screen issue. When your grub screen loads on boot press any key and take a look at your boot options. If your machine is booting into any Fedora kernel ending in "xen" this may be the source of your issues. Get rid of xen or boot into a non xen kernel and you should be able to run beryl.

The key for me in getting beryl to run is seeing the Nvidia splash screen just before the log in screen. Then I know I am on the right track.

HalJordan
21st February 2007, 10:20 PM
Ok, I'm a total N008.
I know how linux works, and what I want from it(FC6), I just don't know how to get it to do so.

I am trying to run Beryl, whenever I start the manager, I get a blank white screen with a cursor.

What do I do to fix it?(Please keep in mind that you'll eventually have to spoon feed me the instructions so try start out doing so)

I appreciate any help you can provide in advance.

icydog
21st February 2007, 11:19 PM
Have you read this thread? Instructions have been spoon-fed many times already. Start at post #40 if you want to save time. Also make sure you have Livna Nvidia drivers installed.

jdeslip
21st February 2007, 11:46 PM
HalJordan. Am I right to assume you have the livna nvidia driver installed and are probably running x86_64? If so, as icydong said, he posted the solution in post #40:

Run (in command line - or change the command your icon is running) to be
LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager

I assume this will be fixed in newer version of beryl.

HalJordan
22nd February 2007, 12:17 AM
How do I enable Livna?/How do I know I have Livna enabled?

jdeslip
22nd February 2007, 12:26 AM
Please check out this site for information on adding extra repositories (1st step of a very good site for getting multimedia to work) http://www.gagme.com/greg/linux/fc6-tips.php. After you have installed the livna repository do a yum install kmod-nvidia.

To see if you have this already installed (maybe a friend helped you?) do rpm -qa | grep livna or rpm -qa | grep nvidia to see if the livna repository is installed and/or the nvidia driver is installed.

jdeslip
22nd February 2007, 12:27 AM
Looking at your xorg.conf from you other post, it seems like you do have the nvidia driver installed. So you either got it from livna or freshrpms or from the binary at nvidia.com. If you got it from the latter, I'd uninstall it and install it from livna instead.

HalJordan
22nd February 2007, 04:25 AM
If you're looking at my other posts, then you must realize that you must tell me HOW to do something. I am still trying to learn my way through the tunnels, and my lamp is low on fuel.

jdeslip
22nd February 2007, 04:33 AM
Sorry man. Well, it looks like you have the nvidia driver installed? Do you know how you installed it?? It does not come with the basic installation of fedora. Perhaps someone helped you with this? Anyway, let's try to figure that out

what do the following commands return:

rpm -qa | grep nvidia
rpm -qa | grep livna

We'll take it from there... but also try running this command and let me know what happens

LD_PRELOAD=/usr/lib64/nvidia/libGL.so.1 beryl-manager

jdeslip
23rd February 2007, 09:05 AM
New beryl packages in the repo tonight ... but they have the same problem. I guess I will be using the LD_PRELOAD fix for awhile longer.

HalJordan
24th February 2007, 06:44 AM
First, I get zilch on nvidia, and livna-release-6-1 on livna

Second, I've uninstalled beryl completely(I think) and am going to wait till there's a stable version on fedora without all this extra fixing it crap

Thankx anyway though.

jdeslip
24th February 2007, 09:37 AM
The fedora bugzilla admitted this was a build problem today and said it would be fixed in the next release of beryl which is probably 0.20 stable?

icydog
25th February 2007, 12:14 AM
This issue has been fixed in the 0.1.9999.2-2.fc6 beryl packages from extras. See these two bugs for details:

http://bugs.beryl-project.org/ticket/848
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229778

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=226719 appears to be a dupe or at least something very similar to the above.

You do not need to do the LD_PRELOAD thing any more. Just run beryl-manager as usual, either by typing "beryl-manager" or clicking its icon in whatever desktop menu you use.

StephenH
25th February 2007, 07:14 PM
Yes! That fixed that problem. I think the latest update may have introduced another one though.

When I am rotating the cube, I get the expected partial fade-out of my background as I set it. What I am also getting and which is a bit disconcerting is that at certain points of rotation, the backgrounds will fade even more, to almost the point of being transparent. I am attaching two screenshots to show this. :confused:

Has anyone else experience this? Is it a new bug or a regression?

Stephen

StephenH
25th February 2007, 09:07 PM
I just finished searching the Beryl forums. Yes, it appears that this is a bug introduced with the latest updates.

http://forum.beryl-project.org/viewtopic.php?f=37&t=3311

In any case, the solution is to turn off "lighting" under the general options. At least it worked for me.

Stephen

jdeslip
25th February 2007, 09:50 PM
Thanks for the tip

mpajoh
26th February 2007, 05:24 PM
This (http://forums.fedoraforum.org/forum/showpost.php?p=750514&postcount=80) says the problem is fixed.
I have not tried it yet. Has anyolne else?

icydog
26th February 2007, 05:55 PM
Yes, post #80 and #81 say that the white screen issue is fixed.

StephenH
26th February 2007, 06:31 PM
See also post 82. There is a different bug introduced with the latest version. Disabling lighting in the general options fixes it for now.

Stephen

HalJordan
26th February 2007, 09:05 PM
They say that the bug has been sent out as fixed. HOWEVER it they are simultaneously asking if anyone has tested yet. That does not necessarily mean that its fixed.

icydog
26th February 2007, 09:18 PM
@HalJordan: Although I'm not sure what you're saying because your post doesn't really make sense, if I guessed your meaning correctly then please read post #81:

Yes! That fixed that problem.
It's pretty obvious he's tried the new one and it works. I apologize for not making this clearer, but I am using the latest updates and they work for me.

So for anyone just stumbling across this thread now, the white screen issue HAS been fixed and this specific issue DOES NOT occur any longer with the latest Extras builds of beryl.

jdeslip
26th February 2007, 09:40 PM
Yes, I have tested it. It is fixed. I have not yet encountered the new bug, but I don't have lighting on.

HalJordan
26th February 2007, 11:26 PM
Thanks, thats exactly what i needed to hear. I'll try and see what happens on my machine. Exactly which vid card do you have? It may have something to do with it. I have dual PCI-Ex 6800 Ultras.

StephenH
27th February 2007, 04:11 AM
PNY Verto PCI Express GeForce 7600GS with 512 MB DDR2 RAM. It works great, and was easier to configure in Linux than in Windows.

I have no need for dual cards since I only occaionally play one of the Linux games such as Same Gnome, PPRacer or SuperTuxKart. Most of the time I am doing things for which the onboard video would have sufficed, but then I wouldn't have been able to run Beryl very well. :)

Stephen

HalJordan
27th February 2007, 04:51 AM
I use both FC6 and XP. I need the dual cards for HL2, Q4, SS2, FarCry, etc.

PS
I did try the new beryl, and it works great. Now I need to find the right thread with instructions on how to get my mx1000 working. (Please don't reply about that, I'll find something, I'd rather not get this one off topic)
:D :cool: :)