PDA

View Full Version : Compiling from source - k9copy, kdelibs and x86_64



Jongi
31st January 2007, 08:07 PM
I was running ./configure trying to install k9copy from source on my x86_64 install. The following error occurs



checking for KDE... libraries /usr/lib, headers /usr/include/kde
checking if UIC has KDE plugins available... no
configure: error: you need to install kdelibs first.


But kdelibs is installed


[root:/usr/src/k9copy-1.1.0-beta2#] yum list | grep kdelibs | grep installed
kdelibs.i386 6:3.5.5-0.2.fc6 installed
kdelibs.x86_64 6:3.5.5-3.fc6.kde installed
kdelibs-devel.x86_64 6:3.5.5-3.fc6.kde installed
kdelibs-devel.i386 6:3.5.5-0.2.fc6 installed

And I locate the files as follows:


[root:/usr/src/k9copy-1.1.0-beta2#] locate kdelibs
/usr/include/kde/kdelibs_export.h
/usr/lib/libkdevkdelibsimporter.la
/usr/lib/libkdevkdelibsimporter.so
/usr/lib64/libkdevkdelibsimporter.la
/usr/lib64/libkdevkdelibsimporter.so
/usr/share/doc/kdelibs-3.5.5
/usr/share/doc/kdelibs-3.5.5/AUTHORS
/usr/share/doc/kdelibs-3.5.5/COPYING
/usr/share/doc/kdelibs-3.5.5/COPYING-DOCS
/usr/share/doc/kdelibs-3.5.5/COPYING.BSD
/usr/share/doc/kdelibs-3.5.5/COPYING.LIB
/usr/share/doc/kdelibs-3.5.5/README
/usr/share/locale/en_GB/LC_MESSAGES/kdelibs.mo
/usr/share/locale/en_GB/LC_MESSAGES/kdelibs_colors.mo
/usr/share/services/kdevkdelibsimporter.desktop

Seve
31st January 2007, 11:39 PM
Hello:
Did you try it with
./configure --prefix=/usr

Seve

Jongi
1st February 2007, 05:31 PM
same error

Jongi
1st February 2007, 06:53 PM
I ended up downloading the rpm from the k9copy site and using an rpm for vamps from livna made for fc5 x86_64.