PDA

View Full Version : Scanning problems?



Trel
31st January 2007, 06:04 AM
I have the latest hplip installed, and printing works fine, but in the HP utilities, when I click the scan button, nothing happens.

The command assigned to the scan button is



scanimage -d %DEVICE_URI%

Trel
31st January 2007, 08:17 PM
Oops,I had meant to post this in Software, could it be moved there pelase?

Trel
17th February 2007, 05:08 PM
Anyone have any idea as of yet?

silvagroup
19th February 2007, 03:45 AM
Have you checked the HP site. some of the printer functions are not available in all the printers. Scan seems to be one of the more common ones that does not work.

When you did your install of the latest HPLIP did you install from SU or user.

Trel
20th February 2007, 07:09 AM
I installed as SU but I tried scanning using both accounts.
Where on the HP site should I check?

silvagroup
20th February 2007, 07:47 AM
Check here http://hplip.sourceforge.net/supported_devices/index.html

Trel
23rd February 2007, 11:58 PM
I have a Photosmart C5180 connected via USB. According to that site, it should do everythign except fax (which in this case makes sense due to the fact that it doesn't have a Fax).

Scanning is important to me at the moment and I dislike having to boot back into windows to do so.
For kicks, to make sure I'm using the right command settings for scanning, do you happen to know all the correct settings?

silvagroup
24th February 2007, 12:37 AM
I gave up trying to setup the K80xi in FC and installed another distro on that specific machine.
Here's what did work on that other machine with the different distro:
set up the drivers with the hp:/usb...foomatic hpijs.
If that doesn't work (didn't on the FC I was trying to setup I am not sure what else you could do in FC. I would suggest upgrading but if evertything else is working OK you maybe asking for problems.
You are using Gnome? I am on KDE.
Does lpinfo -v show the device? It probably will did on the FC setup I was trying, it just would not work.

Trel
24th February 2007, 01:59 AM
You lost me, the only thing I understood there was KDE and Gnome (I use KDE)

silvagroup
24th February 2007, 09:15 AM
Did you do your initial install with kde you may want to try Gnome and see if you have the same problems. FC is a Gnome distro. May help. Seems KDE is not a full implementation and could cause some problems from some sites I have researched. Like I said with a true KDE distro the printer I was trying to use in FC just worked.

Jeff Sadowski
24th February 2007, 09:30 AM
there are steps that need to be followed in setting up a hp multifuction device if you go to the
http://hpoj.sourceforge.net/ there are setup instructions there. You probably don't need more software just see if you can run through the docs to starting the software I remember having to start some programs in the background in order for scanning utils to work.