PDA

View Full Version : cant boot windows



zamok
31st January 2007, 02:13 AM
i recently tryed to dual boot my computer with xp and zod. when i get to the grubloader it has 2 options fedora core 6 and other when i click other it says this


Booting Other
rootnoverify (hd1,0)
chainloader +1

my computer has 2 harddrives: and 80 gig and a 40 gig.
40 contains windows.
80 contains 10 gb ext3 and a 2 gb swap and 68 gb free space

my grub.config file looks like this

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,0)
# kernel /boot/vmlinuz-version ro root=/dev/hdc1
# initrd /boot/initrd-version.img
#boot=/dev/hdc
default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.18-1.2798.fc6)
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.18-1.2798.fc6.img
title Other
rootnoverify (hd1,0)
chainloader +1


plz help

bob
31st January 2007, 04:17 AM
Try changing the 'other' lines to this:

title Windows
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

Also, hit 'enter' one more time after typing 'chainloader +1' to add a blank line at the bottom so that grub reads all the way to the bottom of the grub.conf

nick.stumpos
31st January 2007, 04:26 AM
try remapping hd0 to 1 and 1 to zero, i believe ive read that windows likes to be hd0 for some reason or another

bob
31st January 2007, 04:32 AM
But Nick, (hd0,0) is the drive that IS booting FC, therefore the other drive must be (hd1). It may need 'mapping', which I've provided, but there's always the quirk that there's a hidden partition on (hd1) that's a restore partition, etc. If so, then Windows may boot as (hd1,1). Of course, the way to tell would be to post the results as root; (su -) of 'fdisk -l' and see what the actual partitions are.

nick.stumpos
31st January 2007, 04:41 AM
sorry bob didnt see your post I really gotta stop leaving theses posts open in tabs for so long, I thought i told him to do what you did, maybe not guess ill reread my post

cheers

bob
31st January 2007, 04:45 AM
Yup, you've kinda got the same thing going, except that I thought you were telling him to reset FC as (hd1,0) and Windows as (hd0,0)... which would stop FC from booting. Sorry if I misread that.

zamok
31st January 2007, 05:37 AM
well bob your plan worked. but it seems that my NTLDR is missing and i have to figure out how to replace it. im just going to try to repair windows with my disk.

bob
31st January 2007, 01:31 PM
Well, you can certainly do that, but if you've installed grub on the mbr, fixing NTLDR will overwrite grub on the master boot record and you won't be able to boot FC until you put it back. Here's how to reinstall grub:

1. Boot off the 1st Fedora CD or use the Fedora Rescue CD
2. At the boot prompt type 'linux rescue'
3. The rescue mode will find the fedora installation
4. Type 'chroot /mnt/sysimage' (without quotes)
5. Type 'grub-install /dev/hda' (to install Grub to the MBR of the 1st HD)
6. Restart and you should get the boot menu


So, since you have two drives and an OS on each, if you want to keep them separate, you might want to consider this option: http://jimlawrnc.mine.nu/mywiki/DualBootLinux

zamok
31st January 2007, 07:10 PM
i think im just going to place the boot.ini NTLDR and NTDETECT.COM files into the root of my windows drive.