PDA

View Full Version : X11 screwed up, i810, FX5200 -blank screen on boot



ositstomc
29th January 2007, 03:05 PM
The history, I installed FC5 on a Celeron P4 (2.4) with a mobo with integrated Intel video (i810) and all was sweet. I installed mythtv and got all the modules working and i was almost finished, I just needed to add a PCI Nvidia 5200 to get TVOut functioning and I was done, and thats when the trouble started.

I made a copy of my Xorg config, I plugged in the 5200 and rebooted, I then installed the NVidia driver http://www.nvidia.com/object/linux_display_ia32_1.0-9746.html rebooted my PC and now it just boots into a FC5 blank blue screen with a mouse pointer. None of the other console screens are available and #1 shows some of the boot history but nothing relevant. BTW this output is on the i810, the Nvidia has no output.

I then rebooted to runlevel 3 and copied back my original xorg config thinking this would resolve my woes but it made no difference, the system still goes through a full boot sequence starting all the services in the GUI boot screen and then when it satys something like 'Starting Avahi.....' it jumps to a blank screen and appears to freeze. I seem to have full network access to the box and am able to SSH to the box no problem.

I am now at a loss as to how I can backout these changes and get back to a working system? How can i remove any installed nvidia drivers? I tried 'yum remove nvidia*' and this seemed to removed some packages but I am not sure they all were removed.

I previously had this Nvidia 5200 card working on this machine under FC4 but then my hard disk upped and died (RIP)

ANy help would be gratefully appreciated.

TIA TomC
:mad:

mr.v.
30th January 2007, 10:31 AM
ositstomc--

when you installed the nvidia drivers did you obtain them from nvidia's site? or did you get them via the livna rpm database (http://rpm.livna.org)? [sidebar...if you want to install livna support go here http://rpm.livna.org/rlowiki/UsingLivna and cut and paste the rpm command for your Fedora Core X version into a terminal]

Anyway, have you run the nvidia-xconfig script (should be in /usr/sbin/nvidia-xconfig if your install went okay).

The other thing I believe may be a problem is that you have multiple graphics cards...therefore for the nvidia driver to work okay you need to tell it what BusID the nvidia card has under your /etc/X11/xorg.conf

I have an onboard nvidia 6100 and a 7900gs in the pci-express slot. In order to obtain support for the 7900gs my xorg.conf I had to add the line

BusID "PCI:2:0:0"
under the device section.

To determine what busid YOU should use...do the following at your console:
lspci
here's my example

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 VGA compatible controller: nVidia Corporation GeForce 7900 GS (rev a1)
as you can see the last line says 02:00.0 which translates to "PCI:2:0:0" but for you it may/will be different. do lspci to figure out what the busid is and put that under the device section (right under where it says driver "nvidia"
e.g.

Identifier "NV PCI"
Driver "nvidia"
VendorName "nvidia"
BusID "PCI:2:0:0"

mr.v.
30th January 2007, 10:38 AM
one more thing...
look at this post in the ubuntu wiki
http://doc.gwos.org/index.php/Nvidia_Intel_Integrated
it basically details the problem you may be having too. Try the busid ... if that doesn't work try the solution he has (disabling agpgart/intel_agp) and placing
Option "NvAGP" "1"
under the Driver "nvidia" line.

P.S. make sure if you do this, you have the nvidia driver installed again and not partially destroyed from your yum remove line