PDA

View Full Version : FC6 mplayer and external repos



GL1800
14th January 2007, 03:27 PM
running FC6 fresh install on plain vanilla hardware.
Likely this is caused by using livna and freshrpms, but what else can we do? I installed mplayer, the install appeared to go smoothly, BUT! When I try to start mplayer from the CLI, I get:
mplayer: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: faacDecOpen
This MAY be a totally wrong library, or some other issue, I don't know.
Also, I installed all the codecs, in both /usr/llocal//lib/codecs and /usr/lib/win32, but, xine, which is working, complains that it can't find the codecs. Hmmm.
Any help, please?

Jman
16th January 2007, 05:17 AM
Let's see which package is actually installed. Do
rpm -qf /usr/lib/libavcodec.so.51

GL1800
16th January 2007, 12:50 PM
Thanks, and I get:
ffmpeg-0.4.9-0.23.20060817.lvn5

yocum
16th January 2007, 08:31 PM
Make sure your yum.conf file is looking at the right repo. This latest version of ffmpeg from livna is ffmpeg-0.4.9-0.25.20061030.lvn6.

u-noneinc-s
16th January 2007, 08:36 PM
I would guess you just installed the wrong livna release. Your ffmpeg is from lvn5

alpha645
16th January 2007, 08:50 PM
Could be a stupid suggestion, but could it because he is using freshrpms. I mean something like this (http://fedoraproject.org/wiki/JohnMahowald/ATrpmsWarning?highlight=%28warning%29).

me2
17th January 2007, 12:40 AM
I just got the same error today. I'm running the latest mplayer from livna and my ffmpeg is just fine. Mplayer worked fine yesterday. What gives ?

$rpm -q ffmpeg
ffmpeg-0.4.9-0.25.20061030.lvn6

$ rpm -q mplayer
mplayer-1.0-0.66.rc1.lvn6

$ mplayer test.wmv
mplayer: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: faacDecOpen

uname -a
Linux xxxx 2.6.18-1.2869.fc6PAE #1 SMP Wed Dec 20 15:08:30 EST 2006 i686 i686 i386 GNU/Linux

I bet something from a recent yum update broke it. I ran yum update this morning.

me2
18th January 2007, 06:50 AM
Someone in another thread suggested it might be a broken link. So here are my links to that lib.

ls -al /usr/lib/libavcodec*
lrwxrwxrwx 1 root root 21 Nov 2 07:53 /usr/lib/libavcodec.so.51 -> libavcodec.so.51.22.0
-rwxr-xr-x 1 root root 3343268 Nov 1 11:01 /usr/lib/libavcodec.so.51.22.0


Someone suggested it might be a bad update. Here is my yum log for the last week.

Jan 10 16:07:41 Updated: libgcc.i386 4.1.1-51.fc6
Jan 10 16:08:43 Updated: glibc-common.i386 2.5-10.fc6
Jan 10 16:08:59 Updated: glibc.i686 2.5-10.fc6
Jan 10 16:09:01 Updated: libstdc++.i386 4.1.1-51.fc6
Jan 10 16:09:02 Updated: krb5-libs.i386 1.5-13
Jan 10 16:09:12 Updated: libgcj.i386 4.1.1-51.fc6
Jan 10 16:09:15 Updated: dbus.i386 1.0.1-9.fc6
Jan 10 16:09:16 Updated: libgomp.i386 4.1.1-51.fc6
Jan 10 16:09:17 Updated: libgfortran.i386 4.1.1-51.fc6
Jan 10 16:09:23 Updated: glibc-headers.i386 2.5-10.fc6
Jan 10 16:09:25 Updated: glibc-devel.i386 2.5-10.fc6
Jan 10 16:09:44 Updated: libgcj-devel.i386 4.1.1-51.fc6
Jan 10 16:09:55 Updated: libstdc++-devel.i386 4.1.1-51.fc6
Jan 10 16:09:59 Updated: xorg-x11-server-Xorg.i386 1.1.1-47.4.fc6
Jan 10 16:10:01 Updated: cpp.i386 4.1.1-51.fc6
Jan 10 16:10:10 Updated: gcc.i386 4.1.1-51.fc6
Jan 10 16:10:11 Updated: libobjc.i386 4.1.1-51.fc6
Jan 10 16:10:12 Updated: xterm.i386 223-1.fc6
Jan 10 16:10:14 Updated: gcc-gfortran.i386 4.1.1-51.fc6
Jan 10 16:10:17 Updated: krb5-workstation.i386 1.5-13
Jan 10 16:10:18 Updated: dbus-devel.i386 1.0.1-9.fc6
Jan 10 16:10:20 Updated: gcc-c++.i386 4.1.1-51.fc6
Jan 10 16:10:22 Updated: wget.i386 1.10.2-8.fc6.1
Jan 10 16:10:24 Updated: gcc-java.i386 4.1.1-51.fc6
Jan 10 16:10:25 Updated: libgnat.i386 4.1.1-51.fc6
Jan 10 16:10:28 Updated: autofs.i386 1:5.0.1-0.rc3.2
Jan 10 16:10:30 Updated: krb5-devel.i386 1.5-13
Jan 10 16:10:31 Updated: dbus-x11.i386 1.0.1-9.fc6
Jan 10 16:10:33 Updated: nscd.i386 2.5-10.fc6
Jan 12 11:34:00 Updated: wine-core.i386 0.9.29-1.fc6
Jan 12 11:34:07 Updated: gimp-print.i386 4.2.7-23.fc6
Jan 12 11:34:08 Updated: glib.i386 1:1.2.10-26.fc6
Jan 12 11:34:10 Updated: wine-jack.i386 0.9.29-1.fc6
Jan 12 11:34:11 Updated: wine-capi.i386 0.9.29-1.fc6
Jan 12 11:34:12 Updated: wine-cms.i386 0.9.29-1.fc6
Jan 12 11:34:13 Updated: wine-ldap.i386 0.9.29-1.fc6
Jan 12 11:34:14 Updated: wine-twain.i386 0.9.29-1.fc6
Jan 12 11:34:17 Updated: wine-tools.i386 0.9.29-1.fc6
Jan 12 11:34:18 Updated: wine-nas.i386 0.9.29-1.fc6
Jan 12 11:34:19 Updated: wine-esd.i386 0.9.29-1.fc6
Jan 12 11:34:24 Updated: lm_sensors.i386 2.10.1-1.fc6
Jan 12 11:34:27 Updated: postgresql-libs.i386 8.1.6-1.fc6
Jan 12 11:34:45 Updated: linuxdoc-tools.i386 0.9.21-8.fc6
Jan 12 11:34:47 Updated: wine-arts.i386 0.9.29-1.fc6
Jan 12 11:34:48 Updated: glib-devel.i386 1:1.2.10-26.fc6
Jan 12 11:34:49 Updated: gimp-print-utils.i386 4.2.7-23.fc6
Jan 12 11:34:59 Updated: util-linux.i386 2.13-0.45.4.fc6
Jan 12 11:35:00 Updated: wine.i386 0.9.29-1.fc6
Jan 12 11:35:01 Updated: cpuspeed.i386 1:1.2.1-1.43.fc6
Jan 12 11:35:07 Updated: wine-devel.i386 0.9.29-1.fc6
Jan 12 11:35:08 Updated: gimp-print-plugin.i386 4.2.7-23.fc6
Jan 12 11:35:12 Updated: shadow-utils.i386 2:4.0.17-11.fc6
Jan 14 01:07:45 Updated: selinux-policy.noarch 2.4.6-23.fc6
Jan 14 01:07:47 Updated: m4.i386 1.4.5-4
Jan 14 01:07:50 Updated: tar.i386 2:1.15.1-24.fc6
Jan 14 01:08:03 Updated: selinux-policy-targeted.noarch 2.4.6-23.fc6
Jan 14 01:08:05 Updated: jpackage-utils.noarch 1.7.3-1jpp.2.fc6
Jan 14 01:08:08 Updated: cpuspeed.i386 1:1.2.1-1.46.fc6
Jan 14 01:08:13 Updated: gawk.i386 3.1.5-13.fc6
Jan 15 13:04:49 Updated: avahi.i386 0.6.16-1.fc6
Jan 15 13:04:49 Updated: avahi-compat-howl.i386 0.6.16-1.fc6
Jan 15 13:04:50 Updated: avahi-glib.i386 0.6.16-1.fc6
Jan 15 13:04:51 Updated: avahi-qt3.i386 0.6.16-1.fc6
Jan 15 13:05:02 Updated: evolution-data-server.i386 1.8.2-2.fc6
Jan 15 13:05:10 Updated: gettext.i386 0.14.6-4.fc6
Jan 15 13:05:10 Updated: libvolume_id.i386 095-17.fc6
Jan 15 13:05:14 Updated: sysklogd.i386 1.4.1-41.fc6
Jan 15 13:05:16 Updated: python-numeric.i386 24.2-1.fc6
Jan 15 13:05:19 Updated: gawk.i386 3.1.5-14.fc6
Jan 15 13:05:24 Updated: shadow-utils.i386 2:4.0.17-12.fc6
Jan 15 13:05:26 Updated: udev.i386 095-17.fc6
Jan 15 13:05:27 Updated: avahi-devel.i386 0.6.16-1.fc6
Jan 15 13:05:30 Updated: w3m.i386 0.5.1-15.fc6
Jan 16 00:34:12 Updated: libselinux.i386 1.33.3-2.fc6
Jan 16 00:34:13 Updated: yum-metadata-parser.i386 1.0.3-1.fc6
Jan 16 00:34:17 Updated: yum.noarch 3.0.3-1.fc6
Jan 16 00:34:19 Updated: libselinux-devel.i386 1.33.3-2.fc6
Jan 16 00:34:20 Updated: libselinux-python.i386 1.33.3-2.fc6
Jan 16 07:48:35 Updated: flash-plugin.i386 7.0.69-2
Jan 16 16:32:54 Erased: mplayerplug-in
Jan 16 16:32:58 Erased: mplayer-fonts
Jan 16 16:33:00 Erased: mplayer-gui
Jan 16 16:33:24 Erased: mplayer
Jan 16 16:34:54 Installed: mplayer-doc.i386 1.0-0.66.rc1.lvn6
Jan 16 16:34:58 Installed: mplayer.i386 1.0-0.66.rc1.lvn6
Jan 16 16:35:00 Installed: mplayer-fonts.noarch 1.1-4.lvn6
Jan 16 16:35:08 Installed: mplayer-gui.i386 1.0-0.66.rc1.lvn6
Jan 16 16:35:14 Installed: mplayerplug-in.i386 3.35-1.lvn6
Jan 16 16:47:56 Updated: avahi.i386 0.6.16-2.fc6
Jan 16 16:47:57 Updated: avahi-glib.i386 0.6.16-2.fc6
Jan 16 16:47:58 Updated: avahi-compat-howl.i386 0.6.16-2.fc6
Jan 16 16:47:59 Updated: avahi-qt3.i386 0.6.16-2.fc6
Jan 16 16:48:01 Updated: fetchmail.i386 6.3.6-1.fc6
Jan 16 16:48:02 Updated: avahi-devel.i386 0.6.16-2.fc6
Jan 16 20:09:15 Updated: nspr.i386 4.6.4-0.6.1.fc6
Jan 17 08:57:02 Updated: flash-plugin.i386 9.0.31.0-1
Jan 17 19:43:43 Updated: libselinux.i386 1.33.4-2.fc6
Jan 17 19:44:20 Updated: foomatic.i386 3.0.2-39.4.fc6
Jan 17 19:44:23 Updated: system-config-printer-libs.i386 0.7.49-1.fc6
Jan 17 19:44:24 Updated: strace.i386 4.5.15-1.fc6
Jan 17 19:44:29 Updated: system-config-printer.i386 0.7.49-1.fc6
Jan 17 19:44:30 Updated: libselinux-python.i386 1.33.4-2.fc6
Jan 17 19:44:34 Updated: autofs.i386 1:5.0.1-0.rc3.6
Jan 17 19:44:36 Updated: libselinux-devel.i386 1.33.4-2.fc6

Any ideas ?

alpha645
18th January 2007, 07:21 AM
Someone in another thread suggested it might be a broken link. So here are my links to that lib.

ls -al /usr/lib/libavcodec*
lrwxrwxrwx 1 root root 21 Nov 2 07:53 /usr/lib/libavcodec.so.51 -> libavcodec.so.51.22.0
-rwxr-xr-x 1 root root 3343268 Nov 1 11:01 /usr/lib/libavcodec.so.51.22.0


Someone suggested it might be a bad update. Here is my yum log for the last week.

Jan 10 16:07:41 Updated: libgcc.i386 4.1.1-51.fc6
Jan 10 16:08:43 Updated: glibc-common.i386 2.5-10.fc6
Jan 10 16:08:59 Updated: glibc.i686 2.5-10.fc6
Jan 10 16:09:01 Updated: libstdc++.i386 4.1.1-51.fc6
Jan 10 16:09:02 Updated: krb5-libs.i386 1.5-13
Jan 10 16:09:12 Updated: libgcj.i386 4.1.1-51.fc6
Jan 10 16:09:15 Updated: dbus.i386 1.0.1-9.fc6
Jan 10 16:09:16 Updated: libgomp.i386 4.1.1-51.fc6
Jan 10 16:09:17 Updated: libgfortran.i386 4.1.1-51.fc6
Jan 10 16:09:23 Updated: glibc-headers.i386 2.5-10.fc6
Jan 10 16:09:25 Updated: glibc-devel.i386 2.5-10.fc6
Jan 10 16:09:44 Updated: libgcj-devel.i386 4.1.1-51.fc6
Jan 10 16:09:55 Updated: libstdc++-devel.i386 4.1.1-51.fc6
Jan 10 16:09:59 Updated: xorg-x11-server-Xorg.i386 1.1.1-47.4.fc6
Jan 10 16:10:01 Updated: cpp.i386 4.1.1-51.fc6
Jan 10 16:10:10 Updated: gcc.i386 4.1.1-51.fc6
Jan 10 16:10:11 Updated: libobjc.i386 4.1.1-51.fc6
Jan 10 16:10:12 Updated: xterm.i386 223-1.fc6
Jan 10 16:10:14 Updated: gcc-gfortran.i386 4.1.1-51.fc6
Jan 10 16:10:17 Updated: krb5-workstation.i386 1.5-13
Jan 10 16:10:18 Updated: dbus-devel.i386 1.0.1-9.fc6
Jan 10 16:10:20 Updated: gcc-c++.i386 4.1.1-51.fc6
Jan 10 16:10:22 Updated: wget.i386 1.10.2-8.fc6.1
Jan 10 16:10:24 Updated: gcc-java.i386 4.1.1-51.fc6
Jan 10 16:10:25 Updated: libgnat.i386 4.1.1-51.fc6
Jan 10 16:10:28 Updated: autofs.i386 1:5.0.1-0.rc3.2
Jan 10 16:10:30 Updated: krb5-devel.i386 1.5-13
Jan 10 16:10:31 Updated: dbus-x11.i386 1.0.1-9.fc6
Jan 10 16:10:33 Updated: nscd.i386 2.5-10.fc6
Jan 12 11:34:00 Updated: wine-core.i386 0.9.29-1.fc6
Jan 12 11:34:07 Updated: gimp-print.i386 4.2.7-23.fc6
Jan 12 11:34:08 Updated: glib.i386 1:1.2.10-26.fc6
Jan 12 11:34:10 Updated: wine-jack.i386 0.9.29-1.fc6
Jan 12 11:34:11 Updated: wine-capi.i386 0.9.29-1.fc6
Jan 12 11:34:12 Updated: wine-cms.i386 0.9.29-1.fc6
Jan 12 11:34:13 Updated: wine-ldap.i386 0.9.29-1.fc6
Jan 12 11:34:14 Updated: wine-twain.i386 0.9.29-1.fc6
Jan 12 11:34:17 Updated: wine-tools.i386 0.9.29-1.fc6
Jan 12 11:34:18 Updated: wine-nas.i386 0.9.29-1.fc6
Jan 12 11:34:19 Updated: wine-esd.i386 0.9.29-1.fc6
Jan 12 11:34:24 Updated: lm_sensors.i386 2.10.1-1.fc6
Jan 12 11:34:27 Updated: postgresql-libs.i386 8.1.6-1.fc6
Jan 12 11:34:45 Updated: linuxdoc-tools.i386 0.9.21-8.fc6
Jan 12 11:34:47 Updated: wine-arts.i386 0.9.29-1.fc6
Jan 12 11:34:48 Updated: glib-devel.i386 1:1.2.10-26.fc6
Jan 12 11:34:49 Updated: gimp-print-utils.i386 4.2.7-23.fc6
Jan 12 11:34:59 Updated: util-linux.i386 2.13-0.45.4.fc6
Jan 12 11:35:00 Updated: wine.i386 0.9.29-1.fc6
Jan 12 11:35:01 Updated: cpuspeed.i386 1:1.2.1-1.43.fc6
Jan 12 11:35:07 Updated: wine-devel.i386 0.9.29-1.fc6
Jan 12 11:35:08 Updated: gimp-print-plugin.i386 4.2.7-23.fc6
Jan 12 11:35:12 Updated: shadow-utils.i386 2:4.0.17-11.fc6
Jan 14 01:07:45 Updated: selinux-policy.noarch 2.4.6-23.fc6
Jan 14 01:07:47 Updated: m4.i386 1.4.5-4
Jan 14 01:07:50 Updated: tar.i386 2:1.15.1-24.fc6
Jan 14 01:08:03 Updated: selinux-policy-targeted.noarch 2.4.6-23.fc6
Jan 14 01:08:05 Updated: jpackage-utils.noarch 1.7.3-1jpp.2.fc6
Jan 14 01:08:08 Updated: cpuspeed.i386 1:1.2.1-1.46.fc6
Jan 14 01:08:13 Updated: gawk.i386 3.1.5-13.fc6
Jan 15 13:04:49 Updated: avahi.i386 0.6.16-1.fc6
Jan 15 13:04:49 Updated: avahi-compat-howl.i386 0.6.16-1.fc6
Jan 15 13:04:50 Updated: avahi-glib.i386 0.6.16-1.fc6
Jan 15 13:04:51 Updated: avahi-qt3.i386 0.6.16-1.fc6
Jan 15 13:05:02 Updated: evolution-data-server.i386 1.8.2-2.fc6
Jan 15 13:05:10 Updated: gettext.i386 0.14.6-4.fc6
Jan 15 13:05:10 Updated: libvolume_id.i386 095-17.fc6
Jan 15 13:05:14 Updated: sysklogd.i386 1.4.1-41.fc6
Jan 15 13:05:16 Updated: python-numeric.i386 24.2-1.fc6
Jan 15 13:05:19 Updated: gawk.i386 3.1.5-14.fc6
Jan 15 13:05:24 Updated: shadow-utils.i386 2:4.0.17-12.fc6
Jan 15 13:05:26 Updated: udev.i386 095-17.fc6
Jan 15 13:05:27 Updated: avahi-devel.i386 0.6.16-1.fc6
Jan 15 13:05:30 Updated: w3m.i386 0.5.1-15.fc6
Jan 16 00:34:12 Updated: libselinux.i386 1.33.3-2.fc6
Jan 16 00:34:13 Updated: yum-metadata-parser.i386 1.0.3-1.fc6
Jan 16 00:34:17 Updated: yum.noarch 3.0.3-1.fc6
Jan 16 00:34:19 Updated: libselinux-devel.i386 1.33.3-2.fc6
Jan 16 00:34:20 Updated: libselinux-python.i386 1.33.3-2.fc6
Jan 16 07:48:35 Updated: flash-plugin.i386 7.0.69-2
Jan 16 16:32:54 Erased: mplayerplug-in
Jan 16 16:32:58 Erased: mplayer-fonts
Jan 16 16:33:00 Erased: mplayer-gui
Jan 16 16:33:24 Erased: mplayer
Jan 16 16:34:54 Installed: mplayer-doc.i386 1.0-0.66.rc1.lvn6
Jan 16 16:34:58 Installed: mplayer.i386 1.0-0.66.rc1.lvn6
Jan 16 16:35:00 Installed: mplayer-fonts.noarch 1.1-4.lvn6
Jan 16 16:35:08 Installed: mplayer-gui.i386 1.0-0.66.rc1.lvn6
Jan 16 16:35:14 Installed: mplayerplug-in.i386 3.35-1.lvn6
Jan 16 16:47:56 Updated: avahi.i386 0.6.16-2.fc6
Jan 16 16:47:57 Updated: avahi-glib.i386 0.6.16-2.fc6
Jan 16 16:47:58 Updated: avahi-compat-howl.i386 0.6.16-2.fc6
Jan 16 16:47:59 Updated: avahi-qt3.i386 0.6.16-2.fc6
Jan 16 16:48:01 Updated: fetchmail.i386 6.3.6-1.fc6
Jan 16 16:48:02 Updated: avahi-devel.i386 0.6.16-2.fc6
Jan 16 20:09:15 Updated: nspr.i386 4.6.4-0.6.1.fc6
Jan 17 08:57:02 Updated: flash-plugin.i386 9.0.31.0-1
Jan 17 19:43:43 Updated: libselinux.i386 1.33.4-2.fc6
Jan 17 19:44:20 Updated: foomatic.i386 3.0.2-39.4.fc6
Jan 17 19:44:23 Updated: system-config-printer-libs.i386 0.7.49-1.fc6
Jan 17 19:44:24 Updated: strace.i386 4.5.15-1.fc6
Jan 17 19:44:29 Updated: system-config-printer.i386 0.7.49-1.fc6
Jan 17 19:44:30 Updated: libselinux-python.i386 1.33.4-2.fc6
Jan 17 19:44:34 Updated: autofs.i386 1:5.0.1-0.rc3.6
Jan 17 19:44:36 Updated: libselinux-devel.i386 1.33.4-2.fc6

Any ideas ?

It seems that yesterday, you updated selinux. Try turning it off.

me2
19th January 2007, 06:16 AM
My selinux is disabled.

me2
19th January 2007, 06:44 AM
Solved.

See here: http://fedoraforum.org/forum/showthread.php?p=727120#post727120

alpha645
19th January 2007, 07:23 AM
Solved.

See here: http://fedoraforum.org/forum/showthread.php?p=727120#post727120

Great job :)