PDA

View Full Version : Newbie Question: Browsing a DVD-ROM



jbarnett74
14th January 2007, 05:26 AM
I am new to Fedora. I have successfully installed Fedora 6 (64 Bit version). Now I'm trying to browse the DVD that I installed from, but I am unable to do so. I'm using an old DVD-Rom drive, which I installed the Fedora from, and I can see a "CD-ROM/DVD-ROM Drive" icon in Nautilus (via Computer). However, when I try to open the item I get a "Unable to mount media" error.

I would guess that the DVD and DVD-Rom drive are fine (since I used them both for installation). Therefore, it seems I don't know what I'm doing. Could someone give me a clue as to how I might correctly mount and browse this fs? I'd appreciate it.

By the way, I've read other forum posts that might suggest Fedora 6 has issues with automounting a DVD-Rom fs. Are those posts applicable or not, considering Nautilus lists the device?

joe.pelayo
14th January 2007, 05:43 AM
MMM, that is the first time I read a problem like that. Honestly aside from using the mount command I don't know what to do. However I will share with something I have learned after three (six) FC6 installations. The first time I install FC6 in a given machine I always get problems, but if I reinstall FC6 problems disappear (can not explain) so, if yours is a 'brand new' nstallation you can try that if anything else works.

sideways
14th January 2007, 05:47 AM
what happens if you try to mount as root from a terminal?

create a mount point 'mkdir /mnt/dvd', then mount with 'mount /dev/dvd /mnt/dvd'

jbarnett74
14th January 2007, 09:38 PM
what happens if you try to mount as root from a terminal?

create a mount point 'mkdir /mnt/dvd', then mount with 'mount /dev/dvd /mnt/dvd'

Ok, so I've managed it that way (logged in as root). However, Nautilus still doesn't recognize that it's mounted though. Is it necessary, or possible, to point the Nautilus "CD-ROM/DVD-ROM Drive" item to the new directory ("/mnt/dvd")?

sideways
14th January 2007, 10:29 PM
You can create a bookmark to it in Places->Add Bookmark, or do what I do which is put an icon on my desktop using a symbolic link



ln -s /mnt/dvd /home/yourname/Desktop/DVD


Also check that the autofs service is running in System->Administration->Services.

I have problems automounting my dvd drive when I insert a disc on one of my machines, I think it's a hardware issue with the drive. I added this line to /etc/fstab which seems to help

/dev/dvdrw /mnt/dvd auto pamconsole,exec,noauto,managed 0 0


(on my machine /dev/dvdrw is just a link to /dev/hdc the actual dvd drive)

John the train
14th January 2007, 11:03 PM
It may not be directly related to this problem, but if I put a CD or DVD in my CD/DVD burner to read and open the relevant drive in ' computer ' it reports ' no media inserted ', but if I leave it for about 5 seconds or so the drive spins up and the disc auto-mounts. Hope this will be of use to some readers of this thread.

jbarnett74
15th January 2007, 06:54 AM
I added the line to etc/fstab and rebooted the machine. When I tried opening the Nautilus item it looked like it worked (the media was being read, but then the error message showed up again.

Now when I try to mount the drive I get the following message:

mount: block device /dev/dvd is write-protected, mounting read-only
mount: you must specify the filesystem type

I don't know many filesystem types, but I tried passing the -t option "ext2", "ext3", "jfs", "autofs". "autofs" seemed to lockup the entire O.S.

I can't help but think I'm making this more difficult than it needs to be. I appreciate your help though.

sideways
15th January 2007, 07:12 AM
well you could try '-t udf', but obviously this isn't fixing the problem smoothly.

you could also try modifying the fstab entries eg try 'auto' instead of 'noauto', add 'user' as an option

I settled with mounting manually from a root terminal whenever a disc wasn't automounted, since I only had the problem with one specific drive on one machine.

jbarnett74
15th January 2007, 07:26 AM
I think I may have narrowed the problem to the media. While I don't understand why I wouldn't be able to ls the dvd used to install Fedora (in the same drive used), I have inserted an audio cd and it mounts automatically. I've tried data CDs, containing Windows data, but they didn't work either. Since I am new to Linux, I don't have any media with Linux filesystems other than the DVD I mentioned.

If anyone has any suggestions as to how I might mount the install DVD or FAT filesystem media, please let me know. For what it's worth, I've got Wine installed and I've tried using Wine File to browse the FAT CDs, but that hasn't helped either.

jbarnett74
16th January 2007, 03:12 PM
I've figured out a workable solution for the media I've been trying to read. Realizing that I burned the DVD and other media as ISO media, I tried using the "iso" as the filetype. I got a message asking if I meant "iso9960". So I tried the following line and the fs mounted fine.

mount -t iso9960 /dev/dvd /mnt/dvd

Thanks for pointing me down the right path, and for the other tidbits of useful info (such as the symbolic links).