PDA

View Full Version : Package Upgrade



hankiemalawo
13th January 2007, 01:19 AM
Iam a newbie and I would like to install the package libaio-devel-0.3.104-2.i386.rpm (it's required before I can install Oracle 10g). When I try to run the insallation I am getting the following error/conflict

“file /usr/lib/libaio.a from install of libaio-devel-0.3.104-2 conflicts with file from package libaio-devel-0.3.93-4
file /usr/lib/libaio.so from install of libaio-devel-0.3.104-2 conflicts with file from package libaio-devel-0.3.93-4”

Can some one please help me on the steps used to upgrade to the new package

Seve
13th January 2007, 02:00 AM
Hello:
This should not be located in the how-to Section.
Perhaps you could ask one of the Forum Managers to Move it?

Exactly how are you trying to install the package?
Are you using yum?
Are you using FC6 ?
The current version on FC6:
libaio.i386 0.3.106-3.2 core
libaio-devel.i386 0.3.106-3.2 core

Seve

hankiemalawo
13th January 2007, 10:05 PM
Thanls, I figured it out , I had to uninstall libaio-devel-0.3.93-4 using using the followinng command
rpm -e libaio-0.3.93-4
and I insalled the new package with
rpm -ivh /home/download/libaio-0.3.96-3.i386.rpm

Thanks for the help