PDA

View Full Version : Can't Log into KDE: Splash Disappears



Reisswolf
12th January 2007, 04:51 PM
Hi,

A little while ago, while Konqueror was still open, I deleted the contents of /tmp/kde-<username>. In fact, I ran "shred -u -z *" in that directory, instead of "rm *." When I put the mouse focus back on Konqueror after shredding those files, Konqueror simply shut down and would not open again. So I decided to reboot my computer.

When I tried to log into KDE again at the login screen, the splash started to hang at "Initializing Services." I had faced this problem before, and I had solved it by simply logging into GNOME and removing .kde/ and .kderc from the home directory and /tmp/kde-<username> from the /tmp directory. So I did those same things again.

But this time, after hanging for a while at "Initializing Services" the splash image simply disappears, and nothing else happens. There seems to be no way at all for me to log back in KDE.

Can someone please help?

Seve
12th January 2007, 06:11 PM
Hello:
If no one has a better suggestion and you are totally stuck you could try
yum groupremove " KDE (K Desktop Environment)"

and then

yum groupinstall " KDE (K Desktop Environment)"

and hopefully that gets KDE back for you

Seve

Reisswolf
12th January 2007, 07:39 PM
Hi Seve,

Thanks again for your reply. Well, I have managed to find another way, and it would be good to post it here in case someone else should ever have need for my solution.

First, I had to remove the following directories:
1. ~/.kde/
2. ~/.config/menus/
3. /tmp/kde-<username>/

Then I removed ~/.kderc. After that, I ran the following command from a shell:
$ kbuildsycoca --noincrement

Then I logged out of GNOME and logged into KDE. I was able to log in!

Of course, I had lost all my previous settings, so I had to reconfigure my desktop to my liking, but that was not a big problem at all.

Seve
12th January 2007, 07:51 PM
Hello:
Your solution was certainly much easier.

Glad you got it sorted out :)

Seve