PDA

View Full Version : Error: Missing Dependency



metalman51
11th January 2007, 05:54 PM
Hello all. I did a reinstall of fc 5 last night and ran into this problem. After the installation was complete I checked for updates using yum and I got this:

[root@h170 ~]# yum -y update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core [1/3]
extras [2/3]
updates [3/3]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package yelp.i386 0:2.14.3-3.fc5 set to be updated
---> Package gnome-system-monitor.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package evolution-webcal.i386 0:2.4.1-3.4 set to be updated
---> Package gdm.i386 1:2.14.11-1.fc5 set to be updated
---> Package gedit.i386 1:2.14.3-1 set to be updated
---> Package rhgb.i386 0:0.16.3-1.fc5.1 set to be updated
---> Package gnome-desktop-devel.i386 0:2.14.3-1.fc5 set to be updated
---> Package gstreamer-plugins-base.i386 0:0.10.5-1 set to be updated
---> Package mozilla-devel.i386 37:1.7.13-1.1.fc5 set to be updated
---> Package gnome-pilot-devel.i386 0:2.0.13-7.fc5.6 set to be updated
---> Package firefox.i386 0:1.5.0.9-1.fc5 set to be updated
---> Package pirut.noarch 0:1.0.3-0.fc5 set to be updated
---> Package quota.i386 1:3.13-1.2.2 set to be updated
---> Package mkbootdisk.noarch 0:1.5.2-7 set to be updated
---> Package gnome-media.i386 0:2.14.2-1 set to be updated
---> Package gnome-user-share.i386 0:0.10-1.fc5.1 set to be updated
---> Package file-roller.i386 0:2.14.4-1.fc5 set to be updated
---> Package evolution-data-server-devel.i386 0:1.6.3-1.fc5.2 set to be updated
---> Package gnome-terminal.i386 0:2.14.2-1 set to be updated
---> Package eel2-devel.i386 0:2.14.3-1.fc5 set to be updated
---> Package xorg-x11-xfs.i386 1:1.0.1-4.FC5.0 set to be updated
---> Package gstreamer.i386 0:0.10.4-1 set to be updated
---> Package desktop-printing.i386 0:0.19-8.fc5 set to be updated
---> Package gnome-power-manager.i386 0:2.14.3-1 set to be updated
---> Package eog.i386 0:2.14.3-1.fc5 set to be updated
---> Package gnome-panel-devel.i386 0:2.14.3-1.fc5 set to be updated
---> Package gnome-session.i386 0:2.14.3-1.fc5 set to be updated
---> Package mozilla.i386 37:1.7.13-1.1.fc5 set to be updated
---> Package gnome-screensaver.i386 0:2.14.3-3.fc5 set to be updated
---> Package vixie-cron.i386 4:4.1-58.fc5 set to be updated
---> Package gnopernicus.i386 0:1.0.4-1.fc5.1 set to be updated
---> Package NetworkManager-gnome.i386 0:0.6.4-1.fc5 set to be updated
---> Package smartmontools.i386 1:5.36-fc5.1 set to be updated
---> Package systemtap.i386 0:0.5.10-1.fc5 set to be updated
---> Package nfs-utils.i386 1:1.0.8-4.fc5 set to be updated
---> Package evince.i386 0:0.5.1-4 set to be updated
---> Package gok.i386 0:1.0.7-1 set to be updated
---> Package vnc-server.i386 0:4.1.1-39.fc5 set to be updated
---> Package krb5-auth-dialog.i386 0:0.6.cvs20060212-1.1 set to be updated
---> Package pcmciautils.i386 0:012-0.FC5.2 set to be updated
---> Package gnome-applets.i386 1:2.14.3-2.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: mozilla = 37:1.7.12 for package: devhelp
--> Processing Dependency: seamonkey >= 1.0.7 for package: yelp
--> Processing Dependency: seamonkey = 1.0.7 for package: devhelp
--> Processing Dependency: libxpcom_core.so for package: yelp
--> Finished Dependency Resolution
Error: Missing Dependency: mozilla = 37:1.7.12 is needed by package devhelp
Error: Missing Dependency: seamonkey >= 1.0.7 is needed by package yelp
Error: Missing Dependency: seamonkey = 1.0.7 is needed by package devhelp
Error: Missing Dependency: libxpcom_core.so is needed by package yelp

I tried "yum clean all" followed by "yum -y update" with no luck, also I found this post here "http://www.fedoraforum.org/forum/showthread.php?t=143848&highlight=Error%3A+Missing+Dependency" but do not know how to setup livna.repo in /etc/yum.repos.d. If someone could help it would be much appreciated. Thanks.

Seve
11th January 2007, 06:16 PM
Hello:
I would suggest that you try the following:

yum --exclude=yelp,devhelp update

and see if that allows you to get by the current issue

Seve

metalman51
11th January 2007, 06:28 PM
Thanks for the quick reply but when I run "yum --exclude=yelp,devhelp update" I still get the same error message as before.

Error: Missing Dependency: mozilla = 37:1.7.12 is needed by package devhelp
Error: Missing Dependency: seamonkey >= 1.0.7 is needed by package yelp
Error: Missing Dependency: seamonkey = 1.0.7 is needed by package devhelp
Error: Missing Dependency: libxpcom_core.so is needed by package yelp

Is this something I can live with or does this need to be resolved??

Seve
11th January 2007, 06:32 PM
Hello:

There goes the easy answers :)

try

yum --exclude=mozilla update


Seve