PDA

View Full Version : Problem in installing fortran 77 compiler for fedora 6



jyothish
11th January 2007, 03:07 PM
I have got problem in installing f77 compiler into a fedora 6 machine.

I have searched google and found the package given below.
==>
Fortran 77 support for compatibility compiler Fedora Core 6 for x86_64 "compat-gcc-34-g77-3.4.6-4.x86_64.rpm"

When I tried to install, it is showing some error like..

warning: compat-gcc-34-g77-3.4.6-4.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
compat-gcc-34 = 3.4.6-4 is needed by compat-gcc-34-g77-3.4.6-4.x86_64
compat-libf2c-34 = 3.4.6-4 is needed by compat-gcc-34-g77-3.4.6-4.x86_64
libc.so.6()(64bit) is needed by compat-gcc-34-g77-3.4.6-4.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by compat-gcc-34-g77-3.4.6-4.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by compat-gcc-34-g77-3.4.6-4.x86_64
libg2c.so.0()(64bit) is needed by compat-gcc-34-g77-3.4.6-4.x86_64


Kindly help me in installing f77 for fedora 6.

Thankyou.

gundark
11th January 2007, 03:49 PM
Here is where I would start, I would try doing a "yum install compat-gcc-34-g77" if that fails I would look for what repository on the internet has that rpm package and install the repo in /etc/yum.repos.d, I guess to if you wanted to make sure that you are getting the x64 one, just use the add/remove software in applications and do a search for it

olenb
12th January 2007, 12:29 AM
I think you don't want the compatibilty, there errors are indicating you don't have the compatibility
libraries installed. Using gundark suggestion should clear this up, yum should install everything you need, but the compiler will be named funny.
I think you want to install gcc-gfortran, using yum. Then g77 should work.

jyothish
13th January 2007, 06:35 AM
But I need F77 Compiler to be installed.

Also I tried yum. But it is showing another error..

Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=core-6&arch=i386 error was
[Errno 4] IOError: <urlopen error (110, 'Connection timed out')>
Error: Cannot find a valid baseurl for repo: core

srs
13th January 2007, 11:06 AM
Do you need a F77 compiler or do you specifically need g77? Gfortran compiles F77 code. If you specifically need g77 for some reason, 'yum install compat-gcc-34-g77' should work, but it seems like you have some trouble with yum. Try 'yum clean all', then try again. If this does not work, you need to check your /etc/yum.repos.d/*.repo files.