PDA

View Full Version : Hello - Novice Needs Help with Sudo and Compiz/Beryl



Afteraffekt
11th January 2007, 10:00 AM
Well Hello, my name is Travis and thank you for viewing my post. I'll start by explaining my problem(S)

First whenever i go to use "sudo" i get:

Travis is not in the sudoers file. This incident will be reported.
so I cant install or compile anything, then I want to use Compiz and Beryl Themes(emerald i believe is beryl?)
i dont have a clue how to do this....Any help on these problems will be greatly appretiated!

wesamel
11th January 2007, 10:59 AM
Fedora doesn't add your account to the sudoers file by default, you have to do it manually. Here's an easy guide: http://www.mjmwired.net/resources/mjm-fedora-fc6.html#sudo

And here's one for beryl: http://wiki.beryl-project.org/wiki/Install_Beryl_on_Fedora_Core

If you need anything else I'd be glad to help.

Jongi
11th January 2007, 11:20 AM
Fedora perfers you to do things as root: So if you do the following:

# su - (note the dash after the space after typing su)
Type in the root password

You will now be "logged" in as root and you can perform all functions that you normally would using sudo.

# exit
This will get you back to your normal user in the terminal

Afteraffekt
11th January 2007, 11:39 AM
ok i'v done that sudo, but i dont know if it worked, now when i go to install kiba dock i get this when trying to do this:


sudo aptitude install build-essential automake cvs libpango1.0-dev libgtk2.0-dev libgconf2-dev libglitz-glx-dev librsvg2-dev libglade2-dev


sudo: aptitude: command not found

I got beryl working thank you

Jongi
11th January 2007, 11:54 AM
I don't know if aptitude is installed by default in FC.

# su -
Enter root password then press enter
# yum install aptitude

wesamel
11th January 2007, 07:37 PM
It seems that you were an Ubuntu user up until know, right? If so, then welcome to the world of Fedora. Fedora is really an excellent second step in the process of learning about Linux. You have to do a lot of things manually, which are automated in Ubuntu (automatix for example) and in the process (hopefully) understand a lot about how the system works. Which is really valuable if you plan on using linux for the long run. When I was using Ubuntu, all I could do in the command line was copy/paste lines of commands from forums and wikis, now I use the terminal all the time and as well as anyone.

Anyway, yeah in Fedora yum is the default package manager. So you would install stuff using sudo yum install [package name]
Also, a lot of packages have different names in Fedora than Ubuntu, so you can't just copy from an Ubuntu how-to most of the time. I've taken the time to find them for you, but usually you'll have to find a Fedora-specific how-to or search in the add/remove programs tool for them.

Here's what you need to do:

sudo yum install automake cvs pango-devel gtk2-devel GConf2-devel glitz-glx-devel librsvg2-devel libglade2-devel

The most obvious difference is that development packages are named -devel instead of -dev, but they also have slightly simpler names.

Afteraffekt
12th January 2007, 12:24 PM
I am starting to understand, and yes I was an ubuntu user, thank you for that, fedora does seem alot like ubuntu, but so far i like fedora better, iv got beryl working perfectly..in ubuntu i couldnt even get it started!

now how am i to get kiba dock working lol im fairly sure it will work on fedora as well

Afteraffekt
12th January 2007, 12:44 PM
well it seems kiba doesnt work...and i have no clue how to get akam,aru working so i think its time i gave up? :(

Afteraffekt
13th January 2007, 09:40 AM
is there anything made for fedora thats a must have? i want to explore what it is more in depth

wesamel
13th January 2007, 10:26 AM
I don't think there's anything specific to Fedora that isn't available on other distros. There are a few apps that I find really useful that you might be interested in.

First there's Mail Notification, which displays a motification when you have new mail. It's much easier than checking your inbox every once in a while.

There's also Deskbar which works like Apple's spotlight in Mac OS X. You add it to the panel and whenever you press the shortcut keys it lets you launch apps, search for files, look up words in the dictionary, and more.

And Glipper which is just a clipboard history manager, but I find it really useful.

You may also like Beagle which is pretty much Google Desktop for linux.

Tomboy which is a small note-taking app. Pretty self-explanatory.

Finally, Firefox 2 and Thunderbird for e-mail, Azureus for downloading torrents, and Banshee for playing music.

If you want to install them:

sudo yum install mail-notification deskbar-applet glipper beagle tomboy

Afteraffekt
14th January 2007, 01:04 AM
I never liked those on Windows so I wont go after them, if i ever need them i know where to look, thank you

zeroelixis
14th January 2007, 01:22 AM
well it seems kiba doesnt work...and i have no clue how to get akam,aru working so i think its time i gave up? :(

If you didn't get it running this is what I did:

Download Source:

cvs -d:pserver:anonymous@metascape.afraid.org:/cvsroot co kiba-dock

Then build & install it:


cd kiba-dock
./autogen.sh
make
make install-schemas


Works a treat with beryl :cool:

Afteraffekt
14th January 2007, 06:47 PM
Thanks for the help. but when i go to run ./autogen.sh i get this:

[Travis@localhost kiba-dock]$ ./autogen.sh
autoreconf: Entering directory `.'
autoreconf: configure.in: not using Gettext
autoreconf: running: aclocal
autoreconf: configure.in: tracing
autoreconf: configure.in: creating directory config
autoreconf: configure.in: not using Libtool
autoreconf: running: /usr/bin/autoconf
configure.in:30: error: possibly undefined macro: AC_PROG_LIBTOOL
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1


What is wrong here?

wesamel
14th January 2007, 08:46 PM
Do
sudo yum install libtool

RJRibeira
1st February 2007, 03:46 AM
I've got the same problem as this guy and I've been searching for literally weeks for how to get past the ./autogen.sh step. I installed libtool and ./autogen worked fine. But now when I type "make" it just says:

[root@localhost kiba-dock]# make
make: *** No targets specified and no makefile found. Stop.
[root@localhost kiba-dock]#

?? What could be causing this? I'm so close! I really want to get this working. If anyone has any ideas, please let me know. Thanks.

RJRibeira
5th February 2007, 12:06 AM
bump bump bump