PDA

View Full Version : suspend



yuvalaviel
21st April 2004, 01:57 PM
I would like to have the "suspend" option on my HP-compaq nx 9000 FC1 Laptop.
I also have FC2 T2 on the same machine, which finally works fine.

My questions are:
apm:
Can apm do a suspend?
Can it also control CPU frequency?

acpi:
In the FC2 T2, I see all the acpi files, but configuring it through the KDE interface didn't change anything in /etc/acpi
Why? What do I need to do in order to activate acpi?

ewdi
21st April 2004, 02:09 PM
CPU frequentcy usally control by bios (or jumper in soem cases)

If your bios support acpi and also you enable acpi on your kernel boot (lilo and such) it should be able to run with acpi, remember to disable apm when you are using acpi

fjleal
21st April 2004, 02:23 PM
If you're using Grub, and your machine supports ACPI, add "acpi=on" to the "kernel" line on file /boot/grub/grub.conf (you need to be root).

Example:
kernel /vmlinuz-2.4.22-1.2174.nptl ro root=LABEL=/ hda=ide-scsi rhgb acpi=on

yuvalaviel
21st April 2004, 04:00 PM
I tried acpi=on in kernel parameters, and nothing changed.
Still configuring the ACPI through the kde GUI didn't change the /etc/acpi dircetory.
Also a short press on the power button leads to shutdown.
The BIOS menu doesn't mention suspend options.

Any trivial test that I can do to see that the acpi is functioning without having to shutdown every time?

Anybody has tested action and events files?

dragon
26th May 2004, 12:31 PM
Before trying to configure power management, please be aware that there are TWO power management utilities: ACPI and APM. ACPI is newer but isn't supported on all hardware (esp old hardware). You should not run both utilities at the same time.

To determine whether ACPI / APM is running, check that the *acpid service* is running:
1) From the main menu select "System Settings" => "Server Settings" => "Services"
2) Click on acpid / apmd
3) Check the Status window

OR type "ps -A" at a terminal and check for "acpid" or "apmd".

For more information on ACPI, check out the Linux ACPI home page (http://acpi.sourceforge.net/index.html) for documentation and HOWTO's.

yuvalaviel
26th May 2004, 01:49 PM
Thanks, but I was asking for a test that acpi is functioning not running .

Specifically, I want to see that I can have suspend work, even if it is a series of manual operations.

I've read that suspend is not yet working in 2.6. Is that so?

ZeroVerteX
26th May 2004, 05:12 PM
Here's what I had to do to get my suspend key working on my Dell Inspiron 4100. First, I want to say that ACPI sucks right now. I'm sure it will get better but right now APM is the way to go. The process I had to go through requires recompiling the 2.6 kernel in FC2. This is not a hard process. It does require patience.
The first thing I did was in the menu do "System Setting" -> "Server Settings" -> "Services". It should prompt for root password. The Service Configuration windows should come up. You should be running and editing Runlevel 5. If you are using a different Runlevel, click Edit Runlevel to switch. Uncheck acpid and check apmd. Click on acpid and click "Stop". Close the Service Configuration Windows.
Next step: The kernel! Don't run away screaming! It's not hard and I'm detailing all my steps. Open a terminal. Change to root (do "su -" at the command line). Change directory to /usr/src/linux-2.6.5-1.358/ (do "cd /usr/src/linux-2.6.5-1.358/"). Okay, next do "make menuconfig". This command will take us into a text-based menu configuration utility for the kernel. Alternatively, you can do "make xconfig" for a GUI config utility, but for this will stick to the text-based one. I have found out that you can't have ACPI and APM running at the same time. It just doesn't work. Don't know why, and I'm not a programmer, I'm a user, I just want my stuff to work! Use the arrow keys to navigate the menus. Arrow down to "Power Management Options (ACPI, APM) --->" and hit Enter. I have "Power management" selected and "Software Suspend" marked. If you don't have these marked, arrow down to them and hit Space Bar or "Y". I don't know why I didn't need "Suspend-to-disk support" but I do not have it selected. Arrow down to "ACPI Support". In this menu, if you have "ACPI Support" selected, hit Space Bar or "N" to unselect it. Hit "Esc" to go back to the previous menu. Arrow down to "APM BIOS Support" and hit Enter. Of couse, I have the top listing,"APM BIOS Support" selected allong with <*> APM (Advanced Power Management) BIOS support "Enable PM at boot time","Make CPU Idle calls when idle", "Enable console blanking using APM","RTC stores time in GMT","Allow interrupts during APM BIOS calls", and "Use real mode APM BIOS call to power off". The only one I DON'T have selected is "Ignore USER SUSPEND". The help on this option sugests that unless you have a NEC Versa M series notebooks, you shouldn't use it. Hit "Esc" to go back to the previous menu. Under "CPU Frequency Scaling", I didn't change anything, I think I would probably be best that you do the same. Hit "Esc" "Esc" and you will be asked if you want to save your kernel configuration, which you do so hit Enter on Yes. This will take you back out to a command prompt where you should do "make all modules_install install". It will take SEVERAL minutes, depening on the speed of your computer, of course. After it is done, "reboot". If you are running GRUB, when the Boot loader screen comes up, you will have to select the Custom kernel, you'll see. That's how I got my suspend hot key working on my Dell Inspiron 4100. You can try it if you like. Let me know if it works! Oh, and visit my website, http://www.zerovertex.com. Later! Good Luck!