PDA

View Full Version : realplayer file propertie shows mime type as text/plain



nick623
30th December 2006, 08:36 AM
It seems like certain realplayer files when I double click in nautilus file manager gives me an error message
saying it can't open and tells me it's of type plain text document. If I right click on properties it tells me the mime type is "text/plain." Now if I right click and select "open with" realplayer it works no problem. So how do I change the mime type from text/plain to the default one for realplayer?

Thanks

Seve
30th December 2006, 12:00 PM
Hello:
I believe all you need to do if you are running Gnome is locate a file and right click on it and select Properties and select the Open With Tab
and select realplayer. If it is not there just add it.
In KDE control center KDE components file associations.

Seve

nick623
31st December 2006, 01:04 AM
Ok I right clicked selected Properties and selected the "Open with" Tab and added realplayer. But I still get pop up error message stating that file is of "type plain text document." Then it proceeds to tell me of security risk to open it. If I right click and select "Open with" and select RealPlayer10 it plays correctly. But I still can't double click to open in realplayer. The icon actually shows a realplayer file but if I single click the icon it becomes a text document icon.
I've also noticed that the only way I can get thumbnail preview for image files is to single click the Gnome foot icon that appears.
I think this has something to do with the new freedesktop way of mime association etc for Gnome. I've done some googling on this type tried a few suggestions but yet have figured it out. One suggestion was to rm -rf the gnome .thumbnails directory and log out and back in.
Another suggestion dealt with changing the mime type in the file ~/.local/share/applications/default.list . Well I did notice that my default.list file did have the following line:
[Default Applications]
text/plain=realplay-usercustom.desktop

Well that obviously doesn't sound right. So I just deleted the default list thinking when I log back in it would be created correctly but now it's empty.
Oh well I could go on and on maybe someone could shed some light.

Thanks

Seve
31st December 2006, 12:44 PM
Hello:
See this link, it should help explain a little and create a new one.
http://www.gnome.org/learn/admin-guide/2.14/mimetypes-registering.html


Seve

nick623
1st January 2007, 02:59 AM
Thanks for the link.
I've figured out when ever I right click on a file icon and select properties tab and select the "Open with"
tab it is registered in the ~/.local/share/applications/defaults.
I'm confused though. I tried to create a "audio/ram=realplay.desktop" entry into the defaults.list file and of course the .ram file is still listed as Mime type: text/plain in nautilus.

Should I actually modify the /usr/local/RealPlayer/share/realplay.desktop file Mime type entry. Or should I actually create a seperate realplay.desktop file in the .local/share/application/ directory.

If I right click on a *.ram file in nautilus and select -> Properties -> Open with -> and specify Realplayer application it is not reflected in the .local/share/applications/defaults.list file.

Do I need to specify another Mime type in the /local/RealPlayer/share/realplay.desktop file and update the mimecache file?

Also I still can't get image files to show a thumbnail preview in nautilus unless I actually single click on them.
Strange.

I appreciate all the input.

And anymore would be appreciated.

Thanks

nick623
2nd January 2007, 07:46 AM
Ok I've been reading your link http://www.gnome.org/learn/admin-guide/2.14/mimetypes-registering.html. And I think I"m starting to understand a little more.
The primary files I'm trying to work on are realplayer *.ram and *.rm audio files. I did some googling and I believe the correct mime types are application/vnd.rn-realaudio and application/vnd.rn-realmedia respectively. So I added these to the /usr/share/applications/realplay.desktop and /usr/share/applications/default.lists files.
I then used the update-desktop-database application to update the /usr/share/applications/mimeinfo.cache file.
Then I logged in out of Gnome. But still no luck.

Maybe I'm using the wrong mime types for realplayer *.rm and *.ram files?
I looked at this page http://www.gnome.org/learn/admin-guide/2.14/mimetypes-modifying.html and tried adding the correct entries in the ~/.local/share/mimes/packages/Overrides.xml file and updating with the update-mime-database file. That didn't work. Although I haven't tried that system wide yet.

Any ideas what I'm doing wrong.
Should I just uninstall and reinstall nautilus?
Thanks

nick623
4th January 2007, 04:57 AM
Ok I guess I'm talking to my self.
I've tried every link provided etc. Same conclusion.

Switched to KDE went to control center the file works.
I like Gnome but this episode is making me more inclined for a more user friendly interface.
I even reinstallled nautilus with same result.
Honestly, this shouldn't be that hard. The fact that I have to go through process makes me "not happy".
Oh well I'm not spending an entire week to figure out something that is probably trival.
Excuse my rant . But something like this shouldn't be that difficult.

Thanks rant is over

nick623
4th January 2007, 05:03 AM
Ok Konqueror opens *.ram with the default realplayer file. Wierd. But Nautilus same old stuff.
Anyone with any ideas or suggestions let me know.

John the train
12th January 2007, 06:36 PM
@ nick623. I've been working on the same problem, RealPlayer opens audio and video streams from the BBC site automatically, but ordinary .ram audio clips, no joy. Similarly with .ram audio from the Australian Broadcastin Corporation site. So far I think I've established that I need to edit /usr/share/applicatiions/mimeinfo.cache, but there are an awful lot of formats! I'm going to take a break, then try creating a line instructing Gnome/Firefox to pass .ram files to RealPlayer. I can't see .ram as an audio format in the list, maybe the link from the web-page makes it unnecessary in that case. Anyway, one way or the other I'll post my findings here.

nick623
12th January 2007, 10:03 PM
Thanks john. I've tried many suggestions from various web links. But still no success.
I've edited the following files:
/usr/share/applications/defaults.list
/usr/share/applications/mimeinfo.cache
/usr/share/mime/packages/freedesktop.org.xml
/usr/share/mime/globs
And ran 'update-mime-database /usr/share/mime'. Loging and out afterwards with no success.

Any light you could shed on this topic would be appreciated.
Thanks

John the train
13th January 2007, 11:43 AM
Hi Nick,
No success so far, though ( going slightly off-thread for a moment ) I can now listen to some ABC radio in mp3 format through Rythmbox. The files I'm still having problems with are RTSP and the URL ends .ram and .rn, which should be RealAudio, but blowed if I can find them in .../applications/mimeinfo.cache. There are a couple of RealAudio file types that are assigned to Totem and RealPlayer, but I'm a bit nervous about deleting the Totem reference in case it banjaxes DVD playing. If anyone more familiar with mime file types reads this, your help will be appreciated!
BTW, I saw on another thread that JN4Oldschool is impressed with XFCE, he reports that it's as good as KDE or Gnome but resource-lighter. It's still in test, but it might be worth a look to see how it interacts with Firefox, RealPlayer etc.

danieyek
14th January 2007, 05:33 AM
nick623,

I'm working on fixing this from the RealPlayer installer. I'm hoping to check this in soon. After that, you should be able to download and install a nightly build of RealPlayer from:
http://forms.helixcommunity.org/helix/builds/?category=realplay-current

and have all the MIME types, actions, and "fancy" icons set up correctly.

It is a little bit involving to describe the solution here -- unfortunately, it is a little difficult to get everything working well than simply modifying a few lines.

I don't know if it worked 2 years ago, but things have changed since then and a new solution is nearly finish. I'll try to remember to follow up here when I make the check in. Also, my first attempt to fix this problem might not cover all cases, but it should after a week or so. So, let me know if after 10 days or so, there are still missed cases in the then latest nightly build of RealPlayer.

Thank you.

Daniel Yek.

John the train
14th January 2007, 10:27 AM
Daniyek,
Sound good. What got me looking at it was that using RealPlayer in FC5 I could play the ABC RealAudio streams, but in FC5 you were just replacing Helix Player as default player with a more capable version of the same, whereas in FC6 you have to change from Totem to RealPlayer. No wonder I was floundering a bit!

sideways
14th January 2007, 10:33 AM
Can't help with the desktop associations but for web stuff with firefox you just need to have the right plugins and delete the wrong plugins (i use realmedia all the time)
can you post the output of 'ls -l /usr/lib/mozilla/plugins'

nick623
15th January 2007, 12:53 AM
I've got no problem listening to *.ram files on the internet using firefox.
My problems start when I save a file. And then try to double click it.

nick623
20th January 2007, 06:11 AM
Well I finally solved the problem.
I created the following file Overrides.xml in my ~/.local/share/mime/packages directory:
<?xml version='1.0' encoding='utf-8'?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
<mime-type type="audio/vnd.rn-realaudio">
<sub-class-of type="text/plain"/>
<comment>RealAudio document</comment>
<glob pattern="*.ram"/></mime-type>
</mime-info>
Apparently the key is to create the sub-class text/plain. Which I guess means that *.ram files are acually sub-classes of the text/plain mime type.
This was and still is a very hard learning process for me.

Seve
20th January 2007, 06:27 AM
Hello Nick:
Now that you solved it you should throw together a how-to for all of us lesser beings :)
Good job btw.
Seve

nick623
20th January 2007, 06:42 AM
Hello Seve. It is really hard to find specific information on this. It's really confusing to me. Seems like it should be an easier process. Oh well.
I think I'll leave the "How To" for someone else. :)

sideways
20th January 2007, 09:05 AM
Well done for solving this nick623, although I had to put the Overrides.xml in /root/.local/share/mime/packages and then issue the command

update-mime-database /root/.local/share/mime
Putting it in my own .local directory didn't sem to work

I also noticed that in my own .local directory I have these 3 files

~/.local/share/applications/defaults.list
~/.local/share/applications/mimeinfo.cache
~/.local/share/applications/realplay-usercustom.desktop

and in each file the mime type for realplay is text/plain

So I changed MimeType=text/plain; to MimeType=audio/vnd.rn-realaudio; in realplay-usercustom.desktop and text/plain=realplay-usercustom.desktop to audio/vnd.rn-realaudio=realplay-usercustom.desktop in mimeinfo.cache and defaults.list

Now I really thought I had found the problem with the text/plain association with *.ram, but no luck. Only putting your Overrides.xml in /root/.local/share/mime/packages and updating the mime database worked.

I hope this is resolved in Gnome, it should't be this difficult.

Once again, thanks for your efforts

(btw there was a nice post on this for FC4 a while back, but the steps suggested there don't work for *.ram files http://forums.fedoraforum.org/showthread.php?t=26875, I noticed you followed similar steps yourself initially)


EDIT
I assume the Overrides.xml file can also be put in /usr/share/mime/packages, and then activated with update-mime-database /usr/share/mime

danieyek
23rd January 2007, 12:54 PM
nick623:

There was some delays here, but when the build from date 01/23/07 appears, you can then/now download it from:
http://forms.helixcommunity.org/helix/builds/?category=realplay-current
https://player.helixcommunity.org/

Note that this is a nightly test build, not a stable release build.

We are trying to change the installation directory to /opt/real/RealPlayer and /opt/helix/HelixPlayer. Today, only Helix Player's installer default to the new installation location. I am working on fixing RealPlayer. You can just type in /opt/real/RealPlayer when the installer prompts.

IMPORTANT:
There is a problem with .ram MIME Type being in correct in freedesktop.org.xml.
You need to delete the .ram glob line in freedesktop.org.xml before installing to enable double-click default application action with .ram file.

/usr/share/mime/packages/freedesktop.org.xml:
<glob pattern="*.ra"/>
<glob pattern="*.rax"/>
<glob pattern="*.ram"/> <-- Delete this line!
<alias type="audio/x-pn-realaudio"/>
</mime-type>

Please send email to users@player.helixcommunity.org if you encounter any problems.

Thanks.

Daniel Yek.

danieyek
23rd January 2007, 01:00 PM
Hi,

The MIME Type for .ram file is application/ram.

I know all old documentation point to audio/x-pn-realaudio, but that needs to be changed now.

In fact, I just found out about this from Helix Core team.

I'm in the process of opening a bug report against freedesktop.org to change the .ram MIME type.

Thanks.

Daniel Yek.

danieyek
24th January 2007, 05:14 AM
One more thing that I forgot to mention:
Only the binary (realplay*.bin) installer has the double-click (default application) and other fixes. I'm still working on the rpm package.

nick623
27th January 2007, 03:48 AM
Here's another wierd one. My /usr/share/mime/magic file is treated as a realplayer *.smil file by nautilus.
Nautilus -> properties claims that it is the mime type application/smil. However, when I issue the command "file -i /usr/share/mime/magic" it shows its the type "application/octet-stream." I believe it is a binary file. I edited my local Overrides.xml file to include an entry for application/smil erasing any magic content thinking maybe it had something to with sniffing the content of the file since it has no file extension. Of course that didn't work.
I moved it to trash in Nautilus and logged in and out thinking maybe by default nautilus would read the file correct . That didn't work
Strange.
I have added some screenshot attachments.