PDA

View Full Version : update ruined my java install



b3nny
28th December 2006, 05:34 AM
ok guys need some good help here ...

I used wishwashy's technique to install java a while back and it worked great untill i did some sort of update and then it didnt work anymore.. i tried to retrace my steps to install it again .. im running 32 bit firefox etc.. i added the flash player 9 files back into the plugin dir but nothing worked. i then tried gnash but it dosent work either. now the flash icon is off the screen partially when firefox attempts to load a movie. ( the blue "f" icon) i tried to completely remove firefox to start again from scratch but do you think i know how to do that??? No! lol <-- weak ass newby) Anyhow im in a rut and it sucks i need major help.. i thought about re-installing java sun rpm archive that i downloaded straight from there site but i cant figure out how to install a rpm file that is already on my machine (downloaded) please help me i love FC6 but i need some help.

thanks.. sorry for being such a noob


edit: i removed gnash now i just get a blank screen instead of the movie playing..
edit: i think ive solved my java problem now its just this darned flash and firefox prob.

zeroelixis
28th December 2006, 03:37 PM
did you put libflashplayer.so into ~/.mozilla/plugins. That directory is not always there by default but FF looks there. If that doesn't help try with the Flash 7 version.

b3nny
29th December 2006, 10:15 PM
hi.

yes ive tried both of those options over the last while neither one work.. i tried completely uninstalling firefox to reinstall from scratch but i dont know how to do that properly so i think ive just buggered the whole mess up.. however firefox still does work just not the flash...

helps ! lol

b3nny
4th January 2007, 08:11 PM
anyone... please some one walk me thru this from the top.. I would like to completely uninstall all firefox 32/64 bit re-install and re-fix the flash can someone please walk me thru this.. thanks !

bob
4th January 2007, 08:53 PM
Try this 'how-to': http://jimlawrnc.mine.nu/mywiki/Flash9Install

b3nny
5th January 2007, 05:38 AM
i even have the t-shirt from that tutorial (tried it a while back)...i wish it was that easy...still wont play... it worked before i did a update of some kind didnt pay attention to what update it was (some lib file ) didnt think it would hurt my firefox and flash. I did a ton of research the 1st time i isntalled flash downlaoded firefox 32 bit - did the flash tutorial that wishwashy posted worked for a week untill fedora automatic update broked it. Now i have completely mangled firefox... also tried everything that fedoraforum /google can provide...Help

Noneus
5th January 2007, 05:11 PM
Delete your current flashplayerplugins:

rm -f /usr/lib/mozilla/plugins/libflash* ~/.mozilla/plugins/libflash*

yum remove firefox
yum install firefox

Although I doubt that will help. If it helps ok. If not than I guess your Firefox profile is broken in some way. To save your Bookmarks:

cp ~/.mozilla/firefox/*/bookmarks.html ~

Then save

mv ~/.mozilla/firefox /some/backupdir

or delete

rm -rf ~/.mozilla/firefox

your profile.

Next: Start firefox again and it will start with a fresh profile. You can Import your bookmarks.html with the BookmarksOrganizer in firefox.

b3nny
5th January 2007, 10:01 PM
thanks will try this tonight.

Noneus
6th January 2007, 02:41 AM
Ah. And I wouldn't install the flashplayerplugin to /usr/lib/mozilla/plugins There is no advantage to ~/.mozilla/plugins, but that all users can use it.

b3nny
6th January 2007, 05:18 AM
so i should just install it to the .mozilla/plugins in my home dir instead of in the use/lib? sorry just want to clarify.. thanks!

also will the yum command to remove firefox remove both the 64 and 32 bit versions that i have installed?

thanks!

Noneus
6th January 2007, 09:31 AM
yes it will remove both. If you want to remove just one you have to specify like yum remove firefox.i386 for example yum install firefox will install both too.

b3nny
6th January 2007, 06:08 PM
Hi there is this the problem, i did a about : plugins after i reinstalled firefox and re-added the libflsah file... and i notices the libtotem is at each entry for every plugin.. is it overwritting my macromedia flash entry and (Not working as well) and is it safe to do a yum uninstall libtotem w/o recking other stuff (i do have other media players)

thanks!

Totem Web Browser Plugin 2.16.3

File name: libtotem-basic-plugin.so
The Totem 2.16.3 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/ogg Ogg multimedia ogg Yes
video/mpeg MPEG video mpg, mpeg, mpe Yes
audio/wav WAV audio wav Yes
audio/x-wav WAV audio wav Yes
audio/mpeg MP3 audio mp3 Yes
Helix DNA Plugin: RealPlayer G2 Plug-In Compatible (compatible; Totem)

File name: libtotem-complex-plugin.so
The Totem 2.16.3 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
audio/x-pn-realaudio-plugin RealAudio document rpm Yes
Windows Media Player Plug-in 10 (compatible; Totem)

File name: libtotem-gmp-plugin.so
The Totem 2.16.3 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/x-mplayer2 AVI video avi, wma, wmv Yes
video/x-ms-asf-plugin ASF video asf, wmv Yes
video/x-msvideo AVI video asf, wmv Yes
video/x-ms-asf ASF video asf Yes
video/x-ms-wmv WMV video wmv Yes
video/x-wmv WMV video wmv Yes
DivX Web Player

File name: libtotem-mully-plugin.so
The Totem 2.16.3 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
video/divx AVI video divx Yes
QuickTime Plug-in 7.0 (compatible; Totem)

File name: libtotem-narrowspace-plugin.so
The Totem 2.16.3 plugin handles video and audio streams.

b3nny
6th January 2007, 06:44 PM
well i uninstalled totem and reapplied patches for flash beta 9 with no luck stuck those files in every friggen mozzilla dir i could find no luck, then i installed the flash 7 files no friggin luck.. I think that when i launch the firefox -32 that its still launching the 64bit version thats why nothing is working.. i dont know how to fix this...now when i do about : plugins it says there are none installed. I may try to re-installl totem .. i dont really know what im doing so perhaps totem isnt the problem.??

WHAT BS YOU WOULD THINK ADOBE WOULD HAVE THEIR **** TOGETHER!

Noneus
6th January 2007, 07:50 PM
yes it could do that. you could ...

1. edit the /usr/bin/firefox script with root.
Change this:

if [ -x "/usr/lib64/firefox-1.5.0.9/firefox-bin" ]
then
MOZ_LIB_DIR="/usr/lib64"
fi
to his:

#if [ -x "/usr/lib64/firefox-1.5.0.9/firefox-bin" ]
#then
# MOZ_LIB_DIR="/usr/lib64"
#fi

2. install nspluginwrapper: http://gwenole.beauchesne.info/projects/nspluginwrapper/
It makes 32Bit Plugins usable in 64Bit firefox.

b3nny
6th January 2007, 08:06 PM
Its helpful people like you that make me so happy/successful!!!

A giant thank YOU!

I think it was commenting out the starting of the 64 bit firefox and that being why flash was not working no matter what i did.. that was the secret. now i can use flash and firefox and now only winxp for games.. i should be spending more time here in FC6 where i want to be now!

also the wrapper program looks nice not sure if it had anything to do with it or not but when i doanloaded the plugin and viewer i really liked how it auto installed.. more linux stuff should be like that!! imho

learned lots today thanks! :D :D :D