PDA

View Full Version : Problem with new kernel rpm



Jongi
26th December 2006, 10:52 PM
Here is what happens when I try to run kernel-2.6.18-1.2868.fc6 which I updated using SMART. This is a desktop PC.



ACPI: Getting cpuindex for acpiid 0x1
ACPI: Getting cpuindex for acpiid 0x2
ACPI: Getting cpuindex for acpiid 0x3

Red Hat Nash version 5.1.19.0.2 starting
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory

ERROR opening /dev/console
Trying to use fd 0 instead
WARNING: can't access (null)
exec of init ((null)) failed!!! Bad Address
Kernel panic - not syncing: Attempted to kill init

Also why is it that SMART doesn't delete the kernel that yum normally would?

The 2849 kernel works.

Jongi
26th December 2006, 11:29 PM
Used SMART to remove the kernel, and then installed via a yum update -y kernel*

Same problem.

Jongi
27th December 2006, 06:42 PM
I've also tried the following options on the kernel line

1) all-generic-ide
2) irqpoll
3) pci=nommconf

Jongi
27th December 2006, 08:08 PM
The solution to the problem was a simple one. There was one difference between the 2849 and 2868 grub kernel lines. The 2849 had root=LABEL=/ whereas 2868 had root=/dev/hdd6. Once I changed the 2868 line to reflect what the 2849 line was showing it booted without issues.

I had previously seen the difference however I didn't think it would matter as /dev/hdd6 is mounted as /. And it isn't part of a LVM physical volume, just a reiserfs partition.

EDIT: The answer to this problem lies herein in this thread (http://www.fedoraforum.org/forum/showthread.php?p=730491#post730491). The issue is with my fstab mounting /dev/hdd6 as the root partition whereas the actual install is on /dev/sda5.