PDA

View Full Version : fc6 YUM Missing Dependency - help



Rick P
26th December 2006, 10:32 PM
Help,
I'm trying to install Apache 2.2.3
Error: Missing Dependency: libpq.so.3 is needed by package httpd

I found libpq.so.3 in an old Postgres rpm, but couldn't install it because I have a newer version with Postgres 8.2

So I extracted the library and placed it in /usr/lib and changed the owner, etc. It is there with versions 3, 4, and 5.

I still get the error, so I enabled all of the repositories in YUM, but I still get the error.

The lib file is there. Anyone have any ideas on how to tell YUM that it's there?? Do I need to reboot?
Thanks,
Rick

Rick P
27th December 2006, 04:47 AM
To get around this, I downloaded the source for Apache and compiled it.
- Rick

Jman
28th December 2006, 03:41 AM
FYI, FC6 does have httpd 2.2.3, a simple yum install httpd works.