PDA

View Full Version : Skype problems fixed...well sort of.



phefner
26th December 2006, 08:09 PM
I've been an avid FC user for the last several years (beginning with Red Hat 8), and have learned quite a bit about using it. However I could NEVER figure out how to get Skype to record audio properly, so I could actually talk to people. Well, as of 3 days ago, I discovered a work-around that has enabled me to be able to voice chat, using Skype.

Here is my current set up.

AMD Athlon 64 3000+
ULi K8U-X motherboard
2 GB of RAM
SoundBlaster Live! 5.1 (PCI Sound Card)
AC '97 on-board audio (previously disabled as I never use it, but re-enabled now)
Fedora Core 6 with KDE (3.5.x latest stable)

I tried tried hi-jacking the audio and re-directing it. I tried both ALSA and OSS for the sound system. I also tried Gnome for the desktop instead of KDE, but still nothing.

Finally out of desperation, I plugged my microphone into the mic jack on my onboard audio (I never use on-board audio, so I disable it) but left my speakers plugged into my SoundBlaster card. I went into the options of Skype (1.3.53 rpm) and selected the sound device input to be my on-board audio controller (which skype recognized) but left everything else on my Creative Labs (unknown) card.

So the only conclusion that I can come up with is that the SoundBlaster Live! 5.1 card doesn't have very good support in the kernel as a recording device, or in the Skype software itself. Of course, this is just a guess, but really I'm just happy to finally be able to use Skype for voice instead of just text chatting with people.

So for anyone else that uses a similar set up but can't record audio with Skype, try something like this. Has anyone else had to do a similar thing to get it to work on their system?