PDA

View Full Version : Audio badly distored with Mplayer/vlc missing dependencies



fancylad
24th December 2006, 04:18 PM
I have recently reinstalled core 5 and have installed mplayer; however the audio for most files is badly garbled and distorted. It will play .wav files fine and some video files with .avi the audio will he fine too (but not all). i have tried searching for information on this but haven't been able to find anything useful. i just don't understand what is going on. with my previous installation of core 5 it worked fine. here's what's in my /etc/yum.reos.d directory:

dries.repo fedora-legacy.repo livna.repo
fedora-core.repo fedora-updates.repo livna-testing.repo
fedora-development.repo fedora-updates-testing.repo macromedia.repo
fedora-extras-development.repo freshrpms.repo
fedora-extras.repo livna-devel.repo

does anyone know what is going on here? also i have tried to install vlc by using yum install videolan-client, it installs but then says this:

Error: Missing Dependency: libiso9660.so.4 is needed by package videolan-client
Error: Missing Dependency: libcdio.so.6 is needed by package videolan-client

i don't understand. isn't yum supposed to resolve dependency issues? the other puzzling thing was that vlc was working on my previous installation of core 5.
for the record, i wiped out the partition that core 5 was on before i did the re-install. so this isn't the issue. if anyone can help me with this i will very appreciative.

thanks

nick.stumpos
24th December 2006, 05:07 PM
do you always have all those repos enabled?, mixing repos is a known cause of problems, as they do not all follow the same naming standard, and various other issues. This often leads to dependency errors

fancylad
24th December 2006, 05:24 PM
so what repositories should i get rid of then? i want to use mplayer and vlc player for sure.

nick.stumpos
24th December 2006, 05:30 PM
the trio i always reccomend is livna, core and extras, they seem to have everything ive ever needed mplayer and vlc for sure will be in there. you can try uninstalling wehat you have tried to install so far, then only enable these repos and try the installs again, not sure how long you have been using the mioxed repos though could have hosed alot of stuff, your fastest and safest bet would be to backup your data and do a frsh install, takes two hours tops, and you know you are starting with a clean system, then just add livna, as extras and core are there by default, and then install to your hearts content