PDA

View Full Version : FC6: 2 K3b questions



1xused
23rd December 2006, 04:07 PM
I have a couple questions related to K3b.

1) How can I write CDs / DVDs from a normal user account? I get tired of switching to root every time I need to burn a disc. K3b fails 100% if I don't.

2) I have a DVD+RW DL drive, and when I insert a DVD+R DL disc, K3b recognises it as such. When I try to burn data to it, I get an error.

Waiting for media...
Writing Double Layer DVD+R.
Using growisofs 6.1 - <copyright>
Starting writing...
:-( unable to anonymously mmap 335544321 Device temporarily unavailable
fatal error at startup: Device temporarily unavailable
mkisofs did not exit cleanly.
Error while creating ISO image.

Last I tried, I could burn CDs and single - layer DVDs without problems. CAN K3b actually burn DVD+R DL? If so, how can I fix this?

Brian1
23rd December 2006, 07:57 PM
There is aprogram called k3bsetup that sets the permissions to allow users to use the need apps to burn CD/DVD. I am assuming you are using a precompiled version RPM of K3B. If so then I have seen some not to include the k3bsetup tool. Why is unknown. I usually install the latest source version. I sometimes build my own rpm from the src.rpm and they seem to contain it. Not sure on that. I usual plug in the latest and build from that.

Search here for k3bsetup or on google.

Never burn a DL disc so can't say.

Brian

1xused
29th December 2006, 09:19 PM
Ok, I'll try getting and compiling the source. Thanks, I'll post if I need more help.

Botond
6th January 2007, 02:25 PM
Here's what worked for me: http://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=31981&forum=10&post_id=139479

IMPORTANT NOTE for 6.0 users! Newer Linux kernels have ridiculously
low default memorylocked resource limit, which prevents privileged
users from starting growisofs 6.0 with "unable to anonymously mmap
33554432: Resource temporarily unavailable" error message. Next
version will naturally have workaround coded in, but meanwhile you
have to issue following command at command prompt prior starting
growisofs:

* if you run C-like shell, issue 'limit memorylocked unlimited';
* if you run Bourne-like shell, issue 'ulimit -l unlimited';


The strange thing is that this error appeared with the latest update, although I haven't updated my kernel (I'm still running a modified 2.6.18-1.2239).

1xused
10th January 2007, 10:23 PM
When I try to compile the latest version of k3b, I'm told that it can't find my X includes.

rts549
21st January 2007, 03:21 AM
May need to set write buffer size manually using settings tab in K3B. Had same errors, used default 4MB setting. Works now.

ilbh
21st January 2007, 05:11 PM
When I try to compile the latest version of k3b, I'm told that it can't find my X includes.

install kernel-devel package