PDA

View Full Version : text has all turned into squares



C1ivey
22nd December 2006, 08:14 PM
Earlier today I created a file in my etc/ld.so.conf.d directory with the line
/usr/local/lib
as a program I was using required a library in this directory. Since then the program has worked but a different problem has emerged which is quite serious. It is that all the letters in any text on the screen has been replaced by squares. If I open a terminal then the text inside the terminal is fine but everywhere else it is just these squares. I assume that this problem came about as a result of me creating this new file in etc/ld.so.conf.d but I can't see why it should have done.
Also when I run ldcofig I get the message
./ldconfig: /usr/lib/libMrm.so.2 is not a symbolic link
which may be connected to the problem, although I don't know what to do about it.
I am running FC5 and as you've probably worked out I'm quite new to linux, and if anyone has any ideas as to how I should get the text back to normal again then that would be very helpful.
Thanks.

tomcat
22nd December 2006, 08:53 PM
try
yum install urw-fonts

C1ivey
22nd December 2006, 09:09 PM
Thanks fpr the reply Tomcat. I tried what you suggested but I got
Passing package install arguments
Nothing to do
Do you think that means I have the fonts installed but for some reason they are not being used properly?
Thanks again.

tomcat
22nd December 2006, 09:37 PM
I think so. I remember that the same thing happened to me on another distro some months ago and forcing a reinstall of the urw-fonts package fixed it.

C1ivey
22nd December 2006, 09:49 PM
I tried removing the .conf file containing /usr/local/lib that I added to etc/ld.so.conf.d and ran ldconfig again and when I restarted the fonts were all back to normal. I'm guessing that one of the libraries in /usr/local/lib is conflicting with another library that relates to the fonts. Is there any way that I can try to find out which of the libraries in /usr/local/lib is causing the problem?
Thanks again.

tomcat
22nd December 2006, 09:59 PM
Maybe /var/log/messages lists the conflict.

C1ivey
22nd December 2006, 10:38 PM
I have looked in /var/log/messages and I can't see anything that appears to relate to the problem. But then I'm not really sure what I am supposed to be looking for.
What I have done is create a new directory /usr/local_new/lib in etc/ld.so.conf.d and just copied the libraries that were required by the program into this directory. After running ldconfig the program works and the fonts are ok so this seems to have solved the problem.
Thanks.