View Full Version : madwifi and wpa configuration

22nd December 2006, 03:46 AM
I have been trying to get my ar5005 atheros internal card to work with wpa in FC6. I can get a wireless connection with no encryption and WEP, but not with WPA. I have tried NetworkManager and wpa_supplicant.
NetworkManager just locks up. Does anybody have an example of a working wpa_supplicant.config file that works.

24th December 2006, 06:17 PM
I have found in another post a working solution. Once I got the madwifi driver working and tested it on an unencrypted wifi connection. Following another post I used wpa_supplicant.

[root@tstlptp ~]# wpa_supplicant -BWw -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf

After this command I use

[root@tstlptp ~]# wpa_gui

to scan, configure, and connect to a wpa secured access point. This way I did not have to write a wpa_supplicant .config file. The only problem that remains is that getting a dhcp ip address . I deal with this problem by using these commands

[paulb@tstlptp ~]$ su -l
[root@tstlptp ~]# ifdown ath0
[root@tstlptp ~]# ifup ath0
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0... done.

This is not a perfect solution but it works.

24th December 2006, 09:15 PM
Just out of curiosity, why are you playing around with config files to get your wifi going? There's a much simpler way ... just download (yum) madwifi, kmod-madwifi, and NetworkManager (if you don't already have it) or Wifi Radar and off to the races you go. Either way the config files will be set up for you when you use your ath card the first time so there's no more playing around with those config files.

By default, installation of madwifi and kmod-madwifi will enable the wifi card on system boot. Nice thought, but terrible if you're trying to save up your battery on a laptop. Turn off the "thoughtful feature" option in Network Configuration and that will prevent wifi from turning on automatically when you boot the system.

When you've installed those drivers and proggies mentioned above you need only a command to start up wifi (whenever needed). Type (as root, of course)

# ifconfig ath0 up

At this point, NetworkManager, if running, should detect the wifi being turned on and then seeks to hook up to an AP that you specify. Enter the password (if protected).

Blamo! you're done. No config hassles.