PDA

View Full Version : Message bus / dbus service problem



1xused
22nd December 2006, 02:31 AM
FC5, gnome: After installing some things, I don't remember what all it was, I restarted my computer. When I logged in, I got a message saying that power saving features wouldn't work until I started / enabled the system service dbus (or Message Bus.) I checked the services, and it said that service was running. I got the same message after restarting my computer again. My screen saver won't turn on, either by waiting for a certain amount of time, or by clicking "activate screen saver" on the lock screen button I have on my top panel. I also cannot lock my computer / screen by clicking the same button. I used to have a group of disk mounter buttons on the same panel, but they've disappeared and I can't add them back on. I can add other things to the same panel.
Other posts on this forum say that it's a bug, and I should update things. I have a 56k connection and don't feel like downloading several hundred MB to update everything. Can this problem be solved by updating something? If so, what, specifically?
Thanks for helping.

1xused
22nd December 2006, 02:38 AM
Also, su, su - , and sudo don't work. They used to. The first two do nothing, and the third one always refuses the password.

1xused
22nd December 2006, 06:22 AM
Apparently the loss of disk mounter buttons is a side effect of Fedora thinking I have no cd or floppy drives. Inserted cds don't automatically mount. I haven't tried plugging my USB flash drive in, but I suspect it wouldn't work, either.

http://img183.imageshack.us/img183/2632/filebrowsermj8.png

When I try to switch to a console (at+ctrl+F1 - F6), I get this error message, printed over and over, with some numbers changing by 1 every time it's printed:

audit (1166764302.398:30330): avc: denied {read write} for pid=1948 comm="cupsd" name="error_log" dev=hda3 ino=6456373 scontext=system_u: system_r: cupsd_t: s0 - s0: c0.c255 tcontext=system_u: object_r: file_t: s0 tclass=file
tcontext=system_u: object_r file_t: s0 tclass=file