PDA

View Full Version : TI acx100 wireless PCMCIA - kernel 2.4.22-1.2174



spectrumver1
21st February 2004, 10:39 PM
A history report:
For anyone who doesn't know, the Texas Instruments acx100 chipset, primarily present in the D-Link 520+, 650+, and other D-Link cards - pcmcia or pci - with the '+' designation. This chipset is notoriously unsupported by Texas Instruments on the Linux platform. D-Link isn't helping this all that much either.
There is a binary driver that was leaked near the initial release of the chipset, but it's slow and breaks easily.
There is also the acx100 project. This is an open source project to design a fully functioning driver (modules) for the chipset via reverse-engineering and I/O testing.

Some background:
I tried the leaked binary driver when I first installed RH9 and it did NOT work. The card would initialize and activate as eth1, but it wouldn't associate with the wireless network with some kind of I/O error...basically the computer registered the hardware with the kernel but the communication's layer was distorted.
I tried to compile and install my own acx100 modules per instructions from houseofcraig.com. It displayed no errors with the hardware or the association, but there still was no talking to the internet.
After a few months of just using a hardwire connection, I came across the DAG apt-rpm repository and saw the acx100 kernel-module precompiled, ready to go...so I gave it a shot and it worked.
Now, I decided to switch to Fedora - redhat discontinuing their GPL distro and all, decided it was time to move on, as everyone else has. I'm very happy with the OS. Some priviledge diff's need some getting used to, but altogether a very comfortable OS.
I got apt-rpm installed and running, at least as fine as synaptic will let it, installed the acx100 modules, depmod -a. Everything's fine. I plug the card in...nothing. modprobe acx100, insmod error. I'm doing a little more investigation, but, anyone have any idea why this would work in RedHat and not Fedora?

Pues,
Hasta

mhelios
22nd February 2004, 05:23 AM
What version of kernel-pcmcia-cs are you using? You could try the testing package:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/1/i386/

Also, you might want to follow through this htread for pointers:
http://www.redhat.com/archives/fedora-list/2004-January/msg03730.html

Finally, there's:
http://acx100.sourceforge.net/

spectrumver1
22nd February 2004, 07:59 AM
I got it figured out....aparently the driver was preconfigured to read the firmware from /etc/acx100. I thought the firmware was built into the module, but I should have guessed that DAG would avoid the legal issue as much as possible.

Anyone who want's to set this up, I suggest getting the 1.9.8b firmware into /etc/acx100, and DLing the acx100 modules from http://dag.wieers.com/packages/kernel-module-acx100/

Anyways, there it is, sorry to waste the space on the server...all it took was an extra 5 hours of searching (remind me to check system logs FIRST next time)

hasta