PDA

View Full Version : httpd won't start automatically



Master_Kato
18th December 2006, 08:21 PM
Hi,

I've just installed FC6, having previously been using FC2 (though I did a fresh install). I was updating my various config files and after I updated my httpd.conf I started having this strange problem.

On boot, or service restart (service httpd start), httpd FAILS with no error message showing up on the screen or in the system log.

If I start httpd at the command line (/usr/sbin/httpd), not through service, it starts and works normally. My httpd.conf is in the default location of /etc/httpd/conf/httpd.conf

Before I edited httpd.conf it started up on boot as expected. So what is the difference in behavior between manually starting and starting as a service?

Any help would be greatly appreciated, this has me stumped!

Master_Kato
18th December 2006, 08:30 PM
It looks like maybe I do have an error message after all, and I'm getting similar problems with mysqld. I get this cryptic error messages in /var/log/messages :

Seemingly for httpd:

Dec 18 14:27:47 aeon kernel: audit(1166470067.000:391): avc: denied { search } for pid=1987 comm="irqbalance" name="net" dev=proc ino=-268435432 scontext=system_u:system_r:irqbalance_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=dir

Seemingly for mysqld:
Dec 18 14:26:51 aeon kernel: audit(1166470011.466:380): avc: denied { read } for pid=4245 comm="mysqld" name="mysql" dev=hda3 ino=1107982 scontext=user_u:system_r:mysqld_t:s0 tcontext=user_u:object_r:var_lib_t:s0 tclass=lnk_file


Could these be some issue related to SELinux ? I had to turn off one of the SELinux options to get dovecat working - might it interfere with httpd and mysqld as well?

digen
18th December 2006, 09:56 PM
In addition, you can disable SELinux enforcement for Apache HTTP entirely with system-config-securitylevel.

First, click the SELinux tab.

Click on the Transition tree.

Check Disable SELinux protection for Apache HTTP

Execute /etc/init.d/httpd restart

http://fedora.redhat.com/docs/selinux-apache-fc3/sn-debugging-and-customizing.html

You may as well disable SELinux for Mysql similarly.