PDA

View Full Version : mount fat32 on boot error,need help



terry04
18th December 2006, 02:59 PM
i'm new to linux world,since i 'm using a laptop ASUS A3414, there's lot of hardwares can't be detected in Redhat 9, so i switched to FC6.
But here i meet with an error:
I add 2 lines in /dev/fstab
/dev/hda5 /home/d vfat default 0 0
/dev/hda6 /home/e vfat default 0 0
where '/home/d' and '/home/e' are created by su
when reboot, i get messages like this:
cannot mount /home/d ...not a block device...
or something like follows
----------------------------------------------------------------------
i then chmod 777 /home/d
still get
can not mount /home/d write-protected ,mount read-only
can not mount /home/d read-only

still ,i can use mount /dev/hda5 /home/d , and it works well

how can i solve this problem?

thank you guys

terry,

ppesci
18th December 2006, 03:14 PM
In fstab, change 'default' and use 'defaults' instead.

HTH

Pietro Pesci Feltri

terry04
18th December 2006, 04:23 PM
In fstab, change 'default' and use 'defaults' instead.

HTH

Pietro Pesci Feltri


thank you for your reply, of course i wrote 'defaults'. it's my fault to type it wrong here,sorry
the solution is not the spell , i guess

ppesci
18th December 2006, 04:41 PM
Ok, then change defaults for auto,user

HTH

Pietro Pesci Feltri

terry04
18th December 2006, 04:58 PM
oh well, just now i seem to solve this problem by chance:
i changed the mount point to /mnt/d and /mnt/e
then no error messages occured
it is really strange ,right

but still thank you~and the classmate who suggested this thought to me : )

Dies
18th December 2006, 06:41 PM
I think it has something to do with Selinux if you want them in your home folder maybe try again after setting Selinux to Permissive or Disabled. Or just symlink, all the same.