PDA

View Full Version : FC6 Refuses to mount PATA drives



fearofcarpet
18th December 2006, 01:54 PM
I upgraded my system from FC4 to FC6 (using the x86_64 DVD) and ran into all kinds of strange problems with drives. I have two SATA drives and two PATA drives. FC lives on /dev/sda which, along with /dev/sdb*, mounts fine though the installer recognized them backwards (swapped sda/sdb) which drops GRUB into the command line (even though menu.1st is configured corrected) and forces me to enter kernel, initrd, and boot manually...

That is neither here nor there, what is troubling me is that FC6 won't mount my PATA drives. I can partition them and format them (but only using reiserfs - ext3 says the disk is in use by the system), but when I go to mount either /dev/hda* or /dev/hdb* it says the mount point is in use (which it is not) or the filesystem is already mounted (which it is not). /dev/hda* and /dev/hdb* do not appear anywhere in /proc/mounts or /etc/mtab... Is there a kernel module or system service that could be interfering with mounting/formatting ext3?

Oh, and before formatting hda I cloned a partition (with dd) to a file on another drive and I'm able to mount that file (-oloop) just fine. Also, if I boot to the Gentoo installation CD I can mount all the drives just fine... The FC6 installation CD cannot mount any of my PATA drives though - it says the same thing about them being "busy" or "in use", but prefaces with words like "apparently".

After fooling around with it for some time... I can mount my PATA drives of I add -oloop to the mount command...WTF??? Am I going to break something by mounting disk partitions with loop?

Here is dmesg | grep hd and grep ide:


testing NMI watchdog ... OK.
ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdc:DMA, hdd:DMA
hda: IC35L100AVVA07-0, ATA DISK drive
hdb: IC35L100AVVA07-0, ATA DISK drive
hdc: LITEON DVD-ROM LTD163D, ATAPI CD/DVD-ROM drive
hdd: HP DVD Writer 640, ATAPI CD/DVD-ROM drive
hda: max request size: 128KiB
hda: 201045600 sectors (102935 MB) w/1863KiB Cache, CHS=65535/16/63, UDMA(100)
hda: cache flushes supported
hda: hda1 hda2 hda3 < hda5 > hda4
hdb: max request size: 128KiB
hdb: 201045600 sectors (102935 MB) w/1863KiB Cache, CHS=65535/16/63, UDMA(100)
hdb: cache flushes supported
hdb: hdb1
SCSI device sda: 390721968 512-byte hdwr sectors (200050 MB)
SCSI device sda: 390721968 512-byte hdwr sectors (200050 MB)
SCSI device sdb: 976773168 512-byte hdwr sectors (500108 MB)
SCSI device sdb: 976773168 512-byte hdwr sectors (500108 MB)
hdc: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
hdd: ATAPI 40X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
b2c2-flexcop: initialization of 'Air2PC/AirStar 2 ATSC 3rd generation (HD5000)' at the 'PCI' bus controlled by a 'FlexCopIIb' complete
SCSI device sdc: 976773168 512-byte hdwr sectors (500108 MB)
SCSI device sdc: 976773168 512-byte hdwr sectors (500108 MB)
e1000: eth0: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex
e1000: eth0: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex
e1000: eth0: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex
hda: hda1 hda2 hda3 < hda5 > hda4
hda: hda1 hda2 hda3 < hda5 > hda4
hdb: hdb1
hdb: hdb1
hda: hda1
hda: hda1
hda: hda1
hda: hda1



BIOS-provided physical RAM map:
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Boot video device is 0000:01:00.0
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller at PCI slot 0000:00:02.5
SIS5513: SiS 962/963 MuTIOL IDE UDMA133 controller
ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
ide1 at 0x170-0x177,0x376 on irq 15
ide-floppy driver 0.99.newide