PDA

View Full Version : About installation for XMMS &Mplayer help!



Edward.Huang
18th December 2006, 05:26 AM
Dear All

I want to install XMMS and Mplayer into my FC6,but I can not use Yum,'cause I have not yet bought internet service.I tried to download XMMS and Mplayer's rpms via my office's computer and installed them into my FC6,but all failed due to missing many files.

Can anyone help to advise how can I install them withoud Yum? What essential packages should I install before installing the xmms and Mplayer?

Thanks in advance

Seve
18th December 2006, 07:30 AM
Hello:
Which repository are you downloading them from?


Seve

Edward.Huang
18th December 2006, 11:42 AM
I downloaded them from FC6 's extras storage

sgtbob
28th December 2006, 02:16 PM
I have downloaded xmms-1.2.10.tar.gz, moved it to a directory I titled 'xmms' in my home folder, ran 'gunzip xmms-1.2.10-tar.gz' as #, then cd to the subdirectory 'xmms-1.2.10'. When I run the './configure', I get teh follwoing:
[root@localhost xmms-1.2.10]# ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for prefix by checking for xmms... /usr/bin/xmms
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

Where am I going astray and how do I get the 'gcc', etc., items to then do 'make all'??

I have been trying to use the 'tarball' features for some time and simply do not understand them when I run into this issue. Please advise the aged FC6 user...


Bob

a_aryo
29th December 2006, 09:38 AM
hi..
i also have problems with xmms instalation..
when i downloaded xmms-1.2.10.tar.gz, i only need glib-1.2.2..but after i downloaded glib-1.2.2, it still didn't work...

i found in this web site about installing xmms player, here is the url http://www.mjmwired.net/resources/mjm-fedora-fc6.html
i started to download any files required for installation, which are xmms, xmss-libs, xmms-mp3, glib, gtk+..after that i followed the instruction, it still didn't work...

first, i installed the glib..and then gtk+, xmms-libs, xmms-mp3...the installation within those packages was succeeded..i tried to install xmms, but it was failed...
it was said : unzip is needed by xmms-1.2.10-29.fc6.i386.rpm

do any of you know what that's mean? i didn't find "unzip" as a dependency :confused:
just for information, i don't have any internet connection in my home..so i can't use yum

thanx for your help

Aryo