PDA

View Full Version : Can't run yum at all.



cnayak
17th December 2006, 10:54 PM
I got the following error message when I tried to install inkscape on FC6,


Loading "installonlyn" plugin
Existing lock /var/run/yum.pid: another copy is running. Aborting.


I tried restarting the computer but got the same error message again. AFAIK, no other app is using yum (I disabled the updater app). Any suggestions on where to look next?

Regards,
Chandan

Seve
17th December 2006, 11:10 PM
Hello:
You likely have yum-updatesd running in your services, it is enabled on the initial install.
from a terminal type system-config-services and disable/stop/turnoff yum-updatesd
save your settings and exit
then try
yum clean all
then
yum update yum
and you should be good to go.
Seve

u-noneinc-s
17th December 2006, 11:11 PM
ps -e |grep yum. If it returns any pid's kill 1234 where 1234 is the actual pid. I believe you can specify multiple pid's separated by a space kill 123 45 6789

If there are no instances running, post back. Someone will have an answer.

EDIT Darn, Seve. I finally beat you and I had to edit my post.

cnayak
17th December 2006, 11:14 PM
thanks a lot Mark. byw, here's the output,

2070 ? 00:00:00 yum-updatesd

u-noneinc-s
17th December 2006, 11:17 PM
Then just follow Seve's advice. That's the one he's talking about and the one I thought you disabled. I guess there are more than one "updates" process. Maybe you killed the cron.daily auto updates?