PDA

View Full Version : yum misbehaviour = openoffice downgrade



jwiz
17th December 2006, 10:15 PM
Hi all!

Yesterday I have decided to upgrade to the new OOo-2.1 version on my FC5 system, so I "yum removed" the old OOo-2.0.2 packages and "yum localinstalled" the new OOo-2.1 rpms.
Today I did a "yum upgrade" and this crappy tool still wants to install/downgrade to the previous OOo-2.0.2 packages. :mad:

How's that?

Jman
19th December 2006, 11:37 PM
Where did you get the 2.1 rpms from? The development repository?

I suppose when you yum updated, some dependency of OpenOffice.org got updated. When then required getting the right version of OpenOffice.org, and the only one available was 2.0.2 from the repository.

You can post some "yum -d 5 update" output for us to check.

If you did use the development repository, I only recommend doing so when you are committed to. See the testing guide (http://fedoraproject.org/wiki/Testing).

I can't wait for new software either, but not enough to mess too much with the devel branch.

jwiz
20th December 2006, 10:29 PM
I didn't use the devel repo rpms but "yum localinstalled" the official OpenOffice.org-2.1 rpms, after a "yum remove" of the previously installed OOo-2.0.2 rpms from stable.
Guess, I have to "yum remove" them again and just "rpm -i" them to keep yum away from them.

jwiz
20th December 2006, 10:46 PM
Tired thata few minutes ago, but it didn't work.
yum still wants to downgrade to OOo-2.0.2.
Damn rpm hell - high time RH migrates to .deb/apt.

RahulSundaram
21st December 2006, 01:17 AM
Tired thata few minutes ago, but it didn't work.
yum still wants to downgrade to OOo-2.0.2.
Damn rpm hell - high time RH migrates to .deb/apt.

This isnt a problem specific to RPM. If you install packages *external* to the Fedora repositories then you need to exclude them in the yum repository configuration file. The package format makes no difference here.

Paul_Vandenberg
21st December 2006, 02:19 AM
I added exclude=openoffice.org* to my /etc/yum.conf file. The only problem is that I had to disable puplet. It kept telling me I have updates and when I go to do the updates, it says there are none. Apparently pup and pirut use the exclude feature in yum.conf, but puplet doesn't.

Paul

rrkss
21st December 2006, 07:34 AM
I added exclude=openoffice.org* to my /etc/yum.conf file. The only problem is that I had to disable puplet. It kept telling me I have updates and when I go to do the updates, it says there are none. Apparently pup and pirut use the exclude feature in yum.conf, but puplet doesn't.

Paul

Once you exclude the packages the simplest way to fix this is reload the yum update service or just simply reboot the system to get puplet to sync with yum.conf.

paul matthijsse
21st December 2006, 03:40 PM
1. no need to remove any old OO 2.0.x install, just install the 2.1 version
2. yum is no crap in this case, it does exactly what you have asked it to do (namely: look in the repos and get the latest FC official/registered versions of software). When you install 'by hand' yum cannot know...

Paul_Vandenberg
22nd December 2006, 12:58 AM
Once you exclude the packages the simplest way to fix this is reload the yum update service or just simply reboot the system to get puplet to sync with yum.conf.

Whadaya know! It works. I guess I was too impatient.

Thanks!