PDA

View Full Version : Updating to FC6 breaks Tcl/Tk



Fibonacci
14th December 2006, 12:05 PM
Hello

I updated to Fedora Core 6 yesterday, via the installation DVD. Afterwards I found that my Tcl/Tk install, which I had compiled from source and was running fine under FC5, has some problems.

Under FC5, Tcl/Tk and apps written in it (including, of course, aMSN) would recognise dead keys for accented characters without a problem. Now, instead, whenever I press a dead key, it just prints out the corresponding diacritic - so, for example, if I try to write "naïve", it comes out as "naĻive".
Tried Tcl/Tk 8.4, tried 8.5a4, tried recompiling from source, but no dice - it always comes out as "naĻive".
This problem is not present in any other applications I have tried so far (ranging from gnome-terminal to Konqueror). And, as I said already, Tcl/Tk was working fine before updating to FC6.

Any ideas on why this might be happening and how to solve it?

Thanks in advance,

-Fibo

Fibonacci
14th December 2006, 07:12 PM
Just downloaded and tried Tcl/Tk 8.5a5, and the problem is still there.

Also, noticed that UUdeview and Xmaxima are also affected.

Fibonacci
15th December 2006, 03:25 AM
Just tried Tcl/Tk 8.5a5 on Ubuntu liveCD, compiling exactly the same sources as in Fedora, and it runs smoothly. The problem is clearly in Fedora Core 6.