PDA

View Full Version : Mount /mnt/cdrom freeze



sponge
19th April 2004, 03:43 AM
Well. when i try to mount my cdrom it ends up crashing. if i stick a cd in there. it crash's. i dont know whats going on but its bothering me a lot. anyone got any ideas?

ghenry
19th April 2004, 09:06 AM
I would think it's either your CD media or a faulty cdrom drive.

kbradl1
19th April 2004, 01:51 PM
Try mounting the cdrom outside of Gnome. Go to runlevel 3 "telinit 3" to get out of X. If you still have the problem, it is a bad cdrom drive. If you don't it is a bug in your DE.

sponge
20th April 2004, 02:10 AM
ok so i went to runlevel3, tried to mount it. and i got a bunch of timeout crap.

hdb: registering filesystem
hdb: timeout waiting for DMA
hdb: timeout waiting for DMA
hdb: ATAPI reset complete
hdb: Drive not ready
etc
etc
ETc

so think its mabey.. erm.. a old cd-rom that is just broke? lol or is this fixable.

crackers
20th April 2004, 03:35 AM
If it's "suddenly" stopped working (was working before, which I'm assuming was how you got Fedora onto the machine) and you haven't been in there mucking about with the hardware, I can only think of two things:

1) It's a cabling fault (either the cables went bad or you moved the computer and one got dislodged)

or

2) The CD-ROM just died on you.

Try a couple of different CDs, especially those that come from boxed, professional applications. If you can't mount any of them, then the best soution is to just go buy a new one. They run about $20US and you get the cable, too.

imdeemvp
20th April 2004, 04:51 AM
or better yet you can get one from eBay! a used one working in good condition will probably cost you $1.99 + shipping !

good luck!

puschel
17th May 2004, 07:17 AM
I have the same problem as sponge:

After I installed Fedora Core 1 I was able for a while to mount /mnt/cdrom and /mnt/cdrom1.

The I installed apt from fedora.us, did some normal work, and after a while mount /mnt/cdrom made my system freeze - no ctrl-alt-del or ctrl-alt-backspace works. The same happens in X and in concole mode.

I tried to install Fedora several times and always had the same problem - but always in different situations. So I can't say it happend after doing something special (installing some piece of software etc.). But the cdrom works for a new install and short after it, and it works fine under win98se. So it is not a hardware fault.

Any help appreciated.

donpay1
15th November 2005, 11:34 PM
I have the same issue. Rom has worked before in other install of fedora 4. I think it might be an issue fstab. I may just install again?

firestorm
16th November 2005, 12:27 AM
I had this problem with a homemade DVD. Turns out the DVD was the problem, the drive would mount a regular DVD just fine. I did however notice that my fstab thought my drive was located somewhere it wasnt. :(.

chili555
16th November 2005, 11:30 PM
hdb: timeout waiting for DMA
hdb: timeout waiting for DMA
hdb: ATAPI reset complete
hdb: Drive not ready

I had this exact problem when I installed FC4 on my wife's computer. I came to the conclusion it was the motherboard, an Asus P4P800S-X. I installed FC2 and it went perfectly. If you have a P4P800xx, search the web for "P4P800 linux"

donpay1
17th November 2005, 05:26 PM
I ghosted the system back to windows CD burner works fine; I have the same setup in another computer with the same brand (Sony). It works fine! The fstab looks the same the only difference is this is a AMD 64. I have had problem with the first install because the kernel on that cd did not support my system, by doing a text install and running YUM to upgrade the kernel I was able to get the system installed. Now I am wandering if I should recompile the kernel for my computer?

AMD 64 x2 4200
4 GB of ram
I have never done this an am a little reluctant.

donpay1
17th November 2005, 07:51 PM
The lockup is acting like an irq conflict. Is their a way to see the resource being used on the mother board?

safire
17th November 2005, 09:19 PM
I think it is 'hdc lost interrupt' problem
disable PCI IDE interrupt sharing
i've just answered here (http://forums.fedoraforum.org/forum/showthread.php?p=403420#post403420)

mbeain
16th April 2006, 09:50 PM
When I try /mnt/cdrom the system freeze and I can hear the disc spinning over and over.
I had to install Fedora by hard disk because the installer never could mount hdc.
But in Windows my cdrom drive works perfectly.
What happens??
Thank you.