PDA

View Full Version : Fuse kernel module



anaraug
29th November 2006, 11:23 AM
Hello, I'm somewhat new to Linux, having installed it zillions of times but having used it only seldomly, using FC5 on a x86_64 cpu, and trying to set up ntfs-3g.

ntfs-3g installed fine, but can't be used because it claims there's a problem with fuse. Based on my best guess after reading the ntfs-3g faq and a few forum posts, I'm supposed to be updating the fuse kernel module. Eventually, I figured out that I'm supposed to ./configure it with the --enable-kernel-module option when I install fuse. Doing this tells me that configure doesn't know where the kernel source is.

So... being a complete noob, I don't know where it is either, so could someone perhaps give me a hint? Hopefully this is my only problem because it seems like a small one. If what I said in the previous paragraph sounds idiotic, please correct me there, also. Thanks in advance!

Seve
29th November 2006, 06:45 PM
Hello:
You really should not have to do anything extra with either ntfs-3g or fuse. Did you manually install ntfs-3g ? If so, uninstall and use yum.
Both are in the fedora-extras repository and if installed with yum you should be good to go.
yum install ntfs-3g
will also install the fuse rpm
then all you have to do is create a mount point and edit your fstab to mount your ntfs partition(s)

Seve

anaraug
29th November 2006, 08:04 PM
Oh, ok. I thought I read that it was only on yum for FC6, not FC5, but I didn't actually try it... It seems to have installed correctly, but I'm still getting the same error as before from fuse "fusermount: mount failed: No such device ".

To mount it I'm just doing
ntfs-3g /dev/sda1 /mnt/windows -o force

I was told that this is because the kernel probe for fuse is outdated, so that's why I was trying to update the kernel.

Seve
29th November 2006, 08:12 PM
Hello:
To mount your /dev/sda1
log in as root using
su -
gedit /etc/fstab
and add
/dev/sda1 /mnt/windows ntfs-3g defaults 0 0
leave a blank line after
save, exit and reboot and you ntfs drive should be mounted
under /mnt/windows

Seve

szaka
29th November 2006, 09:00 PM
Oh, ok. I thought I read that it was only on yum for FC6, not FC5, but I didn't actually try it... It seems to have installed correctly, but I'm still getting the same error as before from fuse "fusermount: mount failed: No such device ".

To mount it I'm just doing
ntfs-3g /dev/sda1 /mnt/windows -o force

I was told that this is because the kernel probe for fuse is outdated, so that's why I was trying to update the kernel.
Do a 'make uninstall' in the fuse-2.6.0 source directory. If you install an older version of the software then it won't always overwrite the newer one. This is why you still have the FUSE 2.6.0 problem.

anaraug
30th November 2006, 02:02 AM
Ok... I started over from a fresh FC5 install.

After doing yum install ntfs-3g, it installs correctly, probably. I edited fstab, but now, during bootup it says "failed" "permission denied". Do I need to change some kind of user permissions or something?

Seve
30th November 2006, 02:14 AM
Ok... I started over from a fresh FC5 install.

After doing yum install ntfs-3g, it installs correctly, probably. I edited fstab, but now, during bootup it says "failed" "permission denied". Do I need to change some kind of user permissions or something?
Hello:
Sorry about the re-install
What is the directory / mount point that you are using?
If you have not already done so you will need to disable SELinux or set it to Permissive

Seve

anaraug
30th November 2006, 02:21 AM
I needed to reinstall anyway -- I'd messed up quite a few things. Still learning :)

/dev/hdc1 /mnt/big ntfs-3g defaults 0 0
/dev/hda5 /mnt/small ntfs-3g defaults 0 0

is what i have in fstab now, for those mouse points.

Seve
30th November 2006, 02:26 AM
I needed to reinstall anyway -- I'd messed up quite a few things. Still learning :)

/dev/hdc1 /mnt/big ntfs-3g defaults 0 0
/dev/hda5 /mnt/small ntfs-3g defaults 0 0

is what i have in fstab now, for those mouse points.

Hello:
Looks fine, so try disabling SELinux

Seve

anaraug
30th November 2006, 02:35 AM
Hooray! It works now! Thank you very much.