View Full Version : Yum can`t connect though internet works

28th November 2006, 03:23 PM
Hi, just installed FC6 and I have a problem with yum, on any attempt to update/get list etc i get

Loading "installonlyn" plugin
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
http://ftp.chg.ru/pub/Linux/fedora/linux/extras/6/i386/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (101, 'Network is unreachable')>
Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: extras

I tried adding freshrpms and livna repositories, but I still get error with http://ftp.chg.ru...

Any help would be much appreciated.

28th November 2006, 03:41 PM
Problem solved ) with solution from another thread - uncommenting baseserver adress...

However i still don`t get it - why didn`t yum tried to switch to another mirror ?

28th November 2006, 03:44 PM
can you ping any host?
if not maybe the default route is wrong or missing
are you using a proxy?
if so, you should set the environment variable; like:

export http_proxy=http://proxyserver:port

28th November 2006, 04:26 PM
Thanks for your reply :)

but as I said earlier problem was solved - by uncommenting url of base server in extras conf. It seems, that for some reason yum doesn`t try to get other mirrors if first one fails.

28th November 2006, 08:57 PM
I used to suggest re-commenting the base urls when done to help reduce the load on the base, (maybe it doesn't matter anyway), but this seems to be an increasing problem. Perhaps the mirror lists are incomplete or corrupted or something.

At some later date you might try commenting the base out again and trying just to see if maybe it was a problem with the mirrors. Or maybe running yum (with the mirrors again) with -d 10 option and see if it isn't trying a lot of mirrors and only reporting a couple. I did this once just to see what kind of info passed by and I was surprised to see the number of mirrors that just flashed by while searching extras (occasionally stopping on one momentarily) until it finally found a good mirror.

I have not yet installed FC6, and have had little to no problem with yum on FC3 or FC5 (except needing to uncomment base when the repos were getting hammered with FC6 release)

29th November 2006, 12:42 AM
Uncommenting wasn`t possible since without it I could not even get a repository xml file. It seems that in my case the problem wasn`t in yum - as I figured there is only one mirror for people with russian IP`s and it is currently down )

I think I found another solution. If you simply get mirrorlist with a browser (replacing variables with actual values), you could see that beside "repo" and "arch" vars from url there is a third var - "country" that is set automatically. However if you pass it in url it is set to the passed value. So in my case I passed global (mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-$releasever&arch=$basearch&country=global), and everything worked without base url. There are plenty of global servers, so overloading shouldn`t be a problem.

ps. about yum skipping good mirrors - this was probably done intentionally in order to select random server each time and spread load evenly between servers.

29th November 2006, 01:05 AM
Wow, I never thought of any of these "otherwise random" yum problems being locale based. That's probably a very good catch and I hope more members are reading this post.
I have bookmarked this post for future reference.