PDA

View Full Version : Can't record sound from microphone on Fedora Core 6



chuong
26th November 2006, 07:53 AM
I can't seem to record any sound from the microphone on Fedora Core 6.

I have Audacity and the recording is set to /dev/dsp not sure if tha'ts right but that's the default setting.

I know my microphone works because I can hear myself speaking from the output of the head phones.

Anyone know how to record sound using microphone?

fozner
26th November 2006, 11:00 AM
Audacity required LOTS of fiddling to make-work for me. I did not mess around with any config files.

Basically, just fire up Audacity, go into settings, Click on and off software playthru and play other tracks while recording. I don't know if this matters, but I also chose 32 bit float. (no, probably doesn't matter).

What made the difference, I think was also playing with kmix and / or alsamixer and turning on "mix" and "capture" as well as "mic" and setting the volume sliders on each. and back-and-forth between fiddling with kmix and trying to record. Finally it worked. I dread working with it now.

chuong
26th November 2006, 07:06 PM
Ok . . . then.

yocum
8th July 2008, 03:29 PM
Use amixer or gnome-alsamixer to set the Mic to capture mode, and the Capture to capture mode (seems to obvious...). For example, using amixer:

amixer sset 'Mic' cap
amixer sset 'Capture' cap

Additionally, you may need to set the ADC to capture mode (if you have an ADC), as well:

amixer sset 'ADC' cap

yocum
8th July 2008, 03:30 PM
Oh, for reference, I got these instructions from here (scroll down to the [5] Microphone section):

http://www.richardneill.org/a22p-mdk11-0.php#sound

chuong
8th July 2008, 03:32 PM
Uh. . .okay then. . .isn't this post. . .*checks watch*

...

2 years ago ?

:D

Wayne
8th July 2008, 03:35 PM
Well, that depends on how well your Tardis is working :)

It seems some folks live in the past... or try to dig it up when they can.... If you have no objections then we can consign this thread to the scrap heap...

Wayne