PDA

View Full Version : FC6: strange mouse behaviour



Jantje
24th November 2006, 05:05 PM
hi,

today I updated my packages with yumex, and after the update, my mouse doesn't work properly anymore. It's acting 'jumpy' and when I move, it seems to move in slow motion. I tried changing the speed settings, but that doesn't help. The mouse us an optical USB mouse, put on a USB-PS/2 converter, because I use a Belkin KVM Switch. When plug the mouse in, directly in a USB port, it works fine. But with the PS/2, it doesn't anymore. Any ideas to fix my problem? I run the 2.6.18-1.2849.fc6 -kernel on a AMD 4400+ processor.

thanks,

Jan

tashirosgt
25th November 2006, 03:23 AM
The FC6 relase notes say that the new scheme for the X server expects that it will detect things like keyboard and mice automatically without finding them in /etc/X11/xorg.conf. But you might try putting an entry for your mouse in /etc/X11/xorg.conf and see if you can override the misconfiguration of your mouse.

Jantje
25th November 2006, 12:27 PM
hi there, thanks a lot for your tip! I added following section to my xorg.conf :

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

My problem is solved now, it's probably like you said, the misconfiguration is now overruled... Thanks a lot!