PDA

View Full Version : Cannot format SATA drive under FC6



bk_InAZ
24th November 2006, 11:58 AM
This disk worked fine under XP. I dumped XP on the new machine and am trying to get the drive installed as the 2nd SATA drive. It's a 250GB drive. The primary drive is 160GB. A few weeks ago I installed a 2nd (200GB) EIDE (parallel) drive on another Linux machine and had no problem.

I tried GParted, and the command-line tools (fidisk, mkfs.ext3 , mkfs...) I tried different partition types with fdisk, and tried ext2 and ext3 filesystems. I keep getting this error: "Attempt to read block from filesystem resulted in short read while creating root dir".

I have tried at least 10 times, and rebooted the machine almost as many (which seems to matter with GParted).

Can someone give me a proven procedure for doing this? I prefer to use the ext3 filesystem.

As I mentioned, I have done it before, and I have also Googled and searched these forums, but nothing has worked. I even used "dd" to copy "00"'s to the entire drive thinking that maybe there was some remant from XP that was messing it up. I'm at a loss, so your help is much appreciated.

Bill

multescugeorge@
24th November 2006, 12:18 PM
see this, perhaps you have the same issue
http://www.linuxquestions.org/questions/showthread.php?p=2489404

giulix
24th November 2006, 02:08 PM
A low-level format (or whatever is called nowadays) should fix this kind of problems, if it's not hardware-related. The site of your hard drive manufacturer will almost certainly allow you to download some kind of utility to attain this...

bk_InAZ
24th November 2006, 08:22 PM
Thank you both for your replies. My post was getting long so I didn't mention the thread that mulescugeorge referred-to, or the low-level format that guilix made reference to. There's no utility on WD's site for a true low-level format (and some research has led me to the conclusion that IDE disks don't really have a real low-level format capability as that would destroy the factory-installed geometry information and some other key items). Nevertheless, the suggestions are very much appreciated. I am out of ideas to try so other perspectives (and experience) are much appreicated.

I tried "dd if=/dev/zero of=/dev/sdb" to write zeros to all the available bytes on the drive. That didn't seem to accomplish anything useful. I am going to try the same thing with WDs DataLifeguard tool.

I guess I should note that I installed the 200GB PATA drive on a machine running RH9. The command-line tools should be the same, though.

Thanks,

Bill

rappermas
24th November 2006, 08:36 PM
I would try making a Gparted live cd, or a ubuntu live cd, as it comes with gparted. Make the new SATA drive the only drive in your computer--temporarily. From a LiveCD, format it with Gparted into whatever you want. That should take care of any problems.

bk_InAZ
24th November 2006, 10:38 PM
It looks like it was an electical problem with either the cables (bought on eBay, or the motherboard). I need to test further to find out. The WD "write zeros" function seems to be working now. So I can probably partition and format the drive as expected. Just to be safe I made a Gparted Live CD as rappermas suggested. If you don't see another posting from me in this thread, it's working fine (at last).

Many thanks to all who made suggestions.

Bill