PDA

View Full Version : yum.repos.d



mamoo
23rd November 2006, 11:01 PM
can any1 please forward me his/her folder of yum.repos.d?
i mess up a bit toooooooooo much with it
now i cant download
plz help
thnx

Seve
23rd November 2006, 11:11 PM
Hello;
Yes, I would happy to if you delete this :http://forum.fedoraforum.org/forum/showthread.php?t=138602

Seve

Dies
23rd November 2006, 11:14 PM
Here you go, you might want to remove beryl and dries if you don't use them.

Seve
24th November 2006, 12:13 AM
Hello mamoo:
Here is the contents of my yum.repos.d folder:
Use at your own risk:

/etc/yum.repos.d/dries.repo
/etc/yum.repos.d/fedora-core.repo
/etc/yum.repos.d/fedora-extras.repo
/etc/yum.repos.d/fedora-updates.repo
/etc/yum.repos.d/freshrpms.repo
/etc/yum.repos.d/livna.repo

Seve

Cancel
24th November 2006, 06:58 AM
I have a problem with just my livna.repo. I am always getting a warning that says: Cannot find a valid baseurl for repo: livna

Now I only have Livna as an extra repo for yum. I set it Livna up for smart and it works fine. How can I figure out what I did to the yum repo and fix it??

Seve
24th November 2006, 07:13 AM
I have a problem with just my livna.repo. I am always getting a warning that says: Cannot find a valid baseurl for repo: livna

Now I only have Livna as an extra repo for yum. I set it Livna up for smart and it works fine. How can I figure out what I did to the yum repo and fix it??
Hello:
Not sure if you are on FC4, 5, 6 ?
Have a look here: http://rpm.livna.org/rlowiki/UsingLivna
to configure your yum to enable the livna repo

Seve

Cancel
24th November 2006, 09:05 AM
Hello:
Not sure if you are on FC4, 5, 6 ?
Have a look here: http://rpm.livna.org/rlowiki/UsingLivna
to configure your yum to enable the livna repo

Seve


Ooops, my bad.... I am on FC 6. I did the rpm -ivh http://rpm.livna.org/livna-release-6.rpm about 15 times now out of pure desperation thinking I screwed something up. All it says is it is already installed. This proves beating your head on the same spot of the table repeatedly has the same result as doing it once lol. Yum works flawlessly when I disable the linva repo. I was thinking maybe the server is down, but as I stated before, Smart works. I just hope I can repair it somehow.

Thanks for replying!!!

mamoo
24th November 2006, 11:32 AM
thnx seve
but i got about 5-6 text files in my repos
and u gave me only one
where to paste it?

mamoo
24th November 2006, 09:46 PM
i am on fc5

Dies
24th November 2006, 09:55 PM
All you have to do is copy each one into a text file and name it accordingly but here this will be easier:

Dies
24th November 2006, 09:57 PM
To disable any repos you don't want just open the text file as root and change the line that says enable=1 to enable=0. The only enabled repos that aren't standard are livna and beryl btw.
And like Seve said use at your own risk.

mamoo
24th November 2006, 10:38 PM
thnx guys!!!
thnx very much
wil try it tomorrow

Cancel
25th November 2006, 04:30 AM
Seve, Dies thanks so much for your help too. I used the livna.repo that Dies supplied and it works again!!!! And thank-you mamoo for starting this post!!

I am so happy to have Fedora running the way it was meant to!!!!!

timcorless
25th November 2006, 05:49 PM
That livna.repo was just the trick, I only used that one.

Can you explain how it works though please? Its very different to the basic ones supplied in other threads and other websites etc...