PDA

View Full Version : Adaptec 2010s 79xx and I2o_block driver



Dominique007
23rd November 2006, 06:54 AM
Hello

I am installing Fedora Core 6 on a dual boot system with Windows XP. Dual boot is setup with Norton BootMagic and everything is OK.

I have two Adaptec SCSI RAID cards a 39320A/R and a 2010. The 2010S is a ZCR (Zero Channel Raid) that is coupled to the AIC7902 chip on my motherboard. When the 2010s is installed it hides the AIC-7902 reason why it is not found in system scan.

The Fedora Core 6 installation program does not recognize my Adaptec 2010S card. It does recognize the 39320A/R.

I found the solution to my problem in a post on this forum. Pretty simple, at install prompt type "linux dd" to install the Adaptec 79xx driver and I2o_block driver. I searched high and low and cannot find those drivers on the web and do not have the slightest clue on where to find them on the Fedora Core 6 installation DVD. I did find Suse drivers on Adaptec website but the Fedora installation program rejects them. :)

1- Where are the Adaptec 79xx and I2o_block drivers on the Fedora Core 6 DVD?

2- Is there an extension used to identify drivers in Linux? ie: Windows uses *.inf

3- Any recommended source to get the drivers?

4- Any suggestions or command at installation to force drivers to install?


Any help will be greatly appreciated.


Dominique007

agutkind
25th November 2006, 01:31 AM
Bonjour,

I continue my research.

I have the same problems, Fedora seems to be clean with most raid products like we can read, but not with the adaptec 2010s (and certainly other cards).

I have updated the bios of the motherboard (Supermicro) and the bios of the raid card (Adaptec 2010s).
I have tried to install Fedora 6 or 3, or Solaris 10, and it is the same problem, arrived at hard disk discover, no disk detected with raid card installed, array raid 5 of 4 disks or disk alone.
But if I put out the raid card, disk alone is recognized and it is also posible to make logicial raid!
---------------------------------------
Response of Supermicro help desk:
---------------------------------------
Q:Thank you very much for your respons, but for the SuperMicro's motherboard of the server 7043M8 (Super X5DMS-8GM), it is not enough to be recognize, the chip on motherboard is the 7902, not the 7901.

R:The difference between 7902 and 7901 is 7902 is dual channel and 7901 is single channel. Other than that, the driver and firmware are the same. The issue you are having is the ZCR does not have driver for the OS you want to use.
-------------------------------------------------------------------------------------

Q:For the motherboard (X5DMS-8GM), bios vers 1.6a
For the Adaptec raid card 2010S, bios rev 3B0a
For Fedora 6 like for Solaris 10, always no disks are recognized.

R:You will need to add driver for Adaptec 2010S controller since FC6 may not
have native driver. Unfortunately, Adaptec does not have driver for this
new OS so it looks like you cannot use this OS. This is the link to
download driver for this controller.

http://www.adaptec.com/en-US/support/raid/scsi_raid/ASR-2010S/index.htm
--------------------------------------------------------------------------------------

Dominique007
25th November 2006, 07:25 AM
Thank you for your response.

I tried a lot since my post. Seems so far FC6 will not recognize the (Adaptec Integrated Controller) AIC7902 on my motherboard or the Adaptec ASR-2010s ZCR RAID card and detect disks properly. According to all the research I did (and did I ever dig) the way to force driver installation from disks in FC6 is:

At startup screen type "linux noprobe" the installation program will not attempt to detect hardware and will prompt user instead.

After loading the boa or snake thing whatever it is called, a window will pop up to manually install drivers or something of the sort, click on add.

Search in the list and select the Adaptec 79xx driver click ok

Click add again and select I2o_block driver click ok.

I did that twice inverting order of installation of drivers still no disks detected...


In answer to my own questions since nobody so far answered them:

1- Where are the Adaptec 79xx and I2o_block drivers on the Fedora Core 6 DVD?

A:Somewhere! Hidden in the craks of Linux that I still do not undertand being a newbie. Maybe in one of the rpm files. Whatever RPM's are.

2- Is there an extension used to identify drivers in Linux? ie: Windows uses *.inf

A: So far looks like .tar.gz and .img are driver files we can throw in possibly RPM files as they seem to apply to all sauces :-) One thing for sure if you have a .img file you can create a driver disk using rawwrite for Windows or Linux.

3- Any recommended source to get the drivers?

I dont know, just a blob and sure beats me. Found a website that specialises in I2o with search keyword I2o and could not understand it since I am a newbie. Some drivers that end with .tar.gz must be some sticky material :-) and also a whole bunch of patches there that could be applied in a manner that I do not grasp yet.

4- Any suggestions or command at installation to force drivers to install?

A: "linux noprobe" just maybe, but it did not work for me.


Perhaps most of my self answers are 75% wrong. Do not know. Used to hate Windows XP Pro with a passion. Since there is very little support from the community I am starting to change my mind. At least it recognizes my drives and I can get very lame support from Microsoft India. Crap is starting to look like bronze probably soon silver but I wont push, it will never go to gold or platinum. Perhaps going to the novell side of things with SUSE will solve problem.

I will keep searching as of all research I did so far puts Redhat and Fedora Core on top. Maybe I will figure it out in a few months.

Feel free to reply to post do not be shy!

Dominique007

wdingus
11th April 2007, 09:09 PM
Very similar to the problem we worked on in 2005:

http://www.fedoraforum.org/forum/archive/index.php/t-71961.html

I'm back with a new FC release on some of the same boxes, and experiencing basically the same problem.

RHEL5 by the way works. Do "linux noprobe" and pick the i2o driver off the list, all is well...

Do the same on FC6 and it's a no go.

For both OSes if you jump to an alternate console after loading the i2o driver you'll notice that "dmesg" shows the i2o driver loading, finding your RAID arrays, and looking like all is well. What I found odd at that point though was that there was no /dev/i2o/ subdirectory. I did though find /sys/block/i2o!hda/ with lots of info about my RAID, partitions, etc... RHEL5 takes this and runs with it, FC6 does not.

There should be no need to fool with the Adaptec 79xx module, when you install a ZCR card it basically disables the underlying SCSI chipset and overlays the RAID functionality over top of it. If the base Adaptec chipset could be "seen" in that respect when a RAID card is installed, you'd be able to "see" the individual drives, which with RAID you don't want. "Drivers" to RHEL and FC are for the most part built into the kernel, there's usually no need to fool with 3rd party "driver diskettes" or the like. In this case the i2o drivers are built-in, they do load, they do find the card, they do find the RAID array on the card. The part that is falling down is Anaconda(?) realizing all that is true and being able to do something with it. Or perhaps it's disk druid's fault, I do not know for sure.

Something else I did and you might want to try just for the heck of it...

Boot "linux noprobe" and select the I2O driver off the list. Proceed and before going into disk druid do CTRL-ALT-F7 then ALT-F2 to get to a console screen.

# mkdir /dev/i2o
# mknod /dev/i2i/hda b 80 0
# fdisk /dev/i2o/hda
p

If I do this I can then see my RAID and all the partitions already on it. So the driver is physically working, but even doing this does not get anaconda/disk druid to proceed without bombing unfortunately...

wdingus
12th April 2007, 06:15 PM
I just compared and contrasted a (fails) FC6 install on this hardware versus a (works) RHEL5 install. Here is the difference I see...

After choosing i2o drivers off the list, from a "linux noprobe" boot, and then continuing forward and it going into X I jump to a console. Looking at the end of /tmp/anaconda.log they are both very similar with the most important looking line existing for FC6 only is this:

DEBUG : exception checking disk blacklist on i2o!hda: (2, 'No such file or directory')

I noticed on both that about the time the install switches from console mode to X a bunch of other modules load, GFS2, EMC, device-mapper, etc...

It would appear that the default device-mapper config might have i2o!hda blacklisted or maybe hda and pattern-matching is hitting that.. Maybe the "!" character is causing issues...

Anyway, at this point I think it's an Anaconda bug. I've not tried a test release of FC7 but may do so just out of curiosity.

AltGrendel
12th April 2007, 06:36 PM
Well, that answers my question.

I've been trying to migrate my boot image to a 2120 and it hasn't worked. Now I know why. What I did as an interim solution is to use a small standard SCSI disk as a boot disk and have everything else on the RAID.

Thanks for the info, guess I'll have to wait for 7.

wdingus
12th April 2007, 07:44 PM
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=223437

There's also a Bugzilla entry for FC7T2 that sounds awfully similar.

AltGrendel
15th April 2007, 03:26 AM
This also means that it won't see the card in rescue mode (tested and confirmed).

I realize that this is kind of a "Well, duh" comment. but I just wanted to make sure.

kunts
4th April 2008, 12:14 PM
This problem on CentOS:
http://www.centos.org/modules/newbb/viewtopic.php?topic_id=10855

I made it for Fedora 8.
==================

## 1. Remove Adaptec ASR-2010s
## 2. Install Fedora on a single disk
## 3. Edit loader

cp -r /boot /boot_copy
cp /boot/initrd-2.6.23.1-42.fc8.img /tmp/initrd.img.gz
gunzip /tmp/initrd.img.gz
mkdir /tmp/initrdnew
cd /tmp/initrdnew
cat /tmp/initrd.img | cpio -i
cp /lib/modules/2.6.23.1-42.fc8/kernel/drivers/message/i2o/* /tmp/initrdnew/lib/

## edit loader:
vi /tmp/initrdnew/init

## rem this lines:
#echo "Loading aic79xx.ko module"
#insmod /lib/aic79xx.ko

## and add lines:
echo "Loading i2o_core.ko module"
insmod /lib/i2o_core.ko
echo "Loading i2o_block.ko module"
insmod /lib/i2o_block.ko

find . -xdev |cpio -o -H newc > /tmp/newinitrd.img
gzip /tmp/newinitrd.img
cp /tmp/newinitrd.img.gz /boot/initrd-2.6.23.1-42.fc8.img

mkdir /dev/i2o
ln -s /dev/sda /dev/i2o/hda
ln -s /dev/sda1 /dev/i2o/hda1
ln -s /dev/sda2 /dev/i2o/hda2
ln -s /dev/sda3 /dev/i2o/hda3
ln -s /dev/sda4 /dev/i2o/hda4

## edit mtab:
vi /etc/mtab
## replace /dev/sdaX to /dev/i2o/hdaX
/dev/i2o/hda1 /boot ext3 rw 0 0

## 4. turn off server
## 5. install Adaptec ASR-2010s
## 6. turn on server and correct RAID-bios (Ctrl+A) to RAID-1

I think RAID-5 can be work if correct RAID-bios to RAID-5, and after this remove disks and install Fedora on single disk, and after that input other disks. But I use only RAID-1.

Sorry for my english.