PDA

View Full Version : FC5 - yum errors



hussram
22nd November 2006, 10:20 AM
I started to get the following errors when I run yum update:

Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
dries [1/7]
dries 100% |=========================| 951 B 00:00
core [2/7]
core 100% |=========================| 1.1 kB 00:00
macromedia [3/7]
macromedia 100% |=========================| 951 B 00:00
updates [4/7]
updates 100% |=========================| 1.2 kB 00:00
freshrpms [5/7]
freshrpms 100% |=========================| 951 B 00:00
crash-hat [6/7]
crash-hat 100% |=========================| 951 B 00:00
extras [7/7]
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 778 kB 00:08
dries : ################################################## 3235/3235
Added 3235 new packages, deleted 0 old in 38.00 seconds
primary.xml.gz 100% |=========================| 767 kB 00:12
core : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 33.58 seconds
primary.xml.gz 100% |=========================| 1.0 kB 00:00
macromedia: ################################################## 2/2
Added 2 new packages, deleted 0 old in 0.08 seconds
primary.xml.gz 100% |=========================| 404 kB 00:04
updates : ################################################## 1120/1120
Added 1120 new packages, deleted 0 old in 20.84 seconds
primary.xml.gz 100% |=========================| 64 kB 00:02
freshrpms : ################################################## 173/173
Added 173 new packages, deleted 0 old in 2.73 seconds
primary.xml.gz 100% |=========================| 22 kB 00:01
crash-hat : ################################################## 86/86
Added 86 new packages, deleted 0 old in 0.87 seconds
primary.xml.gz 100% |=========================| 1.7 MB 00:15
extras : ################################################## 5700/5700Added 5700 new packages, deleted 0 old in 84.04 seconds
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for xine to pack into transaction set.
xine-0.99.4-7.fc5.rf.i386 100% |=========================| 31 kB 00:00
---> Package xine.i386 0:0.99.4-7.fc5.rf set to be updated
---> Downloading header for scribus to pack into transaction set.
scribus-1.3.3.5-1.fc5.rf. 100% |=========================| 90 kB 00:01
---> Package scribus.i386 0:1.3.3.5-1.fc5.rf set to be updated
---> Downloading header for xine-lib-extras to pack into transaction set.
xine-lib-extras-1.1.2-1.f 100% |=========================| 20 kB 00:00
---> Package xine-lib-extras.i386 0:1.1.2-1.fc5.rf set to be updated
---> Downloading header for clamav-debuginfo to pack into transaction set.
clamav-debuginfo-0.88.6-1 100% |=========================| 20 kB 00:00
---> Package clamav-debuginfo.i386 0:0.88.6-1.fc5.rf set to be updated
---> Downloading header for libcdio to pack into transaction set.
libcdio-0.77-1.fc5.rf.i38 100% |=========================| 7.4 kB 00:00
---> Package libcdio.i386 0:0.77-1.fc5.rf set to be updated
---> Downloading header for xvidcore to pack into transaction set.
xvidcore-1.1.2-1.fc5.rf.i 100% |=========================| 5.8 kB 00:00
---> Package xvidcore.i386 0:1.1.2-1.fc5.rf set to be updated
---> Downloading header for elinks to pack into transaction set.
elinks-0.11.0-2.4.i386.rp 100% |=========================| 16 kB 00:01
---> Package elinks.i386 0:0.11.0-2.4 set to be updated
---> Downloading header for libsigc++20 to pack into transaction set.
libsigc%2B%2B20-2.0.17-1. 100% |=========================| 185 kB 00:03
---> Package libsigc++20.i386 0:2.0.17-1.fc5.rf set to be updated
---> Downloading header for lame to pack into transaction set.
lame-3.97-1.fc5.rf.i386.r 100% |=========================| 8.4 kB 00:00
---> Package lame.i386 0:3.97-1.fc5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libiso9660.so.4(ISO9660_4) for package: vcdimager
--> Processing Dependency: libcdio.so.6 for package: vcdimager
--> Processing Dependency: libcdio.so.6(CDIO_6) for package: libcddb
--> Processing Dependency: libiso9660.so.4 for package: videolan-client
--> Processing Dependency: libcdio.so.6(CDIO_6) for package: vcdimager
--> Processing Dependency: libcdio.so.6 for package: videolan-client
--> Processing Dependency: libcdio.so.6 for package: libcddb
--> Processing Dependency: libiso9660.so.4 for package: vcdimager
--> Finished Dependency Resolution
Error: Missing Dependency: libiso9660.so.4(ISO9660_4) is needed by package vcdimager
Error: Missing Dependency: libcdio.so.6 is needed by package vcdimager
Error: Missing Dependency: libcdio.so.6(CDIO_6) is needed by package libcddb
Error: Missing Dependency: libiso9660.so.4 is needed by package videolan-client
Error: Missing Dependency: libcdio.so.6(CDIO_6) is needed by package vcdimager
Error: Missing Dependency: libcdio.so.6 is needed by package videolan-client
Error: Missing Dependency: libcdio.so.6 is needed by package libcddb
Error: Missing Dependency: libiso9660.so.4 is needed by package vcdimager

I have disabled freshrpms and also enabled livna without any luck. I searched, for example, for libios9660* and I could not find it on any repos. Please give some feedback. Thank you.

Regards

Seve
22nd November 2006, 08:12 PM
Hello:
Try
yum --disablerepo=dries update

Seve

sliptrap
23rd November 2006, 09:14 AM
Same errors here, except mine were only for vcdimager. I used:

yum update --exclude libcdio

to get past the errors.

Dave

Dubious Dave
24th November 2006, 03:19 PM
So what causes the problem? I get the same thing on my wife's FC5. Is dries messed up?

evans
24th November 2006, 06:12 PM
I had the same problem. I wasn't satisfied to disable dries, so instead I cleared it up with


yum clean all

rpmdb --rebuilddb

yum update

I hope this helps you too.

evans
24th November 2006, 06:31 PM
Hi again,

my last post was / is misleading as i also had removed dvdrip, which it trns out, was the problem. In particular, dvdrip-0.98.1-1.fc5 from freshrpms wants libcdio-0.76-2.fc5 from extras. However, dries has libcdio-0.77-1.fc5.rf and hence the dependecy error.

Sorry for the bogus advice above, but a little database cleaning never hurts!

evans
24th November 2006, 06:48 PM
Hi again,

my last post was / is misleading as i also had removed dvdrip, which it trns out, was the problem. In particular, dvdrip-0.98.1-1.fc5 from freshrpms wants libcdio-0.76-2.fc5 from extras. However, dries has libcdio-0.77-1.fc5.rf and hence the dependecy error.

Sorry for the bogus advice above, but a little database cleaning never hurts!