PDA

View Full Version : FC6 Nvidia



ATAQ
21st November 2006, 08:12 PM
Hey I am New to the Fedora Realm (Ex Debian), I want to install Nvidia drivers, Although I notice that the kmod-nvidia method is meant to be quite easy, although I do not know the difference. I want tot play games. Quake 4, should I install that one or the Nvidia Proprietary drivers?

Thanks,
Anthony

JN4OldSchool
21st November 2006, 08:14 PM
definitly stick with the kmod-nvidia from livna. These are specially made for FC, I believe the proprietary driver from nvidia will just break things.

edit: just be sure you dont have the "kernel issue" first!

http://fedoraproject.org/wiki/Bugs/FC6Common

This is real easy to fix right off the bat but if you tey to install certain things you will muddy the waters!

Dan
21st November 2006, 08:17 PM
Afternoon, Anthony,

Yup. You'll want the livna nVIDIA drivers, but beware the bite of the Anaconda! Check your kernel version before you try to install the livna driver package. Let me go chase down the links for you to get more info. Back in a second.

Here. I got bit too, so you can look at this thread for answers.

http://www.fedoraforum.org/forum/showthread.php?t=137305

Dan

EDIT: Hah! JN4, you're pretty fast for an old f*rt! :D

ATAQ
21st November 2006, 08:21 PM
Thanks guys, Ya I just installed FC6 today, fixed the Anaconda problem. I usually used the Nvidia drivers on Debian, but I will test out the kmod ones

ATAQ
21st November 2006, 08:37 PM
just restarted X, its manky, whats the command to reconfigure x? in debian its dpkg-reconfigure xserver-xorg
, dunno what it is in Fedora
Regards,
Anthony

drunkahol
21st November 2006, 08:44 PM
Main menus:

System -> Administration -> Display

and

System -> Preferences -> Screen Resolution

will help out.

In what way is it manky? Bad resolution? Bad colour? Bad monitor?

Cheers

Duncan

ATAQ
21st November 2006, 08:50 PM
that wont work you see, its locked out to 640X800, i reconfigured with system-config-display --reconfig, not sure if its ok yet

ATAQ
21st November 2006, 09:06 PM
Hey, I am stuck at 50 hz refresh rate. cant change. modified vertical and horizontal refresh rates in xorg.conf
Any ideas?
Thanks,
Anthony

Dan
21st November 2006, 09:47 PM
Yeah. Look at the Applications>System Tools>NVIDIA Display Settings.

You should be able to tweak a bit there.

ATAQ
21st November 2006, 10:58 PM
NIce one, Sorted thanks, beginning to like this distro. way different to debian