PDA

View Full Version : Possible X problem? freezing post login



wcb
20th November 2006, 09:06 PM
I just recently installed FC 6 (was using FC 4) before, and added another video card (old voodoo) so that I could use two monitors. The other card is an NVidia. I had to play with xorg.conf quite a bit, but I eventually got both monitors working fairly properly.

From the terminal, when I try startx the desktop displays to both monitors, and the mouse icon swirls for a moment then freezes. It doesn't allow me to use the keyboard or mouse afterwards. I can't kill X via ctrl-alt-bksp or switch to another terminal. I tried using init 5 instead of startx, and it took me to the login screen correctly. I am able to use both mouse and keyboard, but as soon as I log in (as any user), it displays the exact same behavior and freezes.

Additionally, I've tried to remotely kill X so that I could modify xorg.conf and try again, but I can't find the process on ps aux, and using init 3 remotely won't work either. I've also tried skill -KILL -u user and a few other things. If anyone could even help me figure out how to drop the frozen X process it would be greatly appreciated.

I've looked around quite a bit for something but nothings worked.

Here are a few parts of xorg.conf:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" RightOf "Screen1"
Screen 1 "Screen1" LeftOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "unix/:7100"
FontPath "built-ins"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

If you need anymore information let me know. I've looked around for other possible similar posts/solutions and haven't found anything, any help would be greatly appreciated.

Thanks,
Carl

wcb
21st November 2006, 04:38 AM
I played with it a bit more and a little more information/stress :( Basically I tried using the killall script to see if I could get the system back in a usable state, no dice there. My biggest concern/problem is that ps aux isn't showing any X process, is it possible that the X process is dead but I'm stuck in some nasty X limbo? Does anyone have any other suggestions of what I could try to just get the machine back to a terminal so I could try other tweaks to xorg.conf. Also, could it be that I'm using one nvidia card and one 3dfx card? Thanks for any feedback, kinda stuck atm.

FunKing
8th December 2006, 01:45 PM
I also had problems with a 3dfx Voodoo 3 card (among another dozen installation problems... if I knew I would have so much pain installing FC6, I wouldn't do it!). It seems to be a driver problem, because previous releases worked without any problems for years but with FC6 it hangs the system after drawing just a few things on the screen. On my /etc/X11/xorg.conf, 'Section "Device"', I changed the line below:

from: Driver "tdfx"
to....: Driver "vesa"

Now it seems to be working "fine"...

Mixy
8th December 2006, 03:30 PM
Well i have the same problem with my ATI card here :/ Haven't got FGLRX installed yet, so it runs with standard driver. But sometimes, When it turns on the screen saver or password protection, it freezes when i log back in. Really annyoing as i can use it most of the time, but then it just crashes :/

I am having a hard time installing FGLRX without macking the whole **** freeze :P Getting an error when installing, and when i boot, the resolution is too high for mye LCD (wich is a pain, because i have to edit resolution with terminal, wich i dont really know how yet XD). Anyway, i have no idea how my xorg.conf really should look like. And i know i really should get FGLRX installed soon (i want my XGL back), i guess i am gonna do it later today.

Anyone know why it freezes? :)

wcb
8th December 2006, 04:29 PM
I had a flukish situation happen. I was trying a few things and tried to log in, and I got a message that nautilus had crashed, then it finally let me in. Both monitors were working with the setup I wanted, but the resolution was incorrect at 800X600. Unfortunately before I could test things with that the primary monitor died on me (from the hardware side), so its back to a single monitor probably on the nvidia :(

tbl
22nd December 2006, 11:04 PM
'got the same with Radeon , few minutes ago !

wcb
23rd December 2006, 12:23 AM
Not sure if this was a solution or not, but after Gnome and later KDE were being difficult I decided to switch to Enlightenment(E16) for my desktop manager. Its clean, lite, and does everything gnome/kde could do that I used. The issue seems to have gone away for the time being. I wonder if it's a Gnome problem?