PDA

View Full Version : exec of init failed:permisssion denied-kernel panic



rossheth
19th November 2006, 09:35 PM
Recently my FC6 system died, giving the message to terminal that the root partition was being remounted read-only. Obviously, the system did not shutdown cleanly. On reboot I get the message
exec of init (/sbin/init) failed: Permission denied!!! followed by `kernel panic'. I tried a full fsck with badblocks- no change. I checked the permissions of /sbin/init- rwx for root. I tried booting with `init=/bin/bash'-same error, with /sbin/init replaced with /bin/bash. I can mount and access the filesystem, so that's not the problem. Is it possible to fix init errors or do I need to reinstall?

grepsy
20th November 2006, 03:56 PM
Have you tried rebuilding the initrd? Or (if you have one) booting into an old kernel?

rossheth
21st November 2006, 08:37 PM
I've given up and reinstalled: not for the first time with FC6, I might add. I think I'll take the liberty of ghosting my partitions against this happening again.