PDA

View Full Version : K3b problem



sparks40
18th November 2006, 10:16 PM
I have bee trying to add (burn) additional files to a cd that was created previously... with no success. I am using fc6 (with the latest updates) and k3b 3.5.5-0.2.fc6.

I have no trouble creating a project or burning the first batch of files. I have the "settings" tab on multisession and there is over 600 meg left on the cd. After exiting k3b I can read the files without any problem.

However when I go back into k3b to add additional files, I can call up the original project name but the application fails to append the new files. I get the following error messages:

1.) could not retrieve multisession information from the disk, and
2.) the disk is either empty or not appendable.

Seems to me that the original project is being closed out.. but the cd is not. I've even tried to open a new project on the same cd, but that does not work either.

Is there a step by step tutorial that I can follow for the correct procedure to burn a multisession cd under k3b as I have a pile of coasters sitting on my desk.

Thanks and Happy Thanksgiving
.

rambutan
19th November 2006, 04:55 AM
I've had that problem too. But not lately. I am very careful each time I burn a CD to check the settings. After clicking on Burn I check the tab Settings and change Multisession mode from "auto" to either "start multisession" for a new CD or "continue multisession" for a CD that already has data. I haven't had that problem since I started refusing "auto" as an option. "Save User Defaults" doesn't seem to help, it keeps going back to "auto" and I change it every burn.

I don't see a way to make a session 'appendable' once it becomes "Appendable: No". Maybe someone else knows. To see the appendablility status in K3b go to Tools -> Diskinfo. If "Appendable: No" it's done for.

sparks40
19th November 2006, 05:16 AM
Thanks for the reply rambutan.

I appreciate it. I am doing exactly what you suggested in your post. Even though diskinfo shows the disk to be "appendable" it does not appear that I can add files to the cd.

Glad to hear that you have solved your problem. Perhaps someone else may have an additional suggestion. I'm going to keep on looking.

Happy thanksgiving.

rambutan
19th November 2006, 05:52 AM
I never bothered to learn how to manage projects. I just delete them each time I finish. When I want to add more to a CD I put the CD in and click on the [New Data CD Project] then click on [Import a Previous Session...] (blue gear, just right of the burn icon). That loads whats already on the CD. Then I add stuff and click on [Burn].

sparks40
19th November 2006, 06:14 AM
Which version of k3b are you using?

Unfortunately I tried your method and was unable to append any additional files on my system. Somewhere there is a solution to this problem and I'm going to continue to look for it.

thanks for the additional suggestions.

rambutan
19th November 2006, 06:16 AM
K3b 0.12.15 KDE 3.5.5-0.2.fc6
Good luck.

sparks40
19th November 2006, 08:17 PM
I also tried "cd/dvd creator" and "graveman"... they all do the same thing so I guess that rules out k3bas such. It must be systemic pertaining to a particular file or package. I have updated several time and I believe that my system is current. I can't beleive that I am the only user experiencing this problem.

sparks40
21st November 2006, 04:09 AM
I have now spent over 30 hours researching this problem, (this forum, other linux forums, google, etc).. Additionally, I have reinstalled fc6.

I can burn a fresh (blank) cd without a problem using both k3b and cd/dvd record. However, I still can not append (add) additional files to a given cd with either program. I get the message, "reload a rewritable cd or a blank cd" when attempting to add files in cd/dvd record .

I have not read anywhere that there is a prohabition against adding files using cd/dvd record or k3b. I have also installed and tried gnomebaker and the results are the same.

There has to be a solution to this problem. I wish someone would just acknowledge that it is a known kernel or application bug, and that it is being addressed. Even better, if someone has already solved this problem... please fill me in!

TNX to all

rambutan
21st November 2006, 04:25 AM
might be a /etc/fstab issue.
What do you have in /etc/fstab for the cd-dvd drives?
Also as a test run k3b as root.
$ su -
# k3b
See if the problem goes away as root.

sparks40
21st November 2006, 04:40 AM
Here is the fstab file:

[frank@localhost ~]$ cat /etc/fstab
LABEL=/ / ext3 defaults 1 1
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
LABEL=SWAP-sda2 swap swap defaults 0 0

Here is the contents of mtab:

[frank@localhost ~]$ cat /etc/mtab
/dev/sda1 / ext3 rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

I tried k3b from root but it did not solve the problem. In order to prevent possible interaction with cd/dvd record I removed k3b.

rambutan
21st November 2006, 05:43 AM
Sorry you're dropping k3b. I'll remain a fan.
Here is my /etc/fstab for the CD and DVD drives

# add permissions for drives so K3b works OK --- first step is to #mkdir the directories!!!
/dev/hdc /media/dvdwriter auto pamconsole,exec,noauto,managed 0 0
/dev/hdd /media/cdwriter auto pamconsole,exec,noauto,managed 0 0

The # comment is to remind me each new install to make the directories. (#mkdir /media/dvdwriter ..cd)
I was surprised to not see anything about the drives in your /etc/fstab.
Before adding these two lines k3b only worked right when user was root.

sparks40
21st November 2006, 05:54 AM
It's easy enough to install k3b.

I follow making the directories ok, but I am not sure about the permissions. Are the permissions implied in the two lines mentioned in the first paragraph or do they have to be set explicitly? If so what should they be?

TNX for your reply.

sparks40
21st November 2006, 06:35 AM
Your suggestion worked perfectly, (so far)!!!!

I was able to use k3b in "user" mode and have made three seperate file additions to the original cd without problem. Apparently k3b does not annotate the fstab file automatically. That seems strange to me.

I hope that all the other people out there who have experienced this problem will read your solution and give it a try.

TNX rambutan for your patience and willingness to help.
Happy thanksgiving to you and your family!

sukumar_baishya
1st March 2007, 09:42 AM
Hi all,

I am intersted to know if the solution given by Rambutan works also in FC5. I am using FC5 and can't easilty change to FC6 immediately for some important ongoing projects in my LinBox.

Thanks

FunWithDirt
1st March 2007, 10:03 AM
Hi all,

I am intersted to know if the solution given by Rambutan works also in FC5. I am using FC5 and can't easilty change to FC6 immediately for some important ongoing projects in my LinBox.

Thanks
Oh no sukumar, please switch! Just kidding. How small the world is, I recognized your name from the opensees forum. I'm waiting for your fc6 makefile. I wish I didn't switch from fc5, that makefile you posted doesn't work for fc6 and I wasted too much time on it so I'm just doing my opensees on windows for now.

sukumar_baishya
1st March 2007, 01:37 PM
Hi, "FunWithDirt"

Nice 2 see ur reply. We r really living in a global village. I hope to I would switch to FC6 by next july. However, did the the make file work in your FC5? In FC6 what are the errors u r getting? BTW, what is the area u r working on with OpenSees? Can u give me some good literature on Pushover analysis. Some of my students are starting to work in this area and I donot really have a good command on this, being a Geotech man.

Hope 2 listen from u.

rambutan
1st March 2007, 04:09 PM
Hi,
Please start a new thread for OpenSees. Others may search for it.
Back to K3b.
I only installed FC5, tried it some and stayed with FC4. Later I tried FC6 and switched to it. Now I use Ubuntu 6.1 K3b works fine. I don't remember any issues but here is part of the /etc/fstab I use with Ubuntu:
/dev/hdc /media/SonyDVD udf,iso9660 user,noauto 0 0
/dev/hdd /media/NEC_CD udf,iso9660 user,noauto 0 0
Since it's not exactly the same as I use in FC6 I thought I would post it as another possibility.

sukumar_baishya
1st March 2007, 04:55 PM
Hi rambutan,
Thanks for reply. I will try the way u did in FC6. However, I could not really follow
"The # comment is to remind me each new install to make the directories. (#mkdir /media/dvdwriter ..cd)". (Your earlier thread on this issue)
Does it mean that every time i need to cdwrite, (I have a combo cdrw/DVD rom drive) i have to mount the drive ? Kindly explain the process.

Thanks a lot for ur reply. BTW, I will soon start a new thread 4 OpenSees

(Sukumar)

rambutan
1st March 2007, 05:15 PM
Hi,
The # is just a comment line. You can put anything you want in a comment line.
I must have installed and tried a dozen Linux OSs by now. I usually have 4 or 5 Linux OSs on my PC at any given time. I copy part of an old /etc/fstab each time to save a lot of typing. The comment is only a reminder to me. You don't need it, but if you have fstab mount something you need to be sure the mount point exists.
Your combo cd/dvd would only have one mount line in fstab. I have both a CD drive and a DVD drive thus two lines. In my case I created a mount point /media/dvdwriter. I made up the name dvdwriter, use anything you want. But be sure to make the directory before you boot. In the terminal
$ su -
# mkdir /media/dvdwriter
then you can boot. /media already exists but the sub-directory needs to be created.