PDA

View Full Version : Simpler Crossfade Plugin



smithxi
18th November 2006, 08:28 AM
I had tons of problems with the crossfade plugin and i tried hard to configure it. I recommend a simple crossfade either in audacious or in the plugin.

cooney
18th November 2006, 08:49 AM
If you're refering to the crossfade plugin for xmms then I have gotten it to work with mp3s. But I must warn you that I have had to use Windows programs to clean up and/or fix some mp3 files that would not behave.

If this applies and you need more info, I'll be glad to expound. If what I have stated so far does not apply, then nevermind.

bob

smithxi
18th November 2006, 10:03 AM
i'm only interested if you know how to make the crossfade start fading as soon as the new file is executed. sorry to be picky, but i had it working before and it would wait up to 25 seconds before it was crossfading and someone walked me through the process. have you gotten your method to fade "on demand?"

cooney
18th November 2006, 03:55 PM
Mine crossfades on demand. It's been awhile since I set it up but I do remember this. Some other plugins will conflict with it. The only other plugin I'm running as far as I can remember is realplay gain which helps keep the volume levels even from song to song. There's another plugin or two that performs auto-leveling on the fly. I can't remember right now what they were called but they just didn't let crossfade work properly.

I would try disabling all plugins you've added except for crossfade and see if that helps get it working. I have to go to work now but will be willing to look into my exact setup later and find out what my settings are and what plugins I'm running.

again, let me know,

bob

smithxi
18th November 2006, 10:33 PM
i was sure to check this, and they were disabled!

cooney
19th November 2006, 01:44 AM
OK smithxi,

I just got home. Let me settle in and get a glass of wine and see what I did that made this thing work. All's that I remember was that it was a pain in the A$$ and I hoped that I would never have to do it again. I'll get back to you soon. You are using xmms are you not?

bob

cooney
19th November 2006, 02:36 AM
OK. Here are the details as best as I can give them. First off, I'm running xmms version 1.2.10 on an old amd k6 using FC4 with 128k ram. An old beater if you will, but a dedicated box for music only; 'My Jukebox' and it works great! :D

While looking at the 'Audio I/O Plugins' tab under preferences, the only input plugin enabled is:

MPEG Layer 1/2/3 Player 1.2.10 [libmpg123.so]

Nothing else.

Under 'Output Plugin' I have selected; 'Crossfade Plugin 0.3.8 [libcrossfade.so].

If you don't have or are using something similar to the above, I don't know if I can help you anymore. Without the ability to do screenshots on this machine, since it has been cut down to bar bones and dedicated to music, I have to look at every screen and variable (of the variable) to type to you what the settings are. That would take a very long time.

If what I have given you so far is 'getting warmer' or shows up on your screen, let me know. I'll be more than happy to type more. I don't remember the source I found originally that helped me to get 'crossfade' working properly, but I do know that it took some work and loss of hair. Despite my baldness now, mine works and I would be more than glad to help you with yours. I'm sorry, but sometimes I suffer from 'CRAFT' (thanx Dan). Perhaps if we get yours going, I will write a howto for anybody else interested in having their own personal jukebox sounding like a well financed radio station without commercials or silence of any kind until the playlist ends, since the original info I found that helped me has seemed to disappear from the web.

bob