PDA

View Full Version : Can not create anything in /mnt



Ragman
16th April 2004, 08:38 PM
I have recently installed Fedora Core 1 on an HP zd7000 laptop. In the process of attempting to get a SanDisk Cruzer mini 256 to be recognized (no luck yet) I have done something that now prevents me from creating anything under the /mnt directory. This behavior occurs even when logged in as Root... Any one know how to resolve this?

The SanDisk seems to be partially recognized, but the processes that manage it always attempt to set it up as a floppy. Perhaps that is the normal behavior, but my computer does not have an on-board floppy and anything related to floppy has already failed during the boot process.


Thanks,
Ragman

SuperNu
16th April 2004, 08:47 PM
I would check the permissions on /mnt, ls -l /mnt, and the folders under mount and see what they are. Also, could you post the contents of /etc/fstab. Maybe something in there got messed up.

--SN

Thoreau
16th April 2004, 09:05 PM
usb thumb drives are /dev/sda# no? i had my working i'm sorry but i don't remember how i did it. and i don't have the configuration anymore... sorry.

yeah i agree, please show us your fstab.

ieatlint
16th April 2004, 10:06 PM
For the sandisk.... www.google.com You'll find other's who've already gotten it working.

For the problems with /mnt ... it's just a folder like any other. Assuming the error you recieve is permission denied, just run this:
chmod 0755 /mnt
If after that, you still can't create a directory in /mnt, then you're doing something wrong in the attempt (or something really bizarre is going on)

Ragman
17th April 2004, 09:52 PM
I tried the chmod 0755, but that did not resolve whatever it is that I messed up...

/etc/fstab

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
/dev/hda5 /osshare vfat defaults 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/sda1 /mntpj/usbkey vfat user,iocharset=utf8,umask=00,sync,quiet,exec,codep age=866,noauto 0 0
#usbdevfs /proc/bus/usb usbdevfs noauto 0 0
#/dev/sda /mnt/floppy auto user,rw 0 0


/etc/auto.misc

cd -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom

# the following entries are samples to pique your imagination
#linux -ro,soft,intr ftp.example.org:/pub/linux
#boot -fstype=ext2 :/dev/hda1
#floppy -fstype=auto :/dev/fd0
#floppy -fstype=ext2 :/dev/fd0
#e2floppy -fstype=ext2 :/dev/fd0
#jaz -fstype=ext2 :/dev/sdc1
#removable -fstype=ext2 :/dev/hdd
#floppy -fstype=auto,rw :/dev/sda
#diskonstick -fstype=auto,rw :/dev/sda


I have used google to try to fix the sandisk mounting problem, but none of the things that seem to be working for others have worked for me <sigh>

Thank you all for your help. I do apreciate it and will keep checking back.

ilja
18th April 2004, 05:23 PM
Is it also impossible to make a new folder as root ?

Ragman
19th April 2004, 05:16 AM
Yes, I can create other directories and folders - just not within /mnt. However, late last night I discovered that making a change to the directory specified within auto.master caused the problem to move with the change. So, I eather have something within my automount set-up that is incorrect, or this is a "feature" that I had not remembered... I will pursue both.

Still not having any luck with the SanDisk. I am starting to wonder whether the various USB configuration files within my system are not current enough. My kernel is 2.4.22.nnnn. I am not too sure how to update USB, so that is one of my next research projects. Pointers greatly appreciated!

Thanks.

Thoreau
19th April 2004, 03:37 PM
you can download one of the 2.6.X kernels and see if that corrects the USB problem... that's very wierd why the USB key shows up in your fstab correct, but you can't access it. not to be a jackass or anything but you have tried
mount /mnt/usbkey

Ragman
25th April 2004, 01:33 AM
I am looking into how to deal w/ upgrading to the 2.6 kernel... As for the fstab, that entry is there because I had hand copied it in, after finding the info in one of the news forums.

I recently found some additional information titled "Adding USB mass storage devices in Fedore Core" at the site: http://cyberelk.net/tim/usb-storage.html. Following its instructions, I can get /etc/sysconfig/hwconf updated w/ the SanDisk info, but it disappears after a reboot -- does not come back when the device is inserted either. So, I am suspecting that I have run into a bug; after moving up to the 2.4.22-1.2174 kernel, the system stopped hanging upon insert.