PDA

View Full Version : NVU & Fedora 6



IPI
17th November 2006, 05:10 AM
I have NVU 1.0 running it under 2.6.18-1.2849.fc6 kernel, the problem is when i open a web page with nvu to edit. when i click on source window, it does display the source but when i click on the code and try to edit, the first key i enter causes nvu to exit and it disappears completely.

Q1. Is there anyway to fix this?

and also i have quanta+ & Bluefish as well, the difficulty i have with these editors is they don't function like frontpage. so i can't drag a picture in design window and place it anywhere on the page ... nvu & frontpage will do the the code generation so no knowledge of html / xml & etc is needed. with quanta & bluefish all i have is the code to edit.


since i don't know much about xml / html and other web languages, i need something like frontage.

Q2. any idea if there is a web editor out there for Fedora other than nvu that takes care of problem?


Thanks in advance :)

Detonate
17th November 2006, 05:29 AM
I would suggest reinstalling NVU, something is not right. I have NVU installed, FC6, and I just went and tried to duplicate your problem and was unable to do so. It worked just fine.

IPI
17th November 2006, 06:14 AM
OK, i did remove it , but do i install the FC4 rpm posted on their website to install it again? which package did you use to install nvu though?


Also thanks for your reply. :)

IPI
17th November 2006, 07:09 AM
Well, after removing nvu, i did install a fresh copy using nvu-1.0-0.1 RPM for i386 from Freshrpms for Fedora Core 4 testing / nvu. When i run the newly installed nvu, same thing happens.

Originally it was working fine though ... i don't know what i did that causes this crash. is there any way to make sure that i completly remove nvu and no setting / config files are left?

I ran nvu from terminal and after nvu exits (disappears) here is the error which gets displayed:


/usr/lib/nvu-1.0/run-mozilla.sh: line 159: 6213 Segmentation fault "$prog" ${1+"$@"}


Also when i run nvu in terminal as root, it does work fine ... :eek:


Thanks

Detonate
17th November 2006, 12:10 PM
I'm running version 1.0 which I downloaded from the NVu site, and installed using the package installer.

sailor
18th November 2006, 03:04 PM
I have had nothing but problems trying to ge NVU to work in FC6...I followed some work arounds on the web without success....was there anything special you had to do to get it to work?

Detonate
18th November 2006, 03:06 PM
No, I installed it, and started using it. Have had no problems.

martin.sourada
18th November 2006, 04:19 PM
Q2. any idea if there is a web editor out there for Fedora other than nvu that takes care of problem?
I prefer BlueFish to NVU. But it has no preview though... But I always previewed created web pages in web browser (more than 1) so I never needed that feature. You can try it - it is in extras. So do yum install bluefish.

rambutan
18th November 2006, 04:22 PM
I used NVu in FC4 but even then I was already trying SeaMonkey (Mozilla Suite). NVu kept hanging up. After 10 minutes or so of use, I might click Save or Publish and nothing would happen. I would restart NVu and things were OK again. This restart NVu happened too often so I switched to SeaMonkey. NVu's only advantage is the FTP feature. I just use gftp which is even better.
Now that I've installed FC6 I'm just using SeaMonkey and gftp.
NVu is based on SeaMonkey as both explain.
http://www.mozilla.org/projects/

IPI
18th November 2006, 07:51 PM
rambutan, does sea money have a preview window ? Or it lets you to edit the code only? that is what i like about nvu that like front page, from normal window you can move things around as add stuff. As you doing it to a simple word file and it does take care of HTML code for you.

As far as quanta+ and bluefish goes, they don't have this capability. (i have both installed).

rambutan
18th November 2006, 07:55 PM
SeaMonkey has four tabs at the bottom like NVu. I guess thats where NVu got it.
SeaMonkey is really the browser suite. You have to use the Composer Window, not the browser.

bignall
21st November 2006, 05:23 PM
I've also been trying to use nvu on FC6. I've tried installing the Fedora Core 4 RPMs, but they both require xorg-x11-deprecated-libs which doesn't seem to exist at the current version of xorg. So, I tried the autopackage package. And it installs okay, but trying to run it, I first got a message saying that it could not load the plugins and telling me to run as root first. So, I ran it as root and it just hangs before it even gets a window open. Then, running again as myself, I get the segmentation fault mentioned earlier.

sailor: you mentioned some work arounds. I couldn't find them, could you please tell me what they are so I can try them too.

Anyone else have any ideas how to get it working?

Seamonkey doesn't seem to do CSS (please correct me if I'm wrong) which i s a big downside to me.

Thanks,
Rosina

rambutan
22nd November 2006, 03:33 AM
Rosina,
I use Seamonkey but not CSS.
Here is a link from mozdev that may help:
http://cascades.mozdev.org/
It's about a style sheet editor for composer.
If you try it let us know if it works or not.

scotta3234
22nd November 2006, 03:43 AM
sailor and others: All I had to do to get nvu working was manually install the rpm located here. ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/testing/4/nvu/nvu-1.0-0.1.i386.rpm
Everything seems to be working properly, although I only installed it yesterday. What types of problems were you having?

sailor
22nd November 2006, 04:17 PM
I was getting a dependency error for libstdc (something like that, not at my linux box at the moment)
I followed a work around for this by manually putting the file in the /usr/lib directory, and doing a symlink to another lib file. Now I get a new error, which I will have to reproduce once I get home....

bob
22nd November 2006, 04:43 PM
Scotta, just tried the NVU from your link and agree that it installs fine on my FC-6 with no dependency errors. Seems to be functioning perfectly.

Dan
22nd November 2006, 06:44 PM
Hot Dog! Thanks Scott, & Bob! Fetching it now.

Dan

triplemaya
22nd November 2006, 11:08 PM
Many thanks Scotta, this solved my problem.

I'd be interested to know where you got that link, I thought I had tried all the links on the nvu site download page. (I was trying to use nvu-1.0-pc-fedora3-kde.tar.bz2 which I got from that site, and it worked fine under fedora 5. (Well, it worked for a while, but then it crashed any time I tried to make changes to a page, but then ooffice apps were doing the same thing, so I assumed my installation of fedora 5 was broken in some way.))

Cheers.

sailor
22nd November 2006, 11:28 PM
thanks for the link, I will try this when I get home tonight...:)

triplemaya, the link is from the freshrpms site, a 3rd party repository...I also had been trying the files on the nvu site without success...

sailor
23rd November 2006, 12:43 AM
OK, sucess! The rpm worked fine except for one thing, for some reason it can not use the default profile. I created another profile and it works. Anyway thanks for the help guys :)

triplemaya
23rd November 2006, 10:22 AM
Thanks sailor. I had a look around freshrpms website, and it doesn't seem easy to find things. Knowing nvu was there, I did a google search of the site, and found nvu for fedora 4, but is there an easier way to find things? Also, I have freshrpms in my list of repositories, but I tried yum install nvu when I couldn't get the other package to work, and it came up with No Match for argument nvu.
BTW, the profile thing always seemed to bug nvu. From time to time it would come up with that message, and, as far as I can recall, if I created a new profile it wouldn't see my previous work. I usually found that if I restarted the computer it worked ok with the default profile!

LarryJ
12th December 2006, 09:05 PM
Thanks to the help I found in this thread, I have NVu running again on my 2.6.18-1.2849.fc6 system.


mkdir ~/nvu
cd nvu
wget ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/testing/4/nvu/nvu-1.0-0.1.i386.rpm
sudo rpm -ivh --nosignature nvu-1.0-0.1.i386.rpm

You then should find NVu under the KDE "Development" menu.

I noticed the SUSE repo has a version that's quite a bit later than this one. Would be nice of FreshRPMs or Dag or someone would repo a more current version. (But beggars can't be choosers :) )

Larry

FreewayFred
2nd January 2007, 12:43 AM
I use Firefox that I downloaded and it runs from my Desktop. I
use gnome desktop. What programs/Desktops/browsers are those of you, who have nvu working, using?

triplemaya
2nd January 2007, 11:53 AM
Fedora 6 / Gnome / Firefox.

These are my notes. HTH

NVU
download from
ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/testing/4/nvu/nvu-1.0-0.1.i386.rpm

INSTRUCIONS
mkdir ~/nvu
cd nvu
wget ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/testing/4/nvu/nvu-1.0-0.1.i386.rpm
sudo rpm -ivh --nosignature nvu-1.0-0.1.i386.rpmf

FreewayFred
4th January 2007, 01:08 AM
Thanks. Everything works.

rambutan
9th January 2007, 03:22 PM
I'm experimenting with CSS so I tried SeaMonkey's link to Cascade. I could not get it to work. I got the rpm for NVu from an earlier post. It installed without dependency problems. I see NVu also uses Cascade for CSS but in NVu it works.
For SeaMonkey I used gedit to create a CSS then used a "link rel" in the html and SeaMonkey displayed the correct styles. SeaMonkey + gedit + gfpt works, especially for simple web sites with simple CSS. If you want to limit your machine to software listed in "Add/Remove Software" this is a good choice.
NVu's CSS tool is much neater than gedit, even though it just makes a very simple text file. Since NVu is still the July 2005 release I wonder if it will keep breaking and needing restarts like in FC4. Time will tell.
Also check out BlueFish for generating CSS files. Their CSS properties and options are huge. You wont have to know the options like with gedit.

anonbeat
9th January 2007, 10:58 PM
Instead of NVU wich is old and not maintained you should consider Kompozer
http://kompozer.net/

KompoZer is the Nvu's unofficial bug-fix release.

bob
10th January 2007, 12:10 AM
Anonbeat, thanks for pointing that one out! It's a good, easy alternative. I just downloaded the Linux version to my /home and then extracted it. Once extracted, I chose to move the kompozer file to /usr/share and then to go to (gnome) Preferences > More Preferences > Menu Layout and add a new item under Programming. The icon I linked to /usr/share/kompozer/chrome/icons/default and then for the launcher, I used /usr/share/kompozer/kompozer It works fine.

rambutan
10th January 2007, 02:18 PM
Thank you anonbeat.
I downloaded KompoZer and like bob added an entry to my menu (FC6).
KompoZer uses KaZcadeS for CSS edits, looks like Cascades in NVu.
I don't yet see a way to edit the CSS directly like with BlueFish and gedit.
I look forward to using KompoZer and learning more about it and CSS.